Dell Unity: Příkaz ls zamrzl na klientovi RHEL 8.4 při připojení exportu Unity NFS prostřednictvím NFSv4 (oprava uživatelem)

Shrnutí: Příkaz ls zamrzl na klientovi RHEL 8.4 při připojení exportu Unity NFS prostřednictvím NFSv4.

Tento článek se vztahuje na Tento článek se nevztahuje na Tento článek není vázán na žádný konkrétní produkt. V tomto článku nejsou uvedeny všechny verze produktu.

Příznaky

Příkaz ls na klientovi Linux zamrzl. K problému dochází pouze u klienta RHEL 8.4 s verzí jádra starší než kernel-4.18.0-305.17.1.el8_4. 
 

Příčina

Problém je způsoben interakcí mezi serverem Unity NFS a klienty RHEL 8.4 s jádrem starším než kernel-4.18.0-305.17.1.el8_4.  Když server NFS odesílá nenulového ověřovače v odpovědi READDIR, klient NFS nadále odešle hodnotu 0 pro ověření souboru cookie v následném hovoru READDIR.  Výsledkem je nekonečná smyčka READDIR, která způsobí, že příkaz ls bude vždy viset. 

Řešení

Zástupné řešení: 
– Připojení exportu nfs prostřednictvím NFSv3.

Trvalá oprava:

- Z klientské strany je chybový procesor opraven v jádru 4.18.0-305.17.1.el8_4.

Podrobnosti naleznete ve verzi systému RHEL. 


https://access.redhat.com/errata/RHSA-2021:3447Klient NFS zamrzá na seznamu sdílených položek, když jsou implementováni ověřovatelé čtení na straně serveru (BZ#1993895)

K tomuto problému je také k dispozici článek databáze znalostí Redhat.



https://access.redhat.com/solutions/6189341 technický tým společnosti Dell Unity také zkoumá budoucí vylepšení kódu, která tento problém dále řeší. Jakmile bude k dispozici aktualizace, aktualizace se aktualizuje.

Dotčené produkty

Dell EMC Unity
Vlastnosti článku
Číslo článku: 000202521
Typ článku: Solution
Poslední úprava: 15 May 2026
Verze:  5
Najděte odpovědi na své otázky od ostatních uživatelů společnosti Dell
Služby podpory
Zkontrolujte, zda se na vaše zařízení vztahují služby podpory.