Falha no backup do PowerFlex Manager 3.x com o erro "Failed to Backup Database "

Shrnutí: O backup do PowerFlex Manager 3.x apresenta falha com o erro "Failed to Backup Database".

Tento článek se vztahuje na Tento článek se nevztahuje na Tento článek není vázán na žádný konkrétní produkt. V tomto článku nejsou uvedeny všechny verze produktu.

Příznaky

O backup do PowerFlex Manager 3.x apresenta falha com os seguintes erros:
AsmManager.log shows
2024-08-01 04:33:42 [JobMgrQuartzScheduler_Worker-56] (BackupDatabaseJob.java:122) [ERROR] Backup Database Job : Failed to Backup Database
2024-08-01 04:33:42 [JobMgrQuartzScheduler_Worker-56] (AsmDefaultJob.java:74) [ERROR] Backup Database Job : Failed to Backup Database
[vxfm-es-node-1] failed to put mappings on indices [[[snmp-traps-2024.07.31/9Kcv1tM0Tn2dN061eVfpLQ]]], type [snmptraps]
java.lang.IllegalArgumentException: Limit of total fields [2000] in index [snmp-traps-2024.07.31] has been exceeded

Příčina

Os backups não estavam em execução porque os índices cresciam muito rápido.

O comando abaixo mostra o índice do syslog crescendo rapidamente:
curl 'localhost:9200/_cat/indices?v'

Nota: Os índices de syslog apagados foram verificados novamente e continuaram a crescer em um ritmo acelerado.
 
Captura de tela dos índices syslog 

Řešení

Procedimento:
  1. Verifique o status dos índices com o seguinte comando:
curl 'localhost:9200/_cat/indices?v'
  1. Verifique o status e interrompa o serviço com os seguintes comandos:
systemctl status rsyslog

systemctl stop rsyslog
  1. Exclua os índices do syslog com o seguinte comando:
curl -X DELETE ' http://localhost:9200/syslog*'
  1. A execução do seguinte comando não mostra syslog porque o serviço foi interrompido:
curl 'localhost:9200/_cat/indices?v'
  1. Execute o backup novamente, e ele deve funcionar. Quando o backup for concluído, inicie o serviço:
systemctl start rsyslog

Para verificar o status ativo do progresso do backup, use o seguinte comando na CLI do PFxM:
tail -f /opt/Dell/ASM/logs/asmManager.log
Vlastnosti článku
Číslo článku: 000227742
Typ článku: Solution
Poslední úprava: 02 Jan 2026
Verze:  2
Najděte odpovědi na své otázky od ostatních uživatelů společnosti Dell
Služby podpory
Zkontrolujte, zda se na vaše zařízení vztahují služby podpory.