NetWorker: Backup von Windows 2012 schlägt für DISASTER_RECOVERY mit "save: Beim Speichern von Disaster-Recovery-Savesets ist ein Fehler aufgetreten.

Zusammenfassung: In diesem Artikel wird der Fehler des Saveset DISASTER_RECOVERY:\ während Windows 2012-Backups erläutert, der durch ein beschädigtes Windows WMI-Repository verursacht wird. NetWorker kann Systemherstellerdaten nicht über WMI abrufen, was zu dem Fehler führt. Das Problem wird durch das Reparieren oder Neuerstellen des WMI-Repositorys und das Aktualisieren des Windows-Clients behoben. ...

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Symptome

DISASTER_RECOVERY:\ Backup auf einem Windows 2012-Rechner schlägt fehl.
Alle anderen Savesets (z. B. Laufwerke, Ordner oder Dateien) werden erfolgreich abgeschlossen.

Die Savesets WINDOWS ROLES AND FEATURES und kritische Laufwerke werden erfolgreich gesichert.

Der einzige angezeigte Fehler ist

save: Error occured while saving disaster recovery save sets

Der letzte Eintrag in der Speicherausgabe lautet (kein Fehler angezeigt):

create_ossr_info_file: Calling get_system_manufacturer_info
Beim Ausführen des Backups in Debug-Level 5 werden die folgenden Fehler gegen Ende des Protokolls notiert:
machine_name: WINDOWS ROLES AND FEATURES:\ level=full, 6636 KB 00:00:02     21 files
Completed savetime=1442493321
09/17/15 14:35:23.961661 Unregistered session id:2, fd:1420, idx:1, ssn_max_pollfd:1, 1(512)
09/17/15 14:35:23.992862 nsr/libwinclass/ossr_sysinfo_xml.cpp: NULL pointer passed to disk_free_list()
09/17/15 14:35:23.992862 nsr/libwinclass/ossr_sysinfo_xml.cpp: NULL pointer passed to pool_free_list()
09/17/15 14:35:23.992862 nsr/libwinclass/ossr_sysinfo_xml.cpp: NULL pointer passed to volume_free_list()
09/17/15 14:35:23.992862 nsr/libwinclass/ossr_sysinfo_xml.cpp: NULL pointer passed to partition_free_list()
09/17/15 14:35:23.992862 nsr/libwinclass/ossr_sysinfo_xml.cpp: NULL pointer passed to adapter_free_list()
86024:save: Error occured while saving disaster recovery save sets.

Ursache

Während DISASTER_RECOVERY:\ Backups verwendet NetWorker die WMI (BS-Komponente), um Informationen zum Clientcomputer (z. B. Domainname, Hersteller, Computername und physischer Speicher) abzurufen, die dann in die DISASTER_RECOVERY:\ Metadaten. In diesem Fall ist das WMI des Computers beschädigt und NetWorker kann die Daten nicht aus WMI abrufen, was zu einem Backupfehler führt.

Das Problem liegt bei Windows WMI. Der Fehler tritt auf, wenn NetWorker eine WMI-Abfrage verwendet, um die Systemherstellerinformationen abzurufen, die mit dem DISASTER_RECOVERY:\ Saveset-Metadaten.
 
Das Ausführen des Befehls Get-WmiObject Win32_Computersystem von PowerShell schlägt mit einer ungültigen Vorgangsmeldung fehl. Um zu überprüfen, ob WMI beschädigt ist oder nicht, führen Sie den folgenden Befehl auf Windows PowerShell auf diesem Computer aus.
 
Eine gute Ausgabe sollte sein:
PS C:\> Get-WmiObject Win32_Computersystem

Domain         : emc.com
Manufacturer   : VMware, Inc.
Model          : VMware Virtual Platform
Name                : LIME
PrimaryOwnerName    : Windows User
TotalPhysicalMemory : 2146951168

Wenn eine andere Ausgabe ausgegeben wird, deutet dies darauf hin, dass WMI beschädigt ist und nicht in der Lage ist, auf die Betriebssystemaufrufe zu reagieren. Im Folgenden finden Sie ein Beispiel für eine beschädigte WMI:
PS C:\Users\Adam.Boesl> Get-WmiObject Win32_Computersystem
Get-WmiObject : Invalid class
At line:1 char:14
+ Get-WmiObject <<<<  Win32_Computersystem
    + CategoryInfo          : InvalidOperation: (:) [Get-WmiObject], ManagementException
    + FullyQualifiedErrorId : GetWMIManagementException,Microsoft.PowerShell.Commands.GetWmiObjectCommand

Lösung

Windows Server 2012-Backups werden in den NetWorker-Kompatibilitätsleitfäden als unterstützt aufgeführt. Lesen Sie die Kompatibilitätsleitfäden für Ihre NetWorker-Version: E-Lab Interoperability Navigator 2.0-HOME (Sie müssen sich mit Ihrem Dell Supportkonto anmelden).
Dieses Problem tritt jedoch unter Windows auf. Die Supportfunktionen sind für Probleme auf Betriebssystemebene auf Plattformen, die von ihrem Anbieter nicht mehr unterstützt werden, eingeschränkt.

Stellen Sie sicher, dass auf dem Client-Betriebssystem die neuesten Betriebssystemupdates installiert sind. Wenn die VSS-Backups (Volume Shadow Copy Service) weiterhin fehlschlagen, können Sie die VSS-Komponenten untersuchen. Die Untersuchung von VSS-Komponenten und die Betriebssystemfunktionen müssen vom Systemadministrator untersucht werden.  

Wenn das Betriebssystemproblem nicht behoben werden kann, führen Sie Backups von Dateisystemdaten des Clients ohne VSS durch.

  1. Konfigurieren Sie die Speichervorgänge des Clients, um Folgendes einzuschließen VSS:*=OFFverwalten:
    Sichern eines Windows-Clients ohne VSS 
    HINWEIS: Anzeigen –> Der Diagnosemodus muss in der NMC aktiviert sein, um die Einstellung für Speichervorgänge anzuzeigen.
  2. Aktualisieren Sie das Feld "Savesets" des Clients, um nur Dateien, Ordner oder Volumes einzuschließen. Zum Beispiel:
WARNUNG: Ohne VSS können Sie keine blockbasierten Backups (BBB) oder konsistente Backups DISASTER_RECOVERY:\ durchführen. Die Dateisystemdaten können ohne VSS gesichert werden. Eine Bare-Metal-Recovery (BMR) ist jedoch ohne DISASTER_RECOVERY:\-Backups nicht möglich.

Weitere Informationen

Betroffene Produkte

NetWorker

Produkte

NetWorker
Artikeleigenschaften
Artikelnummer: 000018662
Artikeltyp: Solution
Zuletzt geändert: 27 Apr. 2026
Version:  5
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