ECS: Dial Home – Ref_ID: Ablauf von EKMServerCertificateExpiry – Symptomcodes: 1361 und 1362

Zusammenfassung: Dies ist ein in ECS 3.3 eingeführtes Dial-Home, um Warnung.

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Symptome

Key-Management:
     Zur Unterstützung der Data-at-Rest-Verschlüsselung (D@RE) verwaltet ECS eine Hierarchie von Verschlüsselungsschlüsseln, wobei ein übergeordneter Schlüssel in der Hierarchie verwendet wird, um einen untergeordneten Schlüssel zu schützen. Vor ECS 3.3 wurden diese Schlüssel nativ von ECS in der Geo-Verbundumgebung gemanagt. Ab ECS 3.3 wurde die Unterstützung für bestimmte externe Key-Management-Lösungen hinzugefügt, die KMIP-konform (Key Management Interoperability Protocol) sind. Zusätzlich zur Unterstützung von Branchenstandards unterstützt ECS 3.3 jetzt die vom Nutzer initiierte Schlüsselrotation, um die Menge der durch einen bestimmten Schlüssel geschützten Daten zu begrenzen. (Weitere Informationen finden Sie im Admin-Guide)

Ein ECS-System hat Dialed Home mit der folgenden Warnmeldung ausgeführt.
 
Symptomcode Schweregrad
1361 WARNING
1362 FEHLER
<?xml version="1.0" encoding="UTF-8"?>
<ConnectHome SchemaVersion="1.0.8"
    xsi:schemaLocation="/opt/connectemc/schema/ema_ConnectHome108.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <TransType>10</TransType>
    <TransTypeDesc>EventXML</TransTypeDesc>
    <TransID>0</TransID>
    <Node Status="Unknown" State="Unknown" ID="ECSQE00079">
        <Identifier>
            <DeviceState>1</DeviceState>
            <DeviceStatus>1</DeviceStatus>
            <ClarifyID>ECSQE00079</ClarifyID>
            <SiteName>UNKNOWN</SiteName>
            <Vendor>EMC</Vendor>
            <DeviceType>ElasticCloudStorageApp</DeviceType>
            <Model>ElasticCloudStorage</Model>
            <SerialNumber>ECSQE00079</SerialNumber>
            <WWN>ECSQE00079</WWN>
            <Platform>platform</Platform>
            <OS>SLES</OS>
            <OS_VER>12.3</OS_VER>
            <UcodeVer>3.3.0.0-4349.d0de882</UcodeVer>
            <EmbedLevel>2</EmbedLevel>
            <InternalMaxSize>512800</InternalMaxSize>
            <Comment>Object Alert</Comment>
        </Identifier>
        <Connection>
            <ConnectType>ESRS</ConnectType>
            <IPName>localhost</IPName>
            <ConnectNum>XXX.XXX.XXX.XXX</ConnectNum>
            <Port>22</Port>
        </Connection>
        <HeartBeat>
            <HBStatus></HBStatus>
            <HBState></HBState>
        </HeartBeat>
        <InternalData>
            <FileList/>
            <EventList>
                <Event>
                    <SymptomCode>1362</SymptomCode>
                    <Category>Configuration</Category>
                    <Severity>Error</Severity>
                    <Status>Unknown</Status>
                    <Component>Object</Component>
                    <ComponentID></ComponentID>
                    <SubComponent>EKM Server Certificate Expiry</SubComponent>
                    <SubComponentID></SubComponentID>
                    <CallHome>true</CallHome>
                    <FirstTime>2019-01-29T06:44:21.014Z</FirstTime>
                    <LastTime>2019-01-29T06:44:21.014Z</LastTime>
                    <Count>0</Count>
                    <EventData><![CDATA[]]></EventData>
                    <Description><![CDATA[The Server Certificate for EKM Server : ecs-dev-keysecure-10.XXX.XXX.XXX will expire in 3533 days 17 hours 15 minutes 53 seconds  [Ref_ID : EKMServerCertificateExpiry]]]></Description>
                </Event>
            </EventList>
        </InternalData>
        <ExternalFiles/>
    </Node>
</ConnectHome>

 

Ursache

Das Serverzertifikat für den EKM-Server läuft in 7 Tagen ab. Erneuern Sie das Zertifikat.

Lösung

  1. Stellen Sie über eine PuTTY-Sitzung eine Verbindung zu einem der Nodes im Cluster her.
  2. Überprüfen des aktuellen Sensorstatus
  3. Suchen Sie nach dem Wert des CurrentState-Tags <> in der obigen Ausgabe. Die Bedingung ist nicht aktiv, wenn der gemeldete Wert "OK" ist. Die Werte "Warning" oder "Error" weisen darauf hin, dass das Problem bereits besteht und Schritte zur Fehlerbehebung erforderlich sind.
  4. Überprüfen Sie die Warnmeldung für den Abschnitt "Beschreibung", um den betroffenen EKM-Server und das Ablaufdatum des Zertifikats zu erfassen.
  5. Nehmen Sie die Serverinformationen und das Ablaufdatum, die im vorherigen Schritt gesammelt wurden, und stellen Sie diese dem Kunden zur Verfügung, damit er das Zertifikat erneuern kann. Dies muss auf dem EKM-Server des Kunden durchgeführt werden.
  6. Sobald der Kunde über das neue Zertifikat verfügt, muss er ECS damit aktualisieren. Die Schritte finden Sie im Administrationshandbuch im Abschnitt Key-Management unter ECS-Einstellungen.
  7. Wenn das Problem weiterhin besteht, öffnen Sie einen Service-Request an den ECS-Support von Dell Technologies, um das Problem zu untersuchen.
svc_rest_cmd /vdc/sensor/status/EKMServerCertificateExpiry
 

Beispiel:
admin@provo-cream:~> svc_rest_cmd /vdc/sensor/status/EKMServerCertificateExpiry
svc_rest_cmd 1.0.10

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<SensorStatusList>
  <SensorId>EKMServerCertificateExpiry</SensorId>
  <ListSensorStatus>
    <SensorStatusRestRep>
      <ContextId>EKMServerCertificateExpiry</ContextId>
      <CurrentState>OK</CurrentState>
      <NodeId>1f4368c3-37cd-467f-9efc-289264806ea0</NodeId>
      <PreviousState>OK</PreviousState>
      <Time>1551118064264</Time>
    </SensorStatusRestRep>
  </ListSensorStatus>


    Beispiel: 
<Description><![CDATA[The Server Certificate for EKM Server : ecs-dev-keysecure-10.XXX.XXX.XXX will expire in 3533 days 17 hours 15 minutes 53 seconds  [Ref_ID : EKMServerCertificateExpiry]]]></Description>

 

Betroffene Produkte

ECS Appliance

Produkte

ECS Appliance, ECS Appliance Hardware Gen1 U-Series, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption, Elastic Cloud Storage
Artikeleigenschaften
Artikelnummer: 000037612
Artikeltyp: Solution
Zuletzt geändert: 17 Dez. 2025
Version:  5
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