NetWorker:管理「Message bus unable to open socket connection」にエラーが表示される

Zusammenfassung: NetWorker管理でワークフローの詳細を表示すると、「Message bus unable to open socket connection to host "Networkerserver_hostname"on port 5672: ソケット エラーが発生しました。」

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

NETWorker Management Console(NMC)サーバーは、NetWorkerサーバーとは別のスタンドアロン システムにインストールされます。

 

NMCモニタリング ウィンドウには、すべてのポリシーが「実行しない」と [実行しない]アイコン表示されますが、バックアップ ジョブとクローン ジョブはスケジュールどおりに完了しています。

 

ワークフローまたはアクションのプロパティを開こうとすると、NMCに次のエラーが表示されます。

Message bus unable to open socket connection to host "Networkerserver_hostname" on port 5672: a socket error occurred.

 

ソケット接続に関するエラー メッセージ
図1: ソケット接続に関するエラー メッセージ

 

ポート5671がNetWorkerサーバーをリスンしています。ポート5671は、メッセージ キュー アダプター プロセスで使用されるSSLポートです。

Linux: netstat -apno | grep 5671

Windows: netstat -ano | findstr 5671

 

NetWorkerサーバーでポート5672が有効になっていません。ポート5672は、メッセージ キュー アダプター プロセスで使用される非SSLポートです。

メモ: NetWorker 19.6以降では、ポート5672(非SSL)はデフォルトで無効になっています。

 

NMCサーバーは、ポート5671を介してNetWorkerサーバーに接続できません。

Linux: curl -v NetWorker_ServerName:5671

Windows (PowerShell): tnc NetWorker_ServerName -port 5671

 

Ursache

ポート5671は、NMC(NetWorker Management Console)サーバーとNetWorkerサーバー間の通信に使用されるメッセージ キュー アダプターによって使用されるSSLポートです。

この問題は、NetWorkerサーバーでポート5671がブロックされている場合に発生します。

 

Lösung

  1. NetWorkerサーバーで、ポート5671のトラフィックを許可するインバウンド ファイアウォール ルールを作成します。
  2. NMCサーバーで、ポート5671からのトラフィックを許可するアウトバウンド ルールを作成します。

 

ファイアウォール ルールを作成するためのオペレーティング システム ベンダーの手順を参照してください。システム管理者またはセキュリティ管理者がこれらの変更を行う必要があります。オペレーティング システムのファイアウォールに変更が適用されたら、NetWorkerサーバーとNMCサーバー間のポート5671接続が成功するかどうかを確認します。それでも接続が失敗する場合は、ネットワーク ファイアウォールが通信をブロックされていないことを確認します。

 

Weitere Informationen

Betroffene Produkte

NetWorker

Produkte

NetWorker Family, NetWorker Series
Artikeleigenschaften
Artikelnummer: 000210569
Artikeltyp: Solution
Zuletzt geändert: 23 Jan. 2024
Version:  5
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.