ЕКС: Додаток Oracle RMAN зіткнувся з помилкою HTTP 501 Не реалізовано після оновлення до ECS 3.8.0.1 - 3.8.0.4
Zusammenfassung: У зв'язку з регресією ECS, програма резервного копіювання Oracle Recovery Manager (RMAN) може зіткнутися з помилкою HTTP 501 "Not Implemented" після оновлення до ECS 3.8.0.1 - 3.8.0.4.
Dieser Artikel gilt für
Dieser Artikel gilt nicht für
Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden.
In diesem Artikel werden nicht alle Produktversionen aufgeführt.
Symptome
Після оновлення до ECS 3.8.0.1 - 3.8.0.4 запити додатків можуть завершуватися помилкою HTTP "501 Not Implemented", якщо всі параметри, що використовуються в запиті, не входять до внутрішнього підтримуваного списку ECS.
Помилка, помічена на RMAN:
Перевірити проблему на ECS:
Command:
Приклад:
Взявши за приклад requestID, далі простежте помилку, як показано нижче:
Команда:
- Підтверджено, що ця проблема вплинула на програму резервного копіювання Oracle Recovery Manager (RMAN).
- Проблема впливає на Oracle RMAN, якщо ви пишете безпосередньо в ECS. Якщо Oracle RMAN напише в ECS через іншу програму, то це не вплине на неї.
- Це може вплинути на інші програми, якщо вони використовують подібну конфігурацію, де всі параметри запиту не є частиною підтримуваного списку.
Помилка, помічена на RMAN:
RMAN-03009: failure of backup command on ORA_SBT_TAPE_1 channel at 11/20/2023 15:15:13 ORA-19506: failed to create sequential file, name="DB_FIP_20231120_mj2bv7g0_503507_1_1", parms="" ORA-27028: skgfqcre: sbtbackup returned error ORA-19511: non RMAN, but media manager or vendor specific failure, error text: KBHS-01404: See trace file /soft/oracle19/diag/rdbms/fip/fip/trace/sbtio_25047_140117933847552.log for details KBHS-00700: HTTP response error 'Not Implemented'
Перевірити проблему на ECS:
Command:
svc_log -f "does not support operation with signature B" -start '<Timeline errors received in ECS> -sr dataheadsvc -n all -sf
Приклад:
# svc_log -f "does not support operation with signature B" -start '1 hours ago' -sr dataheadsvc -n all -sf svc_log v1.0.31 (svc_tools v2.14.0) Started 2023-11-22 15:34:17 Running on nodes: <All nodes> Time range: 2023-11-21 03:34:17 - 2023-11-22 15:34:17 Filter string(s): 'does not support operation with signature B' Show filename(s): True Show nodename(s): True Search reclaim logs (if any): False 169.254.1.5 dataheadsvc.log.20231121-134402.gz 2023-11-21T12:01:51,006 [qtp379782668-6225-88a5e8cf:18bedd2e9f0:d5e:4-s3-136.165.238.100] ERROR S3Service.java (line 638) does not support operation with signature B?not-implemented, request Id 88a5e8cf:18bedd2e9f0:d5e:4
Взявши за приклад requestID, далі простежте помилку, як показано нижче:
Команда:
# svc_log -f "request ID highlighted from previous step" -sr dataheadsvc dataheadsvc-access -start <Timeline of requestID> -sfПриклад:
#svc_log -f "88a5e8cf:18bedd2e9f0:d5e:4" -sr dataheadsvc dataheadsvc-access -start 1h -sf svc_log v1.0.31 (svc_tools v2.14.0) Started 2023-11-22 15:45:40 Running on nodes: <All nodes> Time range: 2023-11-21 03:45:40 - 2023-11-22 15:45:40 Filter string(s): '88a5e8cf:18bedd2e9f0:d5e:4' Show filename(s): True Show nodename(s): True Search reclaim logs (if any): False <output truncated> . . 169.254.1.5 dataheadsvc.log.20231121-134402.gz 2023-11-21T12:01:51,006 [qtp379782668-6225-88a5e8cf:18bedd2e9f0:d5e:4-s3-136.165.238.100] ERROR S3Service.java (line 638) does not support operation with signature B?not-implemented, request Id 88a5e8cf:18bedd2e9f0:d5e:4 169.254.1.5 dataheadsvc-access.log 2023-11-21 12:01:51,007 88a5e8cf:18bedd2e9f0:d5e:4 136.165.232.207:9020 136.165.238.100:4249 dba-rman-prod - HEAD ul-rman-prod ul-rman-prod-01 ul-rman-prod-01 format=xml&x-BlockSize=262144&x-CopyNumber=0&x-Dbid=808640723&x-Dbname=RCAT&x-FileName=DB_RCAT_20231121_1i2c0uuu_63538_1_1&x-Incarnation=fpC63dLILKPb&x-NetTest=FALSE&x-Node=node1.hostname&x-OpenTime=2023-11-21%2012%3A01%3A51 &x-ReqCnt=34&x-ReqTime=2023-11-21%2012%3A01%3A51&x-SbtApi=sbtbackup&x-SbtOp=BeginUpload&x-SbtVersion=19.0.0.1&x-SessionId=0AA9580D05342089E063F7EDA5880453&x-System=Linux%20x86%2064-bit&x- SystemId=13&x-User=oracle HTTP/1.1 501 2 - - 1 - - - - 'x-amz-date: 20231121T120151Z' 'Connection: close' 'X-Amz-Content-SHA256: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855' . . <output truncated>
Ursache
Ця проблема пов'язана з регресією, запровадженою в ECS STORAGE-28517.
- Якщо програма не використовує жодних параметрів, вона не стикається з помилкою HTTP 501.
- Якщо програма використовує параметри:
- Якщо використовується принаймні один параметр зі списку підтримуваних параметрів (нижче), помилки HTTP 501 не відображаються.
- Якщо всіх параметрів, які використовуються в запиті, немає в списку підтримуваних параметрів, повідомляється про помилку HTTP 501.
| "acl", "життєвий цикл", "object-lock", "enable-object-lock", "location", "logging ", "notification", "policy", "requestPayment", "torrent", "delete", "uploadId", "uploads", "versioning", "versions", "website", "tagging", "cors", "accessmode", "fileaccess", "ping", "cors", "endpoint", "isstaleallowed", "query", "replication", "replicationInfo", "legal-hold", "retention ", "retentionUpdate", "searchmetadata", "snapshot", "snapshots", "snapshotId", "empty-bucket-status", "select", "detailedReplicationStatus" |
Lösung
Проблему вирішено, починаючи з ECS 3.8.0.5.
- Якщо ця проблема вплинула на неї після оновлення до ECS 3.8.0.1–3.8.0.4, зверніться до служби технічної підтримки, щоб отримати виправлення.
- Якщо ви використовуєте Oracle RMAN і плануєте оновитися до ECS 3.8.0.1 - 3.8.0.4, повідомте про це Служби, плануючи оновлення, щоб вони запросили спеціальний патч для використання для оновлення. Цей спеціальний патч виправить цю проблему.
ПРИМІТКА: Оскільки проблему вирішено в новішому коді, рекомендується оновитися до версії з виправленням.
Betroffene Produkte
ECS, ECS Appliance, ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Gen 3, ECS Appliance Hardware Series, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption, ECS Software, Elastic Cloud StorageArtikeleigenschaften
Artikelnummer: 000219799
Artikeltyp: Solution
Zuletzt geändert: 11 März 2024
Version: 8
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.