PowerFlex:MSSQL 2019备份失败并报告数据损坏或不一致

Zusammenfassung: 使用 Windows 2019 SDC 并运行 Microsoft SQL 2019 备份时,备份失败并报告数据损坏或不一致 (DI)。

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

  • 安装了 SDC 的 Windows 2019(提醒:RDM/VMDK 磁盘设备不受影响)。
  • PowerFlex 动态校验和功能已启用。
  • Microsoft SQL 2019 备份失败,并显示错误:
    The log scan number (0:-1218248704:37) passed to log scan in database 'TEST_VOL' is not valid. This error may indicate data corruption or that the log file (.ldf) does not match the data file (.mdf). If this error occurred during replication, re-create the publication. Otherwise, restore from backup if the problem results in a failure during startup."
  • PowerFlex 跟踪(MDM、SDS 和 SDC)未指示任何问题。

 

提醒:此问题是在 Microsoft SQL 2019 备份失败期间发现的,但可能会影响其他 Windows 应用程序。

 

影响

Microsoft SQL 2019 备份失败
对数据或任何实际数据损坏或 DI 都没有实际影响。

 

Ursache

SDC 组件中的软件代码问题,特别是动态校验和功能

启用动态校验和后,Windows SDC 会在校验和计算期间更改 FPU 状态,并且不会将其还原,这会导致 FPU 指令的其他用户(在本例中为 MSSQL 应用程序)收到意外结果。

 

Lösung

要解决此问题,应禁用动态校验和。

如果解决方法不可行,请升级到下面的“版本内修复”部分中提到的修复版本。该修复包括一个校验和计算流程,该流程将在计算校验和之前保存 FPU 状态,并在计算完成后还原它。

 

受影响的版本

PowerFlex 3.xPowerFlex
4.x

 

已修复问题的版本

PowerFlex 3.6.5PowerFlex
4.5.3

 

Betroffene Produkte

PowerFlex rack, PowerFlex Appliance, PowerFlex custom node, PowerFlex Software
Artikeleigenschaften
Artikelnummer: 000224854
Artikeltyp: Solution
Zuletzt geändert: 30 Dez. 2025
Version:  6
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.