Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Ghost Imaging on Skylake/Thunderbolt Systems

Summary: Steps for imaging with Ghost Skylake/Thunderbolt computers.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

No symptoms information.

Cause

No cause information.

Resolution

Note: This process requires a good working knowledge of the Ghost imaging process. If you require information about how to use Ghost products, contact Symantec support SLN301402_en_US__2iC_External_Link_BD_v1 for additional information. This information is provided for your convenience and does not imply that Dell will provide support for this imaging process.

Prepare the Windows 10 Ghost PE

  1. Download: Windows 10 Assessment and Deployment Kit (ADK) 1511 installation path and choose the Install Path for installation (Figure 1 [English only]):

    select features to install
    Figure 1
  2. Select Deployment Tools and Windows PE from the list of features to install (Figure 2 [English only]):

    SLN301402_en_US__5Ghost-imaging-prep-2
    Figure 2
  3. Download and install the 7-Zip utility from the following location: 7-Zip Utility SLN301402_en_US__2iC_External_Link_BD_v1.
  4. Download the Windows 10 PE CAB file from the following location at the Dell Techcenter: Windows 10 PE CAB.
  5. Extract the Windows 10 PE CAB file to a temp directory such as C:\DC\temp\Win10PECAB.
  6. Download the ASBmedia USB 3.0 Drivers.
  7. Extract to c:\dc\temp\pws5510\usba
  8. Download the Thunderbolt Controller Drivers.
  9. Extract to c:\dc\temp\pws5510\TBT
  10. Download the Realtek USB Thunderbolt Ethernet Driver.
  11. Extract to c:\dc\temp\pws5510\RTLUSB.
  12. Make a new directory c:\dc\temp
  13. Make a new directory c:\dc\temp\pe10
  14. Make a new directory c:\dc\temp\mount
  15. Open the Deployment and Imaging Tools Environment as Administrator (Figure 3 [English only]).

    run as admin
    Figure 3
    Note: Use a clean version of Windows 10 PE x86 located here:

    C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Windows Preinstallation Environment\x86\en-us
  16. Copy the winpe.wim to a temp directory such as c:\dc\temp
  17. Use dism to mount the winpe.wim in a temp directory:
    1. dism /mount-wim /wimfile:c:\dc\temp\pe10\winpe.wim /index:1 /mountdir:c:\dc\temp\mount
    2. dism /image:c:\dc\temp\mount /add-driver:c:\dc\temp\win10pecab\x86 /recurse /forceunsigned
    3. dism /image:c:\dc\temp\mount /add-driver:c:\dc\temp\pws5510\usba\Driver_Win10 /recurse /forceunsigned
    4. dism /image: c:\dc\temp\mount /add-driver:c:\dc\temp\pws5510\TBT /recurse /forceunsigned
    5. dism /image: c:\dc\temp\mount /add-driver:c:\dc\temp\pws5510\RTLUSB\Windows\WIN10\32 /recurse /forceunsigned
    6. Copy Ghost32.exe 11.5.1 (build 2269 or later) to c:\dc\temp\mount\GHOST
    7. dism /unmount-image /mountdir:c:\dc\temp\mount /commit
  18. Import the winpe.wim file at c:\dc\temp\pe10 to WDS or your USB key as sources\boot.wim.

Prepare the operating system for Ghosting

On the target machine:

  1. Install the Windows operating system and all updates and drivers.
  2. Shrink the partition of the Windows drive but leave 2048 MB for the Sysprep OOBE process when you restore the image (Figure 4 [English only]):

    SLN301402_en_US__9Ghost-imaging-1
    Figure 4
    • Right click on the C: Partition
    • Choose Shrink Volume (Figure 5 [English only]).

      SLN301402_en_US__10Ghost-imaging-2
      Figure 5
      • Subtract 2048 from the amount of space to shrink (Figure 6 [English only]):

        SLN301402_en_US__11Ghost-imaging-3
        Figure 6
  3. Run Sysprep with Generalize, OOBE, and Quit (Figure 7 [English only]).

    SLN301402_en_US__12Ghost-imaging-4
    Figure 7
    Note: Some drivers may not sysprep properly and should be uninstalled prior to sysprepping.
    If you receive errors in the sysprep process, a setuperr.log is in Windows\System32\Sysprep\Panther
  4. Restart the computer and start the PXE/USB process (Figure 8 [English only]).

    SLN301402_en_US__14Ghost-imaging-5
    Figure 8
Note: If you do not see Ghost32 start up when you issue the X:\ghost\Ghost32.exe command in PE: Ghost32.exe stops responding in a WinPE Pre-OS on machines with Intel AHCI Mass Storage Devices https://support.symantec.com/en_US/article.TECH123534.html

Article Properties


Last Published Date

10 Feb 2023

Version

5

Article Type

Solution