Dell Unity: Nonspecific error in UI while uploading Unity OE code for upgrade (Dell Correctable)

Summary: A blank upload error appears in the Unisphere dialog with no specific error message or error code.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Below error is seen on Unity Unisphere while uploading OE code for upgrade:
 
Upload Error

Cause

This is a UI issue where the UI does not correctly handle HTTP 500 or HTTP 409 errors for the REST request.
 

409 Conflict:
This response is sent when a request conflicts with the current state of the server.

500 Internal Server Error:
The server has encountered a situation it doesn't know how to handle.

Resolution

Workaround:

  • Upload the upgrade image using uemcli command rather than from UI: 
uemcli -upload -f Unity-xxx.tgz.bin.gpg upgrade

Or

  • Upload the upgrade image from a system that is on the same subnet as the Unity array.


Resolution:
The fix for this issue is expected to be in the 5.2 release. 

Affected Products

Dell EMC Unity
Article Properties
Article Number: 000190184
Article Type: Solution
Last Modified: 12 Dec 2025
Version:  4
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