VxRail. После замены диска физическое представление в подключаемом модуле VxRail отображает разъем для диска как неуправляемый, а конфигурацию диска — пустой

Summary: После замены диска в физическом представлении в подключаемом модуле VxRail слот диска отображается как неуправляемый, а конфигурация диска пуста.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

После замены диска в физическом представлении в подключаемом модуле VxRail слот диска отображается как неуправляемый, а конфигурация диска пуста:

проблема 1. Замена диска выполняется с помощью обычного процесса VMware не из физического представления VxRail, что устраняет сбой сменного диска.
Вопрос 2: В физическом представлении VxRail теперь отображается диск с неправильным серийным номером, когда диск отсутствует.
Вопрос 3: После устранения указанных выше проблем в физическом представлении слот диска отображается как неуправляемый, а конфигурация диска пустая.

Cause

Замена диска была выполнена с использованием неподдерживаемого метода — всегда следует использовать подключаемый модуль VxRail.
Полный vxnode.config файл должен иметь сегмент диска, сегмент PSU, local_slot_claims Сегмент, Disk_group_options сегмент disk_group_type сегмент. Переменная local_slot_claims или disk_group_options или и то, и другое должно присутствовать в этом файле. Если ни один из них не выходит, он регенерируется из hardware-model-specs.json.

Resolution

Выполните следующие команды в VxRail Manager с пользователем root, чтобы обновить файл ESXi vxnode.config новым серийным номером диска/блока питания и информацией о слоте. Замените <имя> хоста ESXi и <пароль> root ESXi реальным значением.


Чтобы обновить сведения о диске, выполните следующие действия.

curl -X POST --unix-socket /var/lib/vxrail/nginx/socket/nginx.sock http://127.0.0.1/rest/vxm/internal/do/v1/hosts/baseline-update -H 'Content-Type: application/json' -d '[{"hostname":"<ESXi hostname>", "username":"root","password":"<ESXi root password>", "update_disk":true}]'


Чтобы обновить информацию о блоке питания, выполните следующие действия.

curl -X POST --unix-socket /var/lib/vxrail/nginx/socket/nginx.sock http://127.0.0.1/rest/vxm/internal/do/v1/hosts/baseline-update -H 'Content-Type: application/json' -d '[{"hostname":"<ESXi hostname>", "username":"root","password":"<ESXi root password>", "update_psu":true}]'

Перезапустите службы в VxRail Manager

systemctl restart vmware-marvin

systemctl restart runjars

 

Примечание.
  • Если при выполнении команды curl возникает ошибка, проверьте iDRAC, если указаны в списке блоки питания. Если нет (в отчете TSR также указано, что блоки питания отсутствуют), перезагрузите или сбросьте iDRAC и убедитесь, что блоки питания указаны в списке после этого (в следующем отчете TSR также должны отображаться блоки питания).
  • Если команда curl baseline-update возвращает значение 200 success, но файл vxnode.config не обновляется, просмотрите short.term.log в диспетчере VxRail, чтобы выявить проблемы. Возможная причина заключается в том, что сервис платформы на узле не запущен. Можно сбросить iDRAC и перезапустить службу платформы, чтобы проверить, может ли она восстановить работоспособность службы, а затем снова выполнить команду baseline-update.

Affected Products

VxRail Appliance Family, VxRail Appliance Series, VxRail G Series Nodes, VxRail D Series Nodes, VxRail D560, VxRail D560F, VxRail E Series Nodes, VxRail E560, VxRail E560F, VxRail E560N, VxRail E660, VxRail E660F, VxRail E660N, VxRail E665 , VxRail E665F, VxRail E665N, VxRail G560, VxRail G560F, VxRail P Series Nodes, VxRail P570, VxRail P570 VCF, VxRail P570F, VxRail P580N, VxRail P670F, VxRail P670N, VxRail P675F, VxRail P675N, VxRail S Series Nodes, VxRail S570, VxRail S670, VxRail V Series Nodes, VxRail V570, VxRail V570F, VXRAIL V670F, VxRail VD-4510C, VxRail VD-4520C, VxRail VP-760, VxRail VP-7625, VxRail VS-760 ...
Article Properties
Article Number: 000196355
Article Type: Solution
Last Modified: 07 Nov 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.