PowerProtect Data Manager. Сбой обнаружения кластера Kubernetes — исключение ввода-вывода при следующем методе (поток был сбросить)

Summary: Сбой обнаружения кластера Kubernetes в PowerProtect Data Manager — исключение ввода-вывода при следующем методе (поток был сбросить).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Сбой обнаружения кластера Kubernetes в PowerProtect Data Manager.
В файле cndm.log наблюдается следующая ошибка:
2023-03-23T03:32:43.470Z ERROR [] [https-jsse-nio-127.0.0.1-8461-exec-3] [][][][TRACE_ID:9a9664af3ecde3e2;JOB_ID:9d8702e6e8798fea][] [c.e.b.c.d.s.CndmDiscoveryService.start(84)] -  discovery task failed
com.emc.brs.cndm.error.InternalServerErrorException: java.lang.RuntimeException: IO Exception during next method.
Caused by: java.lang.RuntimeException: IO Exception during next method.
Caused by: okhttp3.internal.http2.StreamResetException: stream was reset: INTERNAL_ERROR

Cause

Продукт работает должным образом.

Resolution

В одном случае, когда это наблюдается, между PowerProtect Data Manager и кластером K8s имеется сервер Nginx. 

Измените следующие параметры в файле конфигурации Nginx /etc/nginx/default.d/server.conf
, proxy_redirect отключения.
proxy_buffering отключения;


После этого изменения обнаружение кластера PPDM Kubernetes выполняется нормально. 

Affected Products

PowerProtect Data Manager
Article Properties
Article Number: 000212870
Article Type: Solution
Last Modified: 18 May 2023
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.