SQL Server service (MSSQLSERVER) Fails to Start

Summary: The Microsoft SQL Server service (MSSQLSERVER) may fail to start due to a corrupt database. This article illustrates the process of troubleshooting this issue.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The Microsoft SQL Server service (MSSQLSERVER) fails to start. Error 7024 (source: Service Control Manager) appears in the System event log of the server where SQL is installed.

Cause

This service may fail to start for multiple reasons, and this article addresses one: a corrupt database.

Resolution

When any service fails to start, the Service Control Manager logs an error in the System event log of the server hosting that service. This event (ID 7024 in this case) may or may not provide enough detail to troubleshoot the issue. When troubleshooting an issue with the SQL Server service, the SQL error log likely contains more useful information.

To locate the SQL error log, follow these steps:
  1. Launch SQL Server Configuration Manager.
  2. Select SQL Server Services in the left pane.
  3. In the center pane, right-click SQL Server (MSSQLSERVER) and select Properties.
  4. In the properties window, select the Startup Parameters tab.
  5. In the Existing parameters field, the entry beginning with -e contains the path to the error log.
In File Explorer, browse to the path given above. The ERRORLOG file with no extension is the current error log. (ERRORLOG files with numeric extensions are older logs.) Open the current log file in Notepad and scroll to the end of the file. The last entry in the log should be an error indicating the reason for the service failure.

An error similar to this can indicate a corrupt database:

SQL Server detected a logical consistency-based I/O error: Incorrect checksum

The error message also indicates which database experienced the problem. There are three system databases required for SQL services to start: the master database, the model database, and tempdb. The error most likely mentions one of these databases.

If corruption in the master database is the cause, restoring that database from a backup is the recommended solution.

If corruption in the model database is the cause, a repair procedure can be found in SQL Server Model Database Repair.

The tempdb database is re-created every time the SQL Server service starts, if the model database is intact.

Additional Information

See this video for a demonstration:

You can also view this video on YouTube.

Affected Products

Prosupport for Microsoft Software
Article Properties
Article Number: 000223030
Article Type: Solution
Last Modified: 23 Jan 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.