ElasticSearch 문제로 인해 PowerFlex 3.x에서 4.x로의 업그레이드 실패 데이터베이스 백업 실패

Summary: 이 문서에서는 백업 실패 및 ElasticSearch 문제로 인한 3.x에서 4.x로의 업그레이드 실패를 해결하는 방법을 설명합니다.

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Symptoms

가져오기 절차 중에 PowerFlex 3.x에서 4.x로의 업그레이드가 실패하고 이전 PowerFlex 3.8.3의 데이터베이스 백업이 트리거되어 실패합니다.

 

2025-05-21 15:10:06,299 INFO [backup-1,tid=252] (BackupApplianceCallable.java:216): Executing the script: /opt/Dell/scripts/backup-elasticsearch.py
2025-05-21 15:10:16,779 DEBUG [backup-1,tid=252] (ExecuteSystemCommands.java:103): Last login: Wed May 21 15:10:01 CEST 2025 on cron
2025-05-21 15:10:16,780 ERROR [backup-1,tid=252] (ExecuteSystemCommands.java:127): Non-zero return code running OS command /usr/bin/sudo /opt/Dell/scripts/backup-elasticsearch.py: 3
2025-05-21 15:10:16,781 ERROR [backup-1,tid=252] (ExecuteSystemCommands.java:128): Console output running OS command: Last login: Wed May 21 15:10:01 CEST 2025 on cron
2025-05-21 15:10:16,781 ERROR [backup-1,tid=252] (BackupApplianceCallable.java:225): Error executing the script /opt/Dell/scripts/backup-elasticsearch.py: rc=3
2025-05-21 15:10:16,781 ERROR [backup-1,tid=252] (BackupApplianceCallable.java:246): Unable to backup the database. com.dell.asm.i18n2.exception.AsmCheckedException: The appliance cannot be backed because of an unknown exception.
2025-05-21 15:10:16,785 INFO [backup-1,tid=252] (BackupApplianceCallable.java:73): Executing the script /opt/Dell/scripts/backup-clean.sh

 

ASM Manger 로그
 

Line 16272: 2025-05-21 11:32:50,308 DEBUG [backup-1,tid=245] (ExecuteSystemCommands.java:103): rm: cannot remove ‘/var/es-backup/indices’: Directory not empty
Line 16276: 2025-05-21 11:32:50,315 ERROR [backup-1,tid=245] (ExecuteSystemCommands.java:128): Console output running OS command: rm: cannot remove ‘/var/es-backup/indices’: Directory not emptyCleanup of /var/es-backup failed with RC=1Last login: Wed May 21 11:32:35 CEST 2025
Line 18203: 2025-05-21 12:02:54,161 DEBUG [backup-1,tid=245] (ExecuteSystemCommands.java:103): rm: cannot remove ‘/var/es-backup/indices’: Directory not empty
Line 18207: 2025-05-21 12:02:54,165 ERROR [backup-1,tid=245] (ExecuteSystemCommands.java:128): Console output running OS command: rm: cannot remove ‘/var/es-backup/indices’: Directory not emptyCleanup of /var/es-backup failed with RC=1Last login: Wed May 21 12:02:37 CEST 2025

Cause

ElasticSearch 데이터 문제  

Resolution

명령은 delladmin 계정을 사용하여 PowerFlex Manager CLI에서 실행됩니다.

 

1단계 = 탄력적 검색 데이터베이스의 공간 확보(최대 크기는 5G여야 함)

   

  • curl 'localhost:9200/_cat/indices?v’

 

snmp 트랩 인덱스가 많은 경우 문제가 없는 경우 이전 트랩을 삭제해도 됩니다.

 

  • curl -X DELETE localhost:9200/snmp-traps-YYYY.MM.DD (this deletes a specific date)

 

또는 아래 명령으로 모두 삭제할 수 있습니다.

 

  • curl -X DELETE 'http://localhost:9200/syslog* [localhost]'

 

2단계  = 탄력적 검색 로그를 제거합니다.

  • sudo systemctl status Elasticsearch
    sudo systemctl stop Elasticsearch
    
    cd /var/log/elasticsearch (note: Do not delete vxfm-es-cluster.log)
    rm -rf *log.gz*
    rm -rf *gc.log*
    rm -rf *showlog.log*
    
    Systemctl start Elasticsearch
    sudo systemctl status Elasticsearch


3단계 = ElasticSearch의 모든 데이터를 삭제합니다. 

*경고: 고객은 모든 기간별 알림, 리소스의 성능 메트릭 및 syslog 데이터를 잃게 됩니다.

 

  • curl -XDELETE localhost:9200/_all

 

상태를 확인하고 rsyslog 서비스를 중지합니다.

 

systemctl status rsyslog

systemctl stop rsyslog

 

다시 시도하고 syslog 서비스를 시작합니다.

systemctl start rsyslog

 

 

Affected Products

PowerFlex rack, ScaleIO
Article Properties
Article Number: 000323551
Article Type: Solution
Last Modified: 19 Jun 2025
Version:  2
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