Avamar: Os logs do Avagent mostram "CR_ERROR" durante o registro ou durante o backup

Summary: Os logs do Avagent mostram o erro "CR_ERROR"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Cenário 1 — Falha no registro do client:

avagent.log:

2018/02/20-07:42:30.26300 [agent_main]  agent_message::lowrecv() Unable to recv message size!

2018/02/20-07:42:30.26300 [agent_main]  agent_message::recvcapsule capsule: server_avail:1, ret.size=0
2018/02/20-07:42:30.26300 [agent_main]  agent_message::receive_message after recv
2018-02-20 13:12:30 avagent Error <5061>: No response to message
2018/02/20-07:42:30.26300 [agent_main]  agent_message::hangup closing socket
2018/02/20-07:42:30.26300 [agent_main]  agent_message::hangup closed connection
2018/02/20-07:42:30.26399 [agent_main]  agent_commands::check_mc_response received an bad status code 'CR_ERROR'
2018/02/20-07:42:30.26399 [agent_main]  agent_commands::check_mc_response ret=9. 
 

-- Ou --

2019-01-28 12:52:53 avagent Info <6601>: Hostnamelist: client1.avamar.com,171.16.100.200,client1.avamar.com,127.0.0.1
2019-01-28 12:52:54 avagent Info <5472>: Registering with the MCS (10.18.100.200)
2019-01-28 12:52:54 avagent Error <5320>: Received from MCS#100003:client certificate verification failed 100.168.100.20.
2019-01-28 12:52:54 avagent Error <5061>: No response to message
2019-01-28 12:52:54 avagent Error <6210>: Unable to register '/clients\client1' with MCS at 10.18.100.200:30001
2019-01-28 12:52:54 avagent Error <6164>: Registration error: Client ID(CID) missing from response. (< msgver="1" />
2019-01-28 12:52:54 avagent Error <5036>: Unable to register CR_ERROR
 

Cenário 2 — O registro é concluído, mas os backups travam em "Waiting client" ou "Timed-Out End" sem transferência de dados:

avagent.log:

2017/06/14-15:17:43.99699 [agent_main]  agent_message::receive_message message sent, recv ack, timeout 300
2017/06/14-15:18:02.95099 [agent_main]  agent_message::lowrecv() Unable to recv message size!
2017/06/14-15:18:02.95099 [agent_main]  agent_message::recvcapsule capsule: server_avail:1, ret.size=0
2017/06/14-15:18:02.95099 [agent_main]  agent_message::receive_message after recv
2017-06-14 08:18:02 avagent Error <5061>: No response to message
2017/06/14-15:18:02.95099 [agent_main]  agent_message::hangup closing socket
2017/06/14-15:18:02.95099 [agent_main]  agent_message::hangup closed connection
2017-06-14 08:18:02 avagent Error <5038>: Error sending message CR_ERROR    
 

-- Ou --

avagent Info <7502>: Registration of client /Data_Center1/SharePoint2013/prod_ext/client2.emc.local with MCS avamar-01emc.local:28001 successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3015 VSS successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3023 update successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3001 Windows successful.
2017-06-14 18:41:57 avagent Info <5619>: Registration of client and plugins complete.
2017-06-14 18:41:57 avagent Info <5964>: Requesting work from avamar-01.emc.local
2017-06-14 18:42:16 avagent Error <5061>: No response to message 2017-06-14 18:42:16 avagent Error <5038>: Error sending message CR_ERROR

Cause

Se a solicitação do avagent relatórios de log "No response to message" ou "CR_ERROR Durante o handshake inicial, há um problema de comunicação bloqueando o send/ack mensagens entre a grade do Avamar e o client.

Nota: Todos os erros em ambos os cenários indicam problemas relacionados à rede ou ao firewall no ambiente do cliente.

Resolution

As etapas a seguir podem ser usadas para ajudar a encontrar gargalos:

1. Verifique se todas as portas necessárias do Avamar estão abertas no firewall e se podem enviar e receber dados.
(Avamar Server para client e client para Avamar server)

2. Verifique se há algum software antivírus ou de detecção de malware bloqueando os dados nas portas do Avamar.

3. Se o client estiver atrás de uma NAT, verifique se as tabelas de rota estão configuradas corretamente.

4. Se o mesmo erro for visto em todos os clients, certifique-se de que nenhuma alteração foi feita na rede do Avamar.

5. Entre em contato com a equipe de rede para rastrear o tráfego de rede do client com falha para a grade do Avamar e verifique se há quedas de pacotes na rede.

6. Se nenhum problema for encontrado, colete tcpdump e Wireshark ou Netmon e criar um chamado.

Additional Information

Recursos do Wireshark:
 
Recursos do TCPDump:
  •    https://linuxtechlab.com/learn-use-tcpdump-command-examples(Link externo)

Affected Products

Avamar, Avamar Client
Article Properties
Article Number: 000040936
Article Type: Solution
Last Modified: 24 Sept 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.