Data Protection Advisor: L'agent non riesce a registrarsi sul server

Summary: L'agente di protezione dei dati (DPA) non riesce a registrarsi con il server dell'applicazione di protezione dei dati (APP DPA) a causa dell'impostazione proxy HTTP (Hyper-Text Transfer Protocol), con conseguente errore CURL (URL di comunicazione) [56] e codice HTTP (Hyper-Text Transfer Protocol) 403. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

L'agent non viene visualizzato nell'interfaccia utente in Data Collection>Agents, anche se l'agent è installato.

Con l'agent impostato per il debug, nel registro dell'agent viene visualizzato quanto segue:
 

DBG1    18535.18535    20170628:142552             com.http - httpSendRequest(): CURL error: [56] Received HTTP code 403 from proxy after CONNECT
ERR     18535.18535    20170628:142552         agent.config - initAgentConfig(): Failed to register agent with the server. Waiting to retry...


 

Cause

Un'impostazione proxy http causa questo problema che porta il server dell'app DPA a rifiutare la richiesta di registrazione dell'agent al momento della connessione.

Resolution

Accedere al server agent DPA come root e procedere come segue:

Arrestare il servizio agent DPA con il seguente comando:

/opt/emc/dpa/agent/etc/dpa stop


Modificare il file dpa.custom che si trova nella directory> di installazione DPA</dpa/agent/etc e aggiungere le due righe seguenti:
 

export http_proxy=
export https_proxy=
 
Le due righe precedenti devono essere create esattamente come sopra senza ulteriori caratteri oltre a =.


Salvare le modifiche e riavviare il servizio dell'agent. L'agent deve registrarsi ora, poiché le nuove voci nel file dpa.custom annullano le impostazioni proxy http o https a livello di sistema operativo. 

Per ulteriori informazioni, contattare il supporto tecnico Dell.

 

Products

Data Protection Advisor
Article Properties
Article Number: 000065495
Article Type: Solution
Last Modified: 24 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.