Selhání zálohování pasivního uzlu NetWorker pro DISASTER_RECOVERY: uložit sadu

Summary: Zálohování pasivního uzlu NetWorker selže pro DISASTER_RECOVERY: uložení sady.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Cluster Windows se zálohuje pomocí klientského softwaru NetWorker.
Zálohování pasivního uzlu selže se zprávou:

174424:save: Step (3 of 5) for PID-14480: Creating the snapshot for the selected save sets.
VSS OTHER: ERROR: VSS failed to process snapshot:
176575:save: Unable to save the SYSTEM STATE save sets and create the snapshot.
176571:save: Step (4 of 5) for PID-14480: Unable to complete the backup of the disaster recovery save sets. See the savegrp log to track the closure steps of the backup.
176572:save: Error occurred during the backup of the disaster recovery save sets.


V protokolu prohlížeče systémových událostí pasivního uzlu se zobrazují následující chyby služby Stínová kopie svazku (VSS):

Volume Shadow Copy Service error: Unexpected error calling routine GetVolumePathName is fail on the path <>, winerror 0x00000002.. hr = 0x80070002, 
The system cannot find the file specified. 
Operation: PrepareForSnapshot Event Context: Execution Context: Writer Writer Class Id: {e8132975-6f93-4464-a53e-1050253ae220} Writer Name: System Writer Writer Instance ID: {df094dcb-34af-4112-a3a1-43febe923b77}

 

Cause

Aplikační služby běží na sdílené jednotce, která není místně přidružená k pasivnímu uzlu po převzetí služeb při selhání.
Zapisovač systému hlásí cestu, kde je aplikace spuštěna.  Služba Stínová kopie svazku (VSS) hlásí, že nemůže najít cestu, kde je služba spuštěna.

Resolution

Zkontrolujte výstup "seznam zapisovačů podrobný".
Otevřete CMD jako správce a spusťte následující příkaz:

diskshadow /l output.txt
DISKSHADOW> list writers detailed
DISKSHADOW> exit
 

1. V konzoli NetWorker Management Console (NMC) otevřete vlastnosti klienta pasivního uzlu.
2. Na kartě Aplikace a moduly upravte pole Uložit operace tak, aby obsahovalo: 

VSS:NSR_SYS_WRITER_WIN32_SERVCOMP_USER=yes

 

Additional Information

Pokud výše uvedený postup nepomůže problém vyřešit, postupujte podle níže uvedených kroků a požádejte o pomoc.

Zkopírujte binární soubory vsstrace a vssagent do problematického klienta. Shromažďují velké množství informací o ladění Microsoft VSS.

Proveďte následující kroky a shromážděte výstupy:

  1. Do pole "Operace zálohování" klienta přidejte následující syntaxi: VSS:NSR_SYS_WRITER_WIN32_SERVCOMP_USER=ano
  2. Nastavte příkaz zálohování pro uložení části -D9 -vvvv ve vlastnostech klienta NMC.
  3. "save -o VSS:LCV=yes" výstup na problematickém klientovi
  4. savefs -p výstup na problematickém klientovi.
  5. Výstup LCMAP na problematickém klientovi.
  6. Před zahájením zálohování spusťte kolekci vsstrace a vssagent na problematickém klientovi se dvěma různými cmd :- vsstrace -l 255 +f 0xffff -o C:\vss.trace.log
  7. Spusťte zálohování z konzole NMC.
  8. Počkejte na dokončení zálohování.
  9. Shromážděte výstup příkazu "vssagent -gather C:\VSS.xml"
  10. Shromažďujte NSRGET a reporty z problematického klienta

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000168983
Article Type: Solution
Last Modified: 18 Sept 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.