IDPA System Managerのrootパスワードが頻繁に同期されない
Summary: IDPA 2.3で報告された問題 ACMダッシュボードで正しいパスワードをアップデートした後、IDPA System Managerのrootパスワードが頻繁に同期されなくなります。
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Symptoms
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DPCで確認します。
adminと正しいパスワードを使用して、別のputtyセッションでACMからDPCにsshで接続します
次のコマンドを使用してrootに切り替えます。#su -
admin/rootを使用してDPCに正常にログインできる場合は、次の手順に進みます。
-
ACMのログを確認します
/usr/local/dataprotection/var/configmgr/server_data/logs/server.log:次の文字列を検索して、DPC rootパスワードが同期しなくなったタイミングと回数を確認します。
#grep -i "Setting dpcRootPasswordOutOfSync=true" server.log* server.log.18:2020-09-22 16:10:26,459 INFO [Thread-3200180]-dpcadapter.DPCUtil: Setting dpcRootPasswordOutOfSync=true server.log.7:2020-10-02 18:28:25,577 INFO [Thread-40894]-dpcadapter.DPCUtil: Setting dpcRootPasswordOutOfSync=true
上記のスレッドを確認して、ログに次の症状を確認します。
#grep -E "Thread-3200180" server.log*
- 正常に表示されるACMリクエスト サービス ステータス:
server.log.18:2020-09-22 14:09:55,332 INFO [Thread-3200180]-util.SSHUtil: Remote command using SSH execution status: Host : [10.199.193.14] User : [admin] Pass word : [**********] Command : [/usr/local/dpc/bin/dpc status] STATUS : [0] server.log.18:2020-09-22 14:09:55,332 INFO [Thread-3200180]-util.SSHUtil: STDOUT : [Version: 18.2.0-13 server.log.18:2020-09-22 14:09:55,332 INFO [Thread-3200180]-util.SSHUtil: STDERR : []
- パスワードが同期されていることを確認します。
server.log.18:2020-09-22 14:09:55,340 INFO [Thread-3200180]-dao.DPCConfigDAOImpl: Successfully retrieved DPC configuration server.log.18:2020-09-22 14:09:55,340 INFO [Thread-3200180]-dpcadapter.DPCUtil: dpcRootPasswordOutOfSync=false server.log.18:2020-09-22 14:09:55,340 INFO [Thread-3200180]-dpcadapter.DPCUtil: dpcAdminPasswordOutOfSync=false
- DPCクレドを再度フェッチし、DPCへのSSHを試行します。
server.log.18:2020-09-22 14:09:55,469 INFO [Thread-3200180]-util.SSHUtil: Creating session using SSH parameters: Host : [10.199.193.14] User : [admin] Pas sword : [**********] server.log.18:2020-09-22 14:09:55,469 INFO [Thread-3200180]-util.SSHUtil: Connecting to host [10.199.193.14] using provided credentials. server.log.18:2020-09-22 14:09:55,546 INFO [Thread-3200180]-util.SSHUtil: Connected to host [10.199.193.14] using provided credentials. server.log.18:2020-09-22 14:09:55,547 INFO [Thread-3200180]-util.SSHUtil: Opening a channel for communication. server.log.18:2020-09-22 14:09:55,547 INFO [Thread-3200180]-util.SSHUtil: Channel for communication opened successfully. server.log.18:2020-09-22 14:09:55,701 INFO [Thread-3200180]-util.SSHUtil: Expected Message:: ssword .... server.log.18:2020-09-22 14:10:25,732 ERROR [Thread-3200180]-util.SSHUtil: Error in command execution Expect operation fails (timeout: 30000 ms) for matcher: contains('ssword') - チャネルは14:10:25から開いたままになります
2020-09-22 14:10:25,732 INFO [Thread-3200180]-util.SSHUtil: Waiting for channel close
- 2時間後にチャネルが閉じました:
server.log.18:2020-09-22 16:10:26,458 INFO [Thread-3200180]-util.SSHUtil: Disconnecting channel forcefully. server.log.18:2020-09-22 16:10:26,458 INFO [Thread-3200180]-util.SSHUtil: Channel disconnected successfully. server.log.18:2020-09-22 16:10:26,458 INFO [Thread-3200180]-util.SSHUtil: Processing the ssh command execution results standard output. server.log.18:2020-09-22 16:10:26,458 INFO [Thread-3200180]-util.SSHUtil: Processing the ssh command execution standard error. server.log.18:2020-09-22 16:10:26,459 INFO [Thread-3200180]-util.SSHUtil: Remote command using SSH execution status: Host : [10.199.193.14] User : [admin] Password : [**********] Command : [su -c 'date'] STATUS : [-1]
- 同期解除としてマークします。
server.log.18:2020-09-22 16:10:26,459 INFO [Thread-3200180]-dpcadapter.DPCUtil: DPC root password is out of sync, throwing exception server.log.18:2020-09-22 16:10:26,459 INFO [Thread-3200180]-dpcadapter.DPCUtil: Setting dpcRootPasswordOutOfSync=true
- 正常に表示されるACMリクエスト サービス ステータス:
Cause
DPCの応答が遅くなると(おそらく一部のジョブやアクティビティが原因で)、パスワード同期をチェックするために起動されたコマンドは、予期した時間にプロンプトを表示せず(コマンド実行タイムアウトを引き起こします)、シナリオが失敗します。
Resolution
この問題は、エンジニアリング チームがIDPA 2.7.0コードで修正しました。
Affected Products
Integrated Data Protection Appliance FamilyProducts
Data Protection Central, PowerProtect Data Protection Appliance, Data Protection Central, PowerProtect Data Protection Software, PowerProtect Data Protection Hardware, Integrated Data Protection Appliance SoftwareArticle Properties
Article Number: 000181995
Article Type: Solution
Last Modified: 15 Dec 2025
Version: 4
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