Сбой модернизации NetWorker Virtual Edition до 19.8.0.108 при повторной настройке параметров консоли управления NetWorker

Summary: Операция обновления NetWorker Virtual Edition с версии 19.8.0.81 до версии 19.8.0.108 завершается сбоем при перенастройке параметров консоли управления NetWorker (40 из 50). Получена ошибка: /usr/local/avamar/var/avi/server_log/avinstaller.log.0. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Во время обновления NetWorker Virtual Edition (NVE) с версии 19.8.0.81 до версии 19.8.0.108 происходит сбой. В /usr/local/avamar/var/avi/server_log/avinstaller.log.0 были обнаружены следующие ошибки:
2023-10-25 09:50:23 (-0400) 47170924092060 ERROR: File /nsr/authc_config.txt.preserved not found, impossible to continue - operation failed
2023-10-25 09:50:41 (-0400) 46933625019040 ERROR: File /nsr/authc_config.txt.preserved not found, impossible to continue - operation failed
2023-10-25 10:04:49 (-0400) 47415919573660 ERROR: File /nsr/authc_config.txt.preserved not found, impossible to continue - operation failed
2023-10-25 10:30:41 (-0400) 47351198866080 ERROR: Configuring AuthC service for NetWorker, exit status=1 (error)
2023-10-25 10:30:42 ( operation failed
2023-10-25 10:30:53 (-0400) 47072497048220 ERROR: Configuring AuthC service for NetWorker, exit status=1 (error)
2023-10-25 10:30:54 ( operation failed

Было замечено, что файл /nsr/authc_config.txt.reserved, на который ссылаются журналы, отсутствует в среде пользователя. Поскольку этот файл можно создать вручную, файл был создан вручную со следующим содержимым:

EMC_JAVADIR=/opt/nre/java/latest
EMC_TCUSER=nsrtomcat
EMC_TCPORT=9090
EMC_CREATETCKEYSTORE=n
EMC_TCKEYSTORE=/nsr/authc/conf/authc.keystore
EMC_DATADIR=/nsr/authc/data
EMC_KEEPBOOT=y
После создания файла процесс обновления по-прежнему завершается сбоем, и в журналы записываются следующие сообщения об ошибках:
2023-11-08 15:29:00 (-0500) 46972685933220 ERROR: Configuring AuthC service for NetWorker, exit status=1 (error)
2023-11-08 15:29:00 ( operation failed
2023-11-08 16:05:45 (-0500) 47118958156460 ERROR: Configuring NetWorker Management Console, exit status=1 (error)
2023-11-08 16:05:46 ( operation failed

Cause

В ходе дальнейшего расследования выяснилось, что во время первоначальной установки заказчик изменил EMC_TCPORT на порт, отличный от порта 8443 по умолчанию. Позже они удалили файл authc_config.txt.preserved по необъяснимой причине.

Несмотря на то, что файл authc_config.txt.saved создается вручную с правильным синтаксисом перед попыткой выполнения модернизации NVE, операция обновления завершается сбоем с ошибками в журналах.

Инженеры исследовали и воспроизвели сценарий собственными силами. Во время этого воспроизведения инженеры заметили, что если во время первоначальной установки порт EMC_TCPORT изменить на порт, отличный от порта по умолчанию, это приведет к сбоям при последующих модернизациях, несмотря на то, что порт по умолчанию будет снова настроен на 9090.
 
ПРИМЕЧАНИЕ. Наблюдалось, что, несмотря на сообщенный сбой, модернизация была завершена и обновленную версию можно было подтвердить на сервере NetWorker. Это связано с тем, что операция зависла на этапе перенастройки параметров консоли управления NetWorker (40 из 50) и уже прошла шаги модернизации.

Resolution

Инженерный отдел утверждает, что NVE является предварительно настроенным устройством, и изменение какой-либо конфигурации не поддерживается. Любые изменения, внесенные в конфигурацию, вызывают поток проблем с непредсказуемыми последствиями. Единственный способ устранить эти непредсказуемые проблемы в NVE, для которых файлы конфигурации были изменены, — это развернуть новое устройство NVE и восстановить старую конфигурацию с помощью NSRDR, чтобы гарантировать наличие полностью функциональной операционной системы.
Article Properties
Article Number: 000221783
Article Type: Solution
Last Modified: 04 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.