iDRAC9: Impossibile raccogliere Remote SupportAssist con l'opzione di debug
Summary: Dell RACADM potrebbe non riuscire a eseguire la raccolta dei registri di SupportAssist remota quando l'opzione di debug selezionata e la raccolta hanno raggiunto la dimensione massima del file. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
La raccolta SupportAssist remota non viene esportata con l'opzione debug.
[root@server]# racadm -r %idrac% -u %user% -p %password% -d supportassist collect -t Debug -f TSR.zip Security Alert: Certificate is invalid - self signed certificate in certificate chain Continuing execution. Use -S option for racadm to stop execution on certificate-related errors. Job ID = JID_309193470707 Please wait while the SupportAssist collection is completed ERROR: HTTP Service unavailable for the specified RAC. ERROR: Unable to process the HTTP command request. Please retry the command after some time. Please wait while the logs are being fetched. Depending on the network speed, it may take several minutes to complete this operation. Progress = -9223372036854775808 percent
Cause
Con l'opzione di debug selezionata, altri file vengono aggiunti alla raccolta. In questo modo è possibile che la raccolta raggiunga la dimensione massima di 30 MB. Quando la raccolta viene estratta in remoto e con le dimensioni massime, è possibile che system-httpd.slice superi la memoria massima. Di conseguenza, il sistema ricicla i processi nel cgroup per tornare al di sotto del limite di memoria e genera un errore di raccolta.
Resolution
Il futuro firmware iDRAC9 7.20.10.50 pulirà automaticamente i core file precedenti per ridurre le dimensioni della raccolta di debug.
Utilizzare una delle seguenti opzioni per esportare la raccolta SupportAssist di debug.
Opzione 1
I file core possono essere eliminati prima di eseguire il pull di una raccolta remota per ridurne le dimensioni.
La raccolta SupportAssist di debug può essere estratta localmente dal sistema host utilizzando racadm locale. L'utilizzo di questo metodo non è influenzato in quanto non viene eseguito con gli stessi limiti di memoria cgroup di RACADM remoto.
Utilizzare una delle seguenti opzioni per esportare la raccolta SupportAssist di debug.
Opzione 1
I file core possono essere eliminati prima di eseguire il pull di una raccolta remota per ridurne le dimensioni.
$ racadm -r %idracip% -u %user% -p %password% coredump $ racadm -r %idracip% -u %user% -p %password% coredumpdelete -f %filename% $ racadm -r %idracip% -u %user% -p %password% coredumpdelete --allOpzione 2
La raccolta SupportAssist di debug può essere estratta localmente dal sistema host utilizzando racadm locale. L'utilizzo di questo metodo non è influenzato in quanto non viene eseguito con gli stessi limiti di memoria cgroup di RACADM remoto.
$ racadm supportassist collect -t debug -f TSR.zip
Affected Products
iDRAC9Article Properties
Article Number: 000251323
Article Type: Solution
Last Modified: 19 May 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.