iDRAC9:無法收集具有偵錯選項的遠端 SupportAssist

Summary: 如果選取了偵錯選項,且集合的檔案大小上限,Dell RACADM 的遠端 SupportAssist 記錄收集可能會失敗。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

遠端 SupportAssist 集合無法使用偵錯選項匯出。
[root@server]# racadm -r %idrac% -u %user% -p %password% -d supportassist collect -t Debug -f TSR.zip
Security Alert: Certificate is invalid - self signed certificate in certificate chain
Continuing execution. Use -S option for racadm to stop execution on certificate-related errors.
Job ID = JID_309193470707

Please wait while the SupportAssist collection is completed
ERROR: HTTP Service unavailable for the specified RAC.
ERROR: Unable to process the HTTP command request. Please retry the command after some time.
Please wait while the logs are being fetched. Depending on the network speed,
it may take several minutes to complete this operation.

Progress = -9223372036854775808 percent

Cause

選取除錯選項後,其他檔案會新增到集合中。這可能會導致集合達到最大 30 MB 的大小。當集合以最大大小進行遠端提取時,可能會導致 system-httpd.slice 超過最大記憶體。因此,系統會回收 cgroup 中的進程以回到記憶體限制以下,並導致收集失敗。

Resolution

未來的 iDRAC9 韌體 7.20.10.50 會自動清理舊的核心檔案,以減少除錯集合大小。

使用下列其中一個選項匯出偵錯 SupportAssist 集合。

選項 1
在提取遠端集合之前,可以先刪除核心檔以減小集合大小。 
$ racadm -r %idracip% -u %user% -p %password% coredump 
$ racadm -r %idracip% -u %user% -p %password% coredumpdelete -f %filename%
$ racadm -r %idracip% -u %user% -p %password% coredumpdelete --all
選項 2
您可以使用本機 racadm,從主機系統在本機提取偵錯的 SupportAssist 集合。使用此方法不會受到影響,因為它不會在與遠端 racadm 相同的 cgroup 記憶體限制下執行。 
$ racadm supportassist collect -t debug -f TSR.zip

Affected Products

iDRAC9
Article Properties
Article Number: 000251323
Article Type: Solution
Last Modified: 19 May 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.