iDRAC9: Не вдається зібрати опцію віддаленої підтримкиДопомога з налагодженням

Summary: Dell RACADM може не виконувати віддалене збирання журналів SupportAssist, коли вибрана опція налагодження та колекція мають максимальний розмір файлу.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Віддалену колекцію SupportAssist не вдається експортувати з параметром налагодження.
[root@server]# racadm -r %idrac% -u %user% -p %password% -d supportassist collect -t Debug -f TSR.zip
Security Alert: Certificate is invalid - self signed certificate in certificate chain
Continuing execution. Use -S option for racadm to stop execution on certificate-related errors.
Job ID = JID_309193470707

Please wait while the SupportAssist collection is completed
ERROR: HTTP Service unavailable for the specified RAC.
ERROR: Unable to process the HTTP command request. Please retry the command after some time.
Please wait while the logs are being fetched. Depending on the network speed,
it may take several minutes to complete this operation.

Progress = -9223372036854775808 percent

Cause

За допомогою опції налагодження до збірки додаються вибрані додаткові файли. Це може призвести до того, що розмір колекції досягне максимального розміру 30 МБ. Коли збірка підтягується віддалено і має максимальний розмір, це може призвести до того, що system-httpd.slice перевищить максимальний обсяг пам'яті. В результаті система переробляє процеси в cgroup, щоб повернутися до ліміту пам'яті, що призводить до збою колекції.

Resolution

Майбутня прошивка iDRAC9 7.20.10.50 автоматично очистить старі основні файли, щоб зменшити розмір колекції налагоджень.

Скористайтеся одним із наведених нижче параметрів, щоб експортувати колекцію SupportAssist для налагодження. 

Варіант 1
Файли ядра можуть бути видалені перед тим, як витягувати віддалену колекцію, щоб зменшити розмір збірки. 
$ racadm -r %idracip% -u %user% -p %password% coredump 
$ racadm -r %idracip% -u %user% -p %password% coredumpdelete -f %filename%
$ racadm -r %idracip% -u %user% -p %password% coredumpdelete --all
Варіант 2
Колекцію SupportAssist для налагодження можна отримати локально з хост-системи за допомогою локального racadm. Використання цього методу не впливає, оскільки він не працює в тих самих межах пам'яті cgroup, що й віддалений racadm. 
$ racadm supportassist collect -t debug -f TSR.zip

Affected Products

iDRAC9
Article Properties
Article Number: 000251323
Article Type: Solution
Last Modified: 19 May 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.