PowerScale:预配连接后,预配后步骤失败

Summary: Dell SupportAssist(连接)资源调配完成后,将显示一条错误消息:“Error: 资源调配成功,但一些资源调配后步骤失败。”

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

情况 1:

Connectivity 应自动禁用 Secure Remote Services。有时自动化无法禁用 Secure Remote Services,因此存在错误,例如此处列出的错误:

OneFS 9.9.0.0 及更早版本:

Powerscale-1# # isi supportassist provision view
 
Provision Status:
 
   Current State: COMPLETED
       Sub-state: completed
Success or Fail: Fail
Percent Complete: 100%
           Error: Provisioning was successful, however some post provisioning steps failed: Failed to disable SRS

或者:

Powerscale-1# # isi supportassist provision view
 
Provision Status:
 
   Current State: COMPLETED
       Sub-state: completed
Success or Fail: Fail
Percent Complete: 100%
           Error: RuntimeError: Failed to connect to REST server: isi_papi_d service is unavailable

在 OneFS 9.10 及更高版本中,要检查的命令现在是:

Powerscale-1# isi connectivity provision view

情况 2:

在这种情况下,Secure Remote Services 不会停止运行,如下所示:

Powerscale-1# # isi esrs view
Warning: Secure Remote Service is at end of service life. Upgrade connectivity to Dell Technologies connectivity services as soon as possible by using 'isi connectivity'. See https://www.dell.com/support/kbdoc/en-us/000152189/powerscale-onefs-info-hubs cluster administration guides for more information.
                                    Enabled: Yes <<<<<<<<<<<<<<<<<<<<<<<<<<<
                       Primary ESRS Gateway: 1.2.3.4
                     Secondary ESRS Gateway: 
                        Alert on Disconnect: Yes
                       Gateway Access Pools: subnet0.pool0
          Gateway Connectivity Check Period: 60
License Usage Intelligence Reporting Period: 86400
                           Download Enabled: No
                       SRS Download Enabled: Yes
          ESRS File Download Timeout Period: 50
           ESRS File Download Error Retries: 3
              ESRS File Download Chunk Size: 1000000
             ESRS Download Filesystem Limit: 80
        Offline Telemetry Collection Period: 7200
                Gateway Connectivity Status: Disconnected <<<<<<<<<<<<<<<<<<<<<<

Cause

情况 1:

控制 Secure Remote Services 的守护程序未处于预期状态,需要手动干预。

情况 2:

Secure Remote Services 未处于预期状态,必须手动将其禁用。

Resolution

情况 1:

通常,当控制 Secure Remote Services 的两个守护程序处于遵守状态时,就会发生此问题。验证它们处于正确状态:

PowerScale-1# isi services -a | egrep 'esrs|rsapi'
   isi_esrs_d           ESRS Service Daemon                      Disabled
   isi_rsapi_d          Remote-Service API Daemon                Enabled 

以下是启用 Connectivity 后 Secure Remote Services 的样子:

Powerscale-1# isi esrs view
Warning: Secure Remote Service is at end of service life. Upgrade connectivity to Dell Technologies connectivity services as soon as possible by using 'isi connectivity'. See https://www.dell.com/support/kbdoc/en-us/000152189/powerscale-onefs-info-hubs cluster administration guides for more information.
                                    Enabled: No
                       Primary ESRS Gateway: 1.2.3.4
                     Secondary ESRS Gateway: 
                        Alert on Disconnect: Yes
                       Gateway Access Pools: subnet0.pool0
          Gateway Connectivity Check Period: 60
License Usage Intelligence Reporting Period: 86400
                           Download Enabled: No
                       SRS Download Enabled: Yes
          ESRS File Download Timeout Period: 50
           ESRS File Download Error Retries: 3
              ESRS File Download Chunk Size: 1000000
             ESRS Download Filesystem Limit: 80
        Offline Telemetry Collection Period: 7200
                Gateway Connectivity Status: Disconnected

isi_rsapi_d 守护程序应处于启用状态,如果处于禁用状态,请使用以下命令启用它:

Powerscale-1# isi services -a isi_rsapi_d enable

isi_esrs_d 守护程序应在调配连接后禁用,请使用以下命令将其禁用:

Powerscale-1# isi services -a isi_esrs_d disable

验证 isi_rsapi_d 现在正在每个节点上运行,并且不再有 isi_esrs_d 使用以下命令运行的守护程序:

PowerScale-1# isi_for_array -s "ps -auxww | egrep 'isi_rsapi|isi_esrs' | grep -v grep"

输出应返回类似于以下内容的内容:

Powerscale-2# isi_for_array -s "ps -auxww | egrep 'isi_rsapi|isi_esrs' | grep -v grep"
Powerscale-1: root    2869   0.0  0.8 108068  46684  -  Ss   Thu00       0:03.86 /usr/sbin/isi_rsapi_d
Powerscale-2: root    3015   0.0  0.6 121852  35640  -  Ss   Wed00       0:05.96 /usr/sbin/isi_rsapi_d
Powerscale-3: root    3056   0.0  0.6 102756  36972  -  Ss   Wed07       0:04.32 /usr/sbin/isi_rsapi_d
Powerscale-4: root    2743   0.0  0.6 108676  36412  -  Ss   Tue21       0:04.69 /usr/sbin/isi_rsapi_d
Powerscale-2#

如果输出未反映示例输出,请启动收集并联系 戴尔技术支持

如果输出与示例相同,请使用新的访问密钥和 PIN 再次进行预配。

情况 2:

尝试使用以下命令禁用 Secure Remote Services:

PowerScale-1# isi esrs modify --enabled=false --force

如果命令返回到提示符时没有错误,请检查状态:

Powerscale-1# # isi esrs view
Warning: Secure Remote Service is at end of service life. Upgrade connectivity to Dell Technologies connectivity services as soon as possible by using 'isi connectivity'. See https://www.dell.com/support/kbdoc/en-us/000152189/powerscale-onefs-info-hubs cluster administration guides for more information.
                                    Enabled: No <<<<<<<<<<<<<<<<<<<<<<<<<<<
                       Primary ESRS Gateway: 1.2.3.4
                     Secondary ESRS Gateway: 
                        Alert on Disconnect: Yes
                       Gateway Access Pools: subnet0.pool0
          Gateway Connectivity Check Period: 60
License Usage Intelligence Reporting Period: 86400
                           Download Enabled: No
                       SRS Download Enabled: Yes
          ESRS File Download Timeout Period: 50
           ESRS File Download Error Retries: 3
              ESRS File Download Chunk Size: 1000000
             ESRS Download Filesystem Limit: 80
        Offline Telemetry Collection Period: 7200
                Gateway Connectivity Status: Disconnected 

可以尝试新的资源调配,并使用群集的软件 ID (SWID) 使用新的访问密钥和 PIN。

如果命令出错且无法禁用,请启动收集并联系 戴尔技术支持

此问题预计将在未来的 OneFS 代码版本中得到解决。

Affected Products

Isilon, PowerScale OneFS
Article Properties
Article Number: 000401974
Article Type: Solution
Last Modified: 11 Dec 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.