KB de implementación: El proxy de Datadobi DobiMigrate no tiene acceso a los recursos compartidos/exportaciones de origen

Summary: El proxy de Datadobi DobiMigrate no tiene acceso a los recursos compartidos/exportaciones de origen.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Durante la primera copia y la siguiente de un par de iteraciones de problemas de acceso denegado en archivos y directorios, muchos de ellos son recurrentes.

Un comportamiento extraño es que el mismo archivo podría copiarse en una iteración, pero en la siguiente iteración se informan errores de acceso denegado en los registros.

Se comprueba la misma ruta cada vez que los archivos informan acceso denegado, y los mismos archivos no se informan en las próximas iteraciones y, a continuación, se informa.

Por ejemplo:

Para directorios:

error: AccessDeniedException: /IT/transcore/src2/org
error: AccessDeniedException: /IT/transcore/src

Después de volver a migrar pasa a:

DirectoryIteratorException: java.nio.file.AccessDeniedException: /IT/transcore/src2
DirectoryIteratorException: java.nio.file.AccessDeniedException: /IT/transcore/src
  • Cuando se comparan el origen y el destino, se observa que el directorio no se ha copiado en el destino.
  • Intente hacer clic en ellos y realice una remigrate force metadata + data copy, o intente iniciar otra iteración con los metadatos de recopy, el resultado es una falla
  • Si intenta comparar todos los permisos del lado NFS y CIFS, ambos tienen exactamente los mismos permisos, el directorio primario /IT/transcore y el subdirectorio IT/transcore/src2.

Para archivo:

AccessDeniedException: /Marketing/fvb_test/SCR.pdf
  • Al comparar la fuente y el destino, es posible que descubra que el archivo PDF está copiado, tiene el mismo permiso, tamaño y todo es exactamente igual excepto el propietario, que es un usuario raíz de Linux, mientras que en la fuente era un usuario normal.
  • Intente abrir el archivo en el destino, es posible que esté dañado y no se abra como la fuente, lo cual es totalmente normal.
  • Intentó remigrar los metadatos, pero no funcionó.
  • Sin embargo, después de insertar una iteración normal en la ruta total 2 o 3 veces, es posible que este error para este archivo específico no sea recurrente y, en el arreglo de destino, se abra normalmente y funcione correctamente.

 

Cause

La causa del problema era que uno de los proxies NFS estaba en una red diferente y no podía explorar los datos de origen. No tuvo acceso.

 

Resolution

Se eliminó la exportación NFS que estaba en una red diferente y no tenía acceso.

Para identificar qué proxy NFS tiene o no acceso.

Vaya a Datadobi Management UI (Core) > Tools File Browser > Seleccione el almacenamiento > Seleccione el proxy > Explore los archivos y asegúrese de poder acceder a todos los archivos mediante > este proxy.

Realice lo anterior utilizando todos los proxies para identificar qué archivo no tiene acceso, luego puede confirmar si los proxies tienen acceso o no.
Navegador de archivos DobiMigrate

 

Affected Products

Data Migration for Isilon with Select Software: DobiMiner and StorageX

Products

Data Migration for Isilon with Select Software: DobiMiner and StorageX
Article Properties
Article Number: 000053726
Article Type: Solution
Last Modified: 18 Nov 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.