Wdrażanie pakietu KB: Serwer proxy Datadobi DobiMigrate nie ma dostępu do źródłowych udziałów/eksportów

Summary: Serwer proxy Datadobi DobiMigrate nie ma dostępu do źródłowych udziałów/eksportów.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Podczas pierwszej kopii i kilku kolejnych iteracji problemów z odmową dostępu w plikach i katalogach wiele z nich powtarza się.

Dziwne zachowanie polega na tym, że ten sam plik może zostać skopiowany w jednej iteracji, ale następna iteracja zgłasza błędy odmowy dostępu w dziennikach.

Ta sama ścieżka jest sprawdzana za każdym razem i losowo pliki zgłaszają odmowę dostępu, a te same pliki nie zgłaszają się w następnych iteracjach, a następnie zgłaszają się z powrotem.

Na przykład:

W przypadku katalogów:

error: AccessDeniedException: /IT/transcore/src2/org
error: AccessDeniedException: /IT/transcore/src

Po ponownej migracji zmienia się na:

DirectoryIteratorException: java.nio.file.AccessDeniedException: /IT/transcore/src2
DirectoryIteratorException: java.nio.file.AccessDeniedException: /IT/transcore/src
  • Podczas porównywania źródła i miejsca docelowego okazuje się, że katalog nie został skopiowany do miejsca docelowego.
  • Spróbuj je kliknąć i wykonaj ponowną migrację wymuś metadane + kopiuj dane lub spróbuj uruchomić kolejną iterację z ponownym kopiowaniem metadanych, rezultatem jest niepowodzenie
  • Jeśli spróbujesz porównać wszystkie uprawnienia po stronie NFS i CIFS, oba mają dokładnie takie same uprawnienia, katalog nadrzędny /IT/transcore i podkatalog IT/transcore/src2.

Dla pliku:

AccessDeniedException: /Marketing/fvb_test/SCR.pdf
  • Porównując źródło i miejsce docelowe, może się okazać, że plik PDF jest skopiowany, ma takie same uprawnienia, rozmiar i wszystko jest dokładnie takie samo, z wyjątkiem właściciela, który jest głównym użytkownikiem Linuksa, podczas gdy w źródle był zwykłym użytkownikiem.
  • Spróbuj otworzyć plik w miejscu docelowym, może być uszkodzony i nie otwiera się tak jak źródło, co jest całkowicie normalne.
  • Próba ponownej migracji metadanych nie przyniosła rezultatu.
  • Jednak po 2 lub 3 przesunięciu normalnej iteracji na całkowitej ścieżce może się okazać, że ten błąd dla tego konkretnego pliku nie powtarza się, a w macierzy docelowej otwiera się normalnie i działa poprawnie.

 

Cause

Przyczyną problemu było to, że jeden z serwerów proxy NFS znajdował się w innej sieci i nie mógł eksplorować danych źródłowych. Nie miał dostępu.

 

Resolution

Usunięto eksport NFS, który znajdował się w innej sieci i nie miał dostępu.

W celu określenia, który serwer proxy NFS ma lub nie ma dostępu.

Przejdź do narzędzia interfejsu zarządzania Datadobi (Core) >> Przeglądarka > plików Wybierz pamięć masową > Wybierz serwer proxy > Przeglądaj pliki i upewnij się, że za pośrednictwem tego serwera proxy masz dostęp do wszystkich plików.

Wykonaj powyższe czynności, używając wszystkich serwerów proxy, aby zidentyfikować, który plik nie ma dostępu, a następnie możesz potwierdzić, czy serwery proxy mają dostęp, czy nie.
Przeglądarka plików DobiMigrate

 

Affected Products

Data Migration for Isilon with Select Software: DobiMiner and StorageX

Products

Data Migration for Isilon with Select Software: DobiMiner and StorageX
Article Properties
Article Number: 000053726
Article Type: Solution
Last Modified: 18 Nov 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.