RecoverPoint/SRM: Failover- oder Test-Failover-Vorgänge schlagen mit Volume-/VMFS-Fehlern fehl

Summary: Site Recovery Manager (SRM)-Failover oder Test-Failover schlägt mit der Fehlermeldung "VMFS-Volume für Datenspeicher kann nicht gefunden werden" oder ähnlichen Fehlermeldungen "Volume/VMFS nicht gefunden" fehl. ...

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Symptoms

Versuchen Sie, ein Failover durchzuführen oder führen Sie Site Recovery Manager (SRM)-Test-Failover aus.

SRM-Failover oder Test-Failover schlägt fehl, weil Volumes/VMFS nicht gefunden wurden.

Beispielfehler in SRM-Protokollen:
 
2017-05-21T14:20:53.757+03:00 [53540 error 'AbrRecoveryEngine' opID=773f5494:dd26:ffe2] Dr::Providers::Abr::AbrRecoveryEngine::RecoverVmfsDatastore: Cannot find VMFS volume for datastore 'ds:///vmfs/volumes/57c9acfd-5ead583e-ada6-0017a477xxxx/': (dr.storageProvider.VmfsRecoverySpec) {


2017-05-21T14:20:53.761+03:00 [193968 verbose 'AbrRecoveryEngine' opID=773f5494:dd26:ffe2] FailDeviceGroups: Failing group
2017-05-21T14:20:53.761+03:00 [193968 verbose 'AbrRecoveryEngine' opID=773f5494:dd26:ffe2] GroupCallbackHandler::FailGroup: Failing group 'vm-protection-group-xxxxxx'
2017-05-21T14:20:53.761+03:00 [193968 verbose 'Replication' opID=773f5494:dd26:ffe2] Dr::Replication::EntityOperationJoinerBase<class Dr::TypedMoRef<class Dr::Replication::ProtectionGroup,void>,void>::EntityFailed: Received a failure update for protection group Id=[dr.replication.VmProtectionGroup:bcf4f9b1-2063-4d9a-b773-93be06xxxxxx:vm-protection-group-xxxxxx], error=
--> (dr.storageProvider.fault.DatastoreRecoveryFailed) {
-->    faultCause = (dr.storageProvider.fault.RecoveryVmfsVolumeNotFound) {
-->       faultCause = (dr.storageProvider.fault.RecoveryDeviceNotFound) {
-->          faultCause = (vmodl.MethodFault) null, 
-->          device = "60:06:01:60:0C:F0:3D:00:0E:29:21:28:xx:xx:xx:xx", 
-->          msg = ""
-->       }, 
-->       device = (string) [
-->          "60:06:01:60:0C:F0:3D:00:0E:29:21:28:x:xx:xx:x"
-->       ], 
-->       msg = ""
-->    }, 
-->    protectedName = "General", 
-->    protectedUrl = "ds:///vmfs/volumes/57c9acfd-5ead583e-ada6-0017a4770xxx/", 
-->    msg = ""
--> }



Das manuelle Mounten der Zielgeräte ohne SRM scheint zu funktionieren.

Cause

In einigen Szenarien ist die Zeit, die die Geräte benötigen, um auf den ESXi-Nodes angezeigt zu werden, länger als das Standard-Timeout.
Dieses Problem erfordert einen zweiten Scan oder eine Verzögerung vor dem Scan.

Resolution

Lösung:

Ändern Sie die ESXi/SRM-Parameter für die Speichererkennung.
Diese können je nach Umgebung in unterschiedliche Zahlen geändert werden. Größere Umgebungen mit mehr LUNs oder ESXi-Hosts erfordern möglicherweise längere Timeouts, Wiederholungen oder Verzögerungen.

  1. Öffnen Sie den vSphere Web Client.
  2. Klicken Sie mit der rechten Maustaste auf den SRM-Standort, den Sie ändern möchten, und wählen Sie Advanced Settings aus.
  3. Klicken Sie auf StorageProvider.
  4. Parameter prüfen/bearbeiten:
    • storageProvider.hostRescanDelaySec – Der Standardwert ist 0, versuchen Sie, in eine Zahl zwischen 20 und 180 zu wechseln.
    • storageProvider.hostRescanRepeatCnt – Standardwert ist 1. Versuchen Sie, in eine Zahl zwischen 2 und 3 zu wechseln.
    • storage.commandTimeout – Der Standardwert ist 300, versuchen Sie, auf 600 oder 900 zu erhöhen

Ähnliche Informationen finden Sie in Broadcom-Artikeln, z. B. KB 383166.

Affected Products

RecoverPoint, RecoverPoint CL, RecoverPoint EX

Products

RecoverPoint SE
Article Properties
Article Number: 000065070
Article Type: Solution
Last Modified: 09 Oct 2025
Version:  4
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