PowerStore: IO Errors on NAS File Systems On Node Reboot

Summary: This article details IO Errors on NAS File Systems On Node Reboot

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When one of the nodes of the appliance is rebooted, a NAS file system might experience IO errors. When the node comes up from the reboot, the IO errors will no longer occur, and the file systems should automatically recover. However, this may indicate that there is an issue with the internal access to the NAS file system on the surviving node.

 

Cause

It is possible that the internal multipath access to an SDNAS volume has lost its path to the volume on the local (surviving) node, and only has access to the volume on the peer node. When the peer node reboots, all access is lost. The error messages for this issue appear on the host. They are from the specific application that is being used so will vary depending on the tool or application. 

The following example is the error messages that are produced for IO using Infiload (the output will differ for other tools and applications):
2020-06-05 04:04:04 200605-010404 ERROR [Infiload] Infinio error received during read, this is the p:
2020-06-05 04:04:04 CMD: timeout -s 9 600 python /tmp/originInfinio.py --action=read --directory=/mnt/Infinio_11 --file-number=70 --block-size=256kb
2020-06-05 04:04:04 RC: 1
2020-06-05 04:04:04 EPOCH: 1591318981.75
2020-06-05 04:04:04 PID: 4327
2020-06-05 04:04:04 HOST: hop000177
2020-06-05 04:04:04 RUNTIME: 62.9582920074
2020-06-05 04:04:04 STDOUT:
2020-06-05 04:04:04
2020-06-05 04:04:04 Infinio
2020-06-05 04:04:04 www.dellemc.com
2020-06-05 04:04:04
2020-06-05 04:04:04 [action] read
2020-06-05 04:04:04 Auditing total existing files ...
2020-06-05 04:04:04


 

Resolution

The volume will be available once the peer node boots. However, if the peer node were to reboot again, IO errors would occur again. To correct the issue on the surviving node, the surviving node should be rebooted at the customer’s earliest convenience. See Powering down and Reboot Procedures Guide for instructions on performing the reboot procedure.

 

Affected Products

PowerStore
Article Properties
Article Number: 000133315
Article Type: Solution
Last Modified: 21 Feb 2021
Version:  3
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