DDBEA 4.5 - SQL 2014と2016が同じシステム上にある場合 - SQL Serverインスタンスにログインできません。

Summary: SQL Server 2014および2016にインストールされたDDBEA Microsoft APPエージェント プラグインで、バックアップが失敗し、SQL Serverインスタンスにログインできない問題が発生します。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Data Domain Backup Enterprise Agent - DDBEAプラグインは、SQL Serverバックアップの実行に失敗します。
 

ddbmsqlsv NSR critical Cannot login to SQL Server Default Instance.

ddbmsqlsv: Unable to complete the SQL connection

Cause

環境
SQL Server 2014 がインストールされ、1 つの SQL 2014 インスタンスが実行されています。  SQL Server Management Studio (SSMS)はバージョン2014を使用しています。
同じシステム上に、SQL Server 2016ソフトウェアもインストールされます。

ログオンしているユーザーの権限を確認し、必要なすべての権限が付与されていることを確認しました。
ユーザーは、SSMS、OSQL、SQLCMDツールからネイティブSQLバックアップを実行できます。

調査の結果、SQL Server 2016がインストールされてからしばらく経っていることが明らかになりました。
  •  SQL 2016ソフトウェアが部分的にアンインストールされた(ただし、完全にはアンインストールされていない)
  •  または、SQL 2016インストールから一部のファイルが削除されました。      これにより、SQL 2016 ADO.Net ドライバーが削除されました。  **これらのドライバーは、DDBEAがSQL Serverインスタンスに接続するために必要です。
  • SQL ServerインスタンスとSSMSは、どちらもバージョン2014であり、問題はありません。
  • SQL Server 2016ソフトウェアが正しく、または完全に削除されなかったため、DDBEAのインストールでは、見つからないSQL 2016 ADO.net ドライバーを使用して接続しようとしました。
データベースのバックアップはすべてエラーで失敗します。 
 ddbmsqlsv NSR critical Cannot login to SQL Server Default Instance.
 ddbmsqlsv: Unable to complete the SQL connection

Resolution

この問題を解決するには、

まずDDBEAをアンインストールします。   次に、次のいずれかを実行します。

A)必要なSQLバージョンが2014の場合は、SQL Server 2014

をアンインストールしてから再インストールします。B)必要なSQLバージョンが2016で、正しくアンインストールされなかった場合は、SQL Server 2016の新規インストールを実行します。

上記を行った後、DDBEAを再インストールします。
Article Properties
Article Number: 000161829
Article Type: Solution
Last Modified: 27 May 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.