PowerStore: Systemtilstandskontrol kan rapportere flere fejl efter CP-genstart PowerStoreOS 3.2 eller 3.5
Summary: Denne artikel beskriver, hvordan du kan opstå følgende problem efter en CP-genstart (inklusive NDU) på et PowerStoreOS 3.2- eller 3.5-system. - Kørsel af et systemtilstandstjek kan resultere i flere mislykkede kontroller. - Replikeringssessioner kan også være i en systempausetilstand. - Det er ikke muligt at tilføje et fjernsystem. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- Systemtjekket kan returnere følgende mislykkede kontroller:
- Replikeringssessioner kan være i en systempausetilstand.
Pre-Upgrade Check node_a Failed PUHC health check returned 3 failed checks. Checking SFP Alerts Failed Checking Active Imports Failed Checking Storage Migrations Failed REST Configuration Service node_a Failed Unable to perform health check due to communication error.
- Replikeringssessioner kan være i en systempausetilstand.
Alert 0x01302d03 Data transfer is paused for file system replication session Alert 0x01700403 A replication session associated with resource VolumeABC123 is in System_Paused state because of error.
- Forsøg på at tilføje et fjernsystem kan mislykkes med det samme eller efter 60 sekunder.
Cause
Dette problem var et resultat af et softwareproblem siden 3.2.
Der er flere certifikater, hvilket svarer til flere IP-adresser, som klyngen bruger.
Under CP-genstart (kan ske under NDU, da vi genstarter CP under NDU, kan også ske under manuel CP-genstart eller enhver anden CP-genstart, mens du kører på den berørte version), er der en løbsbetingelse om, at CP ikke kan indlæse alle korrekte certifikater hele tiden under hver genstart.
Som følge heraf kan kommunikation, der er afhængig af certifikat, blive påvirket, herunder for eksempel:
- Replikeringsmgmt-forbindelse brudt og replikeringssessioner påvirket.
- Tilstandskontrol af systemet mislykkedes.
- Kan ikke tilføje et fjernsystem til konfiguration af replikering.
Der er flere certifikater, hvilket svarer til flere IP-adresser, som klyngen bruger.
Under CP-genstart (kan ske under NDU, da vi genstarter CP under NDU, kan også ske under manuel CP-genstart eller enhver anden CP-genstart, mens du kører på den berørte version), er der en løbsbetingelse om, at CP ikke kan indlæse alle korrekte certifikater hele tiden under hver genstart.
Som følge heraf kan kommunikation, der er afhængig af certifikat, blive påvirket, herunder for eksempel:
- Replikeringsmgmt-forbindelse brudt og replikeringssessioner påvirket.
- Tilstandskontrol af systemet mislykkedes.
- Kan ikke tilføje et fjernsystem til konfiguration af replikering.
Resolution
Løsning:
- Løsning på PUHC-fejl: Genstart Control Path (CP) igen,og udfør et systemtilstandstjek efter fem minutter.
svc_container_mgmt restart CP
BEMÆRK: Hvis en anden CP-genstart ikke løser problemet, skal du vente i 15 minutter og genstarte CP igen.
Genstart af CP (administrationsservices) påvirker ikke værtsadgang og bør kun medføre et kort tab af adgang til PowerStore Manager-brugergrænsefladen (UI).
Genstart af CP (administrationsservices) påvirker ikke værtsadgang og bør kun medføre et kort tab af adgang til PowerStore Manager-brugergrænsefladen (UI).
- Løsning på problem med replikeringspause:
1. Genstarte CP igen på det problematiske apparat.
2. Genoptag replication_session på brugergrænsefladen i kildesystemet. Tjek resultatet.
– Løsning på problemet "kan ikke tilføje fjernsystem":
1. Genstart CP på det problematiske apparat.
2. Prøv "add remote system" igen på kildesystemets brugergrænseflade. Tjek resultatet.
BEMÆRK: Hvis en anden CP-genstart ikke løser problemet, skal du vente i 15 minutter og genstarte CP igen.
Genstart af CP (administrationsservices) påvirker ikke værtsadgang og bør kun medføre et kort tab af adgang til PowerStore Manager-brugergrænsefladen (UI).
Genstart af CP (administrationsservices) påvirker ikke værtsadgang og bør kun medføre et kort tab af adgang til PowerStore Manager-brugergrænsefladen (UI).
Rettelse:
Løsningen på dette problem findes i PowerStoreOS 3.6.Affected Products
PowerStore, PowerStore 1000T, PowerStore 1200T, PowerStore 3000T, PowerStore 3200T, PowerStore 5000T, PowerStore 500T, PowerStore 5200T, PowerStore 7000T, PowerStore 9000TProducts
PowerStore 9200TArticle Properties
Article Number: 000216753
Article Type: Solution
Last Modified: 26 Feb 2024
Version: 8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.