Авамар: Не вдається створити резервне копіювання Windows VSS із повідомленням про помилку «Код 0x80070005 Доступ заборонено»
Summary: Не вдається виконати резервне копіювання Windows Volume Shadow Copy Service (VSS) із повідомленням про помилку "код 0x80070005 Доступ заборонено".
Symptoms
Збій резервного копіювання Windows VSS
Резервне копіювання стану системи Windows VSS не вдається отримати повідомлення про помилки, подібні до наведених нижче:
2015-12-11 07:17:22 avvss Error <8336>: VSS exception code 0x80070005 thrown creating object - 'code 0x80070005: Access is denied'
2015-12-11 07:17:22 avvss Error <0000>: Failed to allocate VSS client, exiting
- Службу Avagent може бути настроєно на роботу з обліковим записом домену NT, оскільки резервні копії Avamar SQL також виконуються на цьому ж клієнті.
- Обліковому запису NT Authority/SYSTEM не було надано роль сисадміна в SQL Server Management Studio, яка потрібна для резервного копіювання баз даних SQL.
Cause
Основна причина збою резервного копіювання Windows VSS
Основна причина помилки з помилкою «Доступ заборонено» пов'язана з тим, що службу резервного агента (Avagent) налаштовано з обліковим записом домену NT. Цей обліковий запис не має достатніх дозволів для операцій тіньового копіювання VSS.
За замовчуванням служба Avagent налаштована на роботу з локальним обліковим записом SYSTEM, який має необхідні права. Однак, коли служба налаштована на роботу з обліковим записом домену NT, вона не має необхідних дозволів, що призводить до помилки «Доступ заборонено».
Конкретний код помилки, пов'язаний із цією проблемою, – 0x80070005, що вказує на помилку відмови в доступі.
Error code: 0x80070005
Error message: Access is denied
Сприяючі фактори
- Обліковий запис домену NT, який використовується для налаштування служби Avagent, не має ролі сисадміна в SQL Server Management Studio, яка потрібна для резервного копіювання баз даних SQL.
- Резервні копії Avamar SQL також відбуваються на тому ж клієнті, що може бути пов'язано з конфігурацією служби Avagent.
Resolution
Вирішення збою резервного копіювання Windows VSS
Щоб вирішити помилку резервного копіювання Windows VSS, виконайте такі дії:
- Відкрийте regedit у клієнті Windows, щоб відредагувати реєстр, і дотримуйтесь найкращих практик щодо зміни regedit.
- Перейдіть до розділу реєстру HKLM/System/CurrentControlSet/Services/VSS.
- Клацніть правою кнопкою миші клавішу VssAccessControl і додайте нове значення DWORD (32-розрядне).
- Назвіть його доменом\ім'ям користувача облікового запису служби Avagent і встановіть значення 1.
- Вийдіть з редактора реєстру (перезавантаження не потрібне).
Виконавши наведені вище дії, переконайтеся, що проблему успішно вирішено, перевіривши журнали резервного копіювання на наявність будь-яких повідомлень про помилки, пов'язаних із резервними копіями VSS.
Для цього вирішення не потрібні спеціальні інструменти або програмне забезпечення, крім редактора реєстру Windows (regedit).
Перевірте свої дозволи перед редагуванням реєстру та дотримуйтесь найкращих практик для запобігання проблемам.
Редагування реєстру може спричинити нестабільність системи, якщо зробити це неправильно. Дійте обережно та подумайте про резервне копіювання реєстру, перш ніж вносити зміни.