Les périodes de rétention des sauvegardes des logs SQL de PowerProtect Data Manager ne correspondent pas aux sites source et de destination

Summary: La période répliquée pour les sauvegardes de log pour SQL affiche une période de rétention incorrecte du côté destination.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Les sauvegardes des logs SQL de PowerProtect Data Manager (PPDM) sont enregistrées en tant que sauvegarde complète sur le site de destination avec une politique de rétention de 90 jours. La période de rétention réellement définie est de 30 jours.

Cause

Le nombre de copies de réplication de la source vers la destination ne correspond pas.
Rétention définie au niveau de la politique pour la sauvegarde et la réplication :
  • Sauvegarde complète : 90 Jours
  • Sauvegarde différentielle : 90 Jours
  • Sauvegarde des logs : 30 jours
Ce comportement est dû aux recommandations de Microsoft pour les sauvegardes SQL, car l’appliance PPDM ne prend pas en charge les sauvegardes différentielles sur les réplicas Microsoft SQL de destination secondaires. Il s’agit d’une limitation de Microsoft SQL Server et elle fonctionne normalement.
Cette limitation est également consignée dans les fichiers journaux.

Fichier journal
Les propriétés du groupe de disponibilité SQL affichent « Any replica » sur le snapshot ci-dessous. Il est recommandé de modifier les propriétés du groupe de disponibilité en remplaçant l’option « Any replica » par l’option « Prefer Secondary ».

Groupe de disponibilité pointant vers
 

Resolution

L’administrateur SQL doit remplacer les préférences de sauvegarde du groupe de disponibilité « XXXXX » par le paramètre « Prefer Secondary ». Une fois que cette modification de configuration a été effectuée du côté SQL, surveillez les sauvegardes du serveur SQL. Vérifiez si la période de rétention correspond aux sites source et de destination.
 
Groupe de disponibilité pointant vers
 

Affected Products

Data Domain, PowerProtect Data Manager Appliance, PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, PowerProtect Data Protection Hardware
Article Properties
Article Number: 000218342
Article Type: Solution
Last Modified: 30 Apr 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.