Avamar: Avamar Filesystem backup of Solaris Client fails with Signal 11 exit - Segmentation Fault due to shortage of swap space
Summary: Avamar Filesystem backup of Solaris Client fails with Signal 11 exit - Segmentation Fault
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Avamar Filesystem backup of Solaris Client fails with Signal 11 exit - Segmentation Fault.
The Solaris client's available RAM memory during backup is >20GB.
The Solaris client's available Swap Space is around 256 MB.
avagent log (with debug enabled) shows:
[agent_ctl_sup] ctl_manbase::process_message() done
[ctl_mcs_send] wrapup message: errorrealm: Signal 11 exit - Segmentation Fault, error_exitcode:157, errorcode: 10007
[ctl_mcs_send] wrapup message: errorrealm: Signal 11 exit - Segmentation Fault, error_exitcode:157, errorcode: 10007
The avtar log may stop abruptly without addition information or produce the following error:
avtar Error <0000>: memory no longer available failed when writing to a file in a container for backup, length <length> bytes at offset <offset>, remaining bytes <number_of_bytes>
There may be a core file in /opt/AVMRclnt/var directory.
Cause
The Solaris Operating System is reserving swap space even though there is plenty of memory available, however the amount of swap space is limited and the OS is returning to the backup that there is not enough memory available. This causes the backup to fail or crash producing a core file.
Resolution
Engage the Solaris Administrator to add an extra 4GB of swap space to the Operating System.
Additional Information
Information about gathering client logs can be found at KB 470483 - Gathering log files for troubleshooting Avamar client issues.
Affected Products
AvamarProducts
AvamarArticle Properties
Article Number: 000052404
Article Type: Solution
Last Modified: 20 May 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.