kernel: emcpowerX: emcpowerX1 streaming errors logged in /var/log/messages with PowerPath 6.3 for Linux

Summary: Error messages such as " kernel: emcpowerX: emcpowerX1" streaming and logged in /var/log/messages, up to a point where the host is nearly frozen.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Upgrade PowerPath to 6.3 P01, or install PowerPath 6.3 P01.

OS : Linux 6.9 with kernel 2.6.32-696.30.1.el6.x86_64 
OS : Linux 6.8 with kernel 2.6.32-642.el6.x86_64
Note: The OS version is not significant.
DELL EMC SW: PowerPath for Linux 6.3 P01

Note: Although the error has been reported only with PowerPath 6.3 P01, it can also happen with PowerPath 6.4 or PowerPath 6.5 for Linux. This KB is focusing on PowerPath 6.3 P01 but the resolution would be the same with PowerPath 6.4 or PowerPath 6.5 installed on a retpoline compiled kernel.

Errors similar to the below messages are logged /var/log/messages, constantly, up to a point where the host is nearly completely frozen.
The same host has no issue with PowerPath version 6.2.

Jun 12 20:20:33 ncxxxxxxxx-xxp kernel: emcpoweri: emcpoweri1
Jun 12 20:20:33 ncxxxxxxxx-xxp kernel: emcpowern: emcpowern1
Jun 12 20:20:33 ncxxxxxxxx-xxp kernel: emcpowers: emcpowers1
Jun 12 20:20:33 ncxxxxxxxx-xxp kernel: emcpowerp: emcpowerp1
Jun 12 20:20:33 ncxxxxxxxx-xxp kernel: emcpowerq:
Jun 12 20:20:33 ncxxxxxxxx-xxp kernel: emcpowerf: emcpowerq1
Jun 12 20:20:33 ncxxxxxxxx-xxp kernel: emcpowerf1

Cause

According to PowerPath Engineering, the kernel is logging these messages during partition reread on emcpowerX devices.
This can happen in multiple scenarios:
  • Running partition utilities such as:

           blockdev --rereadpt /dev/emcpowerX

  • Partition creation on emcpowerX devices.
  • Creation of emcpowerX devices during configuration as part of PowerPath start.
  • Sector 0 write of the device.

 

Resolution

PowerPath 7.0 is fixing the issue. However, PowerPath 7.0 can only work on a retpoline compiled kernel. An environment where PowerPath 6.3 P01 is installed has a non retpoline compiled kernel. Once PowerPath 7.0 is installed, a message similar to the following will be displayed :

[root@hostname ~]# rpm  Uvh DellEMCPower.LINUX-7.0.0.00.00-064.RHEL6.x86_64.rpm
Preparing... ########################################### [100%]
1:EMCpower.LINUX ########################################### [100%]
All trademarks used herein are the property of their respective owners.
NOTE:License registration is not required to manage the CLARiiON AX series
array.
*** IMPORTANT ***
Please check the following configurations before starting PowerPath:
- Add _netdev to /etc/fstab mount options for PowerPath pseudo devices.
- Ensure netfs service is started.
netfs service is needed to mount devices with _netdev option.
- Set LVM filter in /etc/lvm/lvm.conf according to PowerPath recommendation.
- Blacklist all devices in /etc/multipath.conf and stop multipathd service.
- Install PowerPath license(s) and ensure that policy is not set to
BasicFailover.
- If no license is available, ensure that only one HBA port is active in
the host.
PowerPath supports only single-HBA configuration when unlicensed.
Warning: This version of PowerPath will work only on retpoline enabled kernels.
Refer to PowerPath Installation and Administration Guide for details.
and before upgrading PowerPath, an OS update needs to be completed.  


When PowerPath is upgraded from an earlier version to 6.5 on a non-retpoline kernel, and then after the upgrade is completed, it should not be started as it fails to start. The kernel must be upgraded to a retpoline compiler and then the host must be rebooted. Once the host reboots, PowerPath 7.0 starts normally on the new retpoline kernel.

Products

PowerPath for Linux
Article Properties
Article Number: 000055307
Article Type: Solution
Last Modified: 20 Nov 2020
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.