RecoverPoint и RecoverPoint для виртуальных машин: Сеанс интерфейса командной строки аварийно завершается при выполнении команд с сообщением «Killed».

Summary: RecoverPoint. Сеанс интерфейса командной строки аварийно завершается сообщением «Killed»; Это сообщение может не отображаться, если сеанс выполняется через PuTTY, так как PuTTY может закрыть окно. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Причиной этой проблемы может быть множество комбинированных изменений интерфейса командной строки в крупномасштабной среде. Выполнение команд в крупных средах может привести к аварийному завершению сеансов интерфейса командной строки.

Если окно остается открытым, пользователь может заметить сообщение «Убито»:

Cluster1> add_replication_volume group=CG copy=Copy1 replication_set=RSet1 name=device_DEV01
Cluster1> add_replication_volume group=CG copy=Copy1 replication_set=RSet2 name=device_DEV02
Cluster1> add_replication_volume group=CG copy=Copy1 replication_set=RSet3 name=device_DEV03
 
Killed


В журналах интерфейса командной строки может отображаться следующее (extracted.*/files/home/kos/cli/result.xx.log):

2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: Handling command: create_replication_set
2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: In CommandHandler::handleCommand(..)
2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: In CreateReplicationSetHandler::initDataMembers()
2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: In CommandHandler::initDataMembers()
2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: m_settingsCache is relevant, returning
2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: Calling Mgmt::getState()
2018/07/29 21:32:49.949 - #2 - 11944/11940 - MemoryShield: totalMemory = 827.188 [MB] resMemory = 331.613 [MB] shrMemory = 73.7656 [MB]
2018/07/29 21:32:49.949 - #0 - 11944/11940 - MemoryShield: errno=0 memory low watermark exceeded, current=347721728 totalMemory = 827.188 [MB] resMemory = 331.613 [MB] shrMemory = 73.7656 [MB], limit=283115520
2018/07/29 21:32:49.949 - #0 - 11944/11940 - MemoryShield: errno=0 memory high watermark exceeded, current=347721728 totalMemory = 827.188 [MB] resMemory = 331.613 [MB] shrMemory = 73.7656 [MB], limit=314572800
2018/07/29 21:32:49.949 - #0 - 11944/11940 - MemoryShield: errno=0 memory shield discovered an error !!!
2018/07/29 21:32:49.949 - #2 - 11944/11940 - DLManager: dumpDetectors
2018/07/29 21:32:49.949 - #2 - 11944/11940 - DLManager: running status for N6Kashya29MemoryShieldScheduler_AO_IMPLE, pid=11944/11940, config=(alertThreshold=10,alertLevel=0,killThreshold=7200,coreThreshold=0,full=1), deltaTime=0, cmd=N6Kashya59MemoryShieldScheduler_AO_IMPL_printStatistics_6_CmdConcreteE
2018/07/29 21:32:49.949 - #0 - 11944/11940 - MemoryShield: errno=0 Assertion failed: false Line 285 File MemoryShield.cc PID: 11940 Info: memory limit exceeded, no core
END OF LOGGER

Cause

Из-за размера среды и большого количества изменений, объединенных в одном сеансе интерфейса командной строки, процесс CLI достигает предела памяти и происходит сбой.

Например, при создании группы консистентности многие изменения объединяются в edit_group_settings как одно изменение. Другой пример: «heavier" команды типа get_group_statistics.

Resolution

Решение:
Следующий подписанный сценарий можно запустить на IP-адресе кластера с помощью putty/ssh > [ 2 ] Настройка -> [ 8 ] Дополнительные параметры -> [ 4 ] Запустить сценарий .

 

ZWE0M2YwMTIzYzg5ZWRhZjk2MzIwYzAzNzA0MzI5YzIKdW5saW1pdGVkCm5vdF9yZXN0cmljdGVk
ClRoZSBpZCBvZiB0aGUgc2NyaXB0IGlzOjAwMDE2NzExNQpDcmVhdGUgYW4gb3V0cHV0IGZpbGUg
Zm9yIGdyb3VwIHN0YXRpc3RpY3MgaW4gbGFyZ2UgZW52aXJvbm1lbnRzCk5pdiBOZXRhbmVsaQoj
IS9iaW4vY3NoCmVjaG8gZ2V0X2dyb3VwX3N0YXRpc3RpY3MgLW4gPiAvaG9tZS93d3cvaW5mby9H
cm91cF9TdGF0cy5vdXRwdXQKY2htb2QgK3IgL2hvbWUvd3d3L2luZm8vR3JvdXBfU3RhdHMub3V0
cHV0CmZvcmVhY2ggQ0cgKCBgc3UgYWRtaW4gLWMgImdldF9ncm91cHMgLW4iIHwgZWdyZXAgIl4g
IFtbOmFsbnVtOl1dIiB8IHNlZCBzLVwgXCAtLWcgfCBzZWQgcy1cOi0tZ2AgKQojICBlY2hvICRD
RwogIHN1IGFkbWluIC1jICJnZXRfZ3JvdXBfc3RhdGlzdGljcyBncm91cD0kQ0ciID4+IC9ob21l
L3d3dy9pbmZvL0dyb3VwX1N0YXRzLm91dHB1dAplbmQKc2V0ZW52IEVUSCBgZ3JlcCBldGggL2hv
bWUva29zL2NvbnRyb2wvYWNxdWlyZUlQLnRjc2ggfCBhd2sgJ3twcmludCAkN30nIHxncmVwIGV0
aGAKc2V0ZW52IElQIGBpcCBhZGQgfCBncmVwICJnbG9iYWwgJEVUSCIgfCBoZWFkIC1uMXxhd2sg
J3twcmludCAkMn0nIHwgc2VkICJzL1wvLiovLyJgCmVjaG8gR3JvdXAgU3RhdGlzdGljcyBmaWxl
IGF2YWlsYWJsZSBodHRwczovLyRJUC9pbmZvCmV4aXQgMAo=
#

Выходной файл создан https://{RPA-IP}/info/Group_Stats.output.


Временное решение 2.
Для этой проблемы существует решение, но требуется вмешательство сотрудников службы технической поддержки Dell Technologies. Персоналу службы поддержки необходим доступ к устройствам Site Control для внутренних изменений. Для получения технической поддержки обратитесь в центр поддержки заказчиков Dell Technologies или к своему менеджеру по обслуживанию и укажите идентификатор решения из базы знаний Dell Technologies.

Affected Products

RecoverPoint, RecoverPoint CL, RecoverPoint EX, RecoverPoint for Virtual Machines

Products

RecoverPoint SE
Article Properties
Article Number: 000167115
Article Type: Solution
Last Modified: 16 Jan 2026
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.