Sanal Makineler için RecoverPoint ve RecoverPoint: CLI oturumu, komutlar çalıştırıldığında "Killed" mesajıyla anormal şekilde sona erer.

Summary: RecoverPoint: CLI oturumu anormal bir şekilde "Öldürüldü" mesajıyla sona eriyor; Oturum PuTTY aracılığıyla çalıştırılırsa PuTTY pencereyi kapatabileceğinden bu mesaj görünmeyebilir.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Büyük ölçekli bir ortamda çok sayıda birleştirilmiş CLI değişikliği bu soruna neden olabilir. Komutları büyük ortamlarda çalıştırmak CLI oturumlarının anormal şekilde kapanmasına neden olabilir.

Pencere açık kalırsa, kullanıcı bir "Öldürüldü" mesajı görebilir:

Cluster1> add_replication_volume group=CG copy=Copy1 replication_set=RSet1 name=device_DEV01
Cluster1> add_replication_volume group=CG copy=Copy1 replication_set=RSet2 name=device_DEV02
Cluster1> add_replication_volume group=CG copy=Copy1 replication_set=RSet3 name=device_DEV03
 
Killed


CLI günlüklerinde aşağıdakiler görünebilir (extracted.*/files/home/kos/cli/result.xx.log):

2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: Handling command: create_replication_set
2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: In CommandHandler::handleCommand(..)
2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: In CreateReplicationSetHandler::initDataMembers()
2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: In CommandHandler::initDataMembers()
2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: m_settingsCache is relevant, returning
2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: Calling Mgmt::getState()
2018/07/29 21:32:49.949 - #2 - 11944/11940 - MemoryShield: totalMemory = 827.188 [MB] resMemory = 331.613 [MB] shrMemory = 73.7656 [MB]
2018/07/29 21:32:49.949 - #0 - 11944/11940 - MemoryShield: errno=0 memory low watermark exceeded, current=347721728 totalMemory = 827.188 [MB] resMemory = 331.613 [MB] shrMemory = 73.7656 [MB], limit=283115520
2018/07/29 21:32:49.949 - #0 - 11944/11940 - MemoryShield: errno=0 memory high watermark exceeded, current=347721728 totalMemory = 827.188 [MB] resMemory = 331.613 [MB] shrMemory = 73.7656 [MB], limit=314572800
2018/07/29 21:32:49.949 - #0 - 11944/11940 - MemoryShield: errno=0 memory shield discovered an error !!!
2018/07/29 21:32:49.949 - #2 - 11944/11940 - DLManager: dumpDetectors
2018/07/29 21:32:49.949 - #2 - 11944/11940 - DLManager: running status for N6Kashya29MemoryShieldScheduler_AO_IMPLE, pid=11944/11940, config=(alertThreshold=10,alertLevel=0,killThreshold=7200,coreThreshold=0,full=1), deltaTime=0, cmd=N6Kashya59MemoryShieldScheduler_AO_IMPL_printStatistics_6_CmdConcreteE
2018/07/29 21:32:49.949 - #0 - 11944/11940 - MemoryShield: errno=0 Assertion failed: false Line 285 File MemoryShield.cc PID: 11940 Info: memory limit exceeded, no core
END OF LOGGER

Cause

Ortamın boyutu ve birçok değişikliğin aynı CLI oturumunda birleştirilmesi nedeniyle CLI işlemi bellek sınırına ulaşır ve çöker.

Örneğin, bir Tutarlılık Grubu oluştururken, birçok değişiklik edit_group_settings komutu tek bir değişiklik olarak kullanın. Başka bir örnek de "heavier" gibi komutlar get_group_statistics.

Resolution

Geçi -ci çözüm:
Aşağıdaki imzalı komut dosyası, putty/ssh > [2] Kurulum -> [8] Gelişmiş seçenekler -> [4] Run script kullanılarak Küme IP'sinde çalıştırılabilir.

 

ZWE0M2YwMTIzYzg5ZWRhZjk2MzIwYzAzNzA0MzI5YzIKdW5saW1pdGVkCm5vdF9yZXN0cmljdGVk
ClRoZSBpZCBvZiB0aGUgc2NyaXB0IGlzOjAwMDE2NzExNQpDcmVhdGUgYW4gb3V0cHV0IGZpbGUg
Zm9yIGdyb3VwIHN0YXRpc3RpY3MgaW4gbGFyZ2UgZW52aXJvbm1lbnRzCk5pdiBOZXRhbmVsaQoj
IS9iaW4vY3NoCmVjaG8gZ2V0X2dyb3VwX3N0YXRpc3RpY3MgLW4gPiAvaG9tZS93d3cvaW5mby9H
cm91cF9TdGF0cy5vdXRwdXQKY2htb2QgK3IgL2hvbWUvd3d3L2luZm8vR3JvdXBfU3RhdHMub3V0
cHV0CmZvcmVhY2ggQ0cgKCBgc3UgYWRtaW4gLWMgImdldF9ncm91cHMgLW4iIHwgZWdyZXAgIl4g
IFtbOmFsbnVtOl1dIiB8IHNlZCBzLVwgXCAtLWcgfCBzZWQgcy1cOi0tZ2AgKQojICBlY2hvICRD
RwogIHN1IGFkbWluIC1jICJnZXRfZ3JvdXBfc3RhdGlzdGljcyBncm91cD0kQ0ciID4+IC9ob21l
L3d3dy9pbmZvL0dyb3VwX1N0YXRzLm91dHB1dAplbmQKc2V0ZW52IEVUSCBgZ3JlcCBldGggL2hv
bWUva29zL2NvbnRyb2wvYWNxdWlyZUlQLnRjc2ggfCBhd2sgJ3twcmludCAkN30nIHxncmVwIGV0
aGAKc2V0ZW52IElQIGBpcCBhZGQgfCBncmVwICJnbG9iYWwgJEVUSCIgfCBoZWFkIC1uMXxhd2sg
J3twcmludCAkMn0nIHwgc2VkICJzL1wvLiovLyJgCmVjaG8gR3JvdXAgU3RhdGlzdGljcyBmaWxl
IGF2YWlsYWJsZSBodHRwczovLyRJUC9pbmZvCmV4aXQgMAo=
#

Çıktı dosyası şurada oluşturulur: https://{RPA-IP}/info/Group_Stats.output.


Geçici Çözüm 2:
Bu sorun için bir çözüm mevcuttur ancak Dell Technologies teknik destek personelinin müdahalesi gerekmektedir. Destek personeli, dahili bir değişiklik için Site Denetimi cihazlarınıza erişmelidir. Teknik destek için Dell Technologies Müşteri Destek Merkezi veya servis temsilcinizle iletişime geçin ve bu Dell Technologies Knowledge Base çözüm kimliğine başvurun.

Affected Products

RecoverPoint, RecoverPoint CL, RecoverPoint EX, RecoverPoint for Virtual Machines

Products

RecoverPoint SE
Article Properties
Article Number: 000167115
Article Type: Solution
Last Modified: 16 Jan 2026
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.