RecoverPoint 和 RecoverPoint for VMs:运行命令时,CLI 会话异常结束并显示“已终止”消息。
Summary: RecoverPoint:CLI 会话异常结束,并显示“已终止”消息;如果会话通过 PuTTY 运行,则可能不会显示此消息,因为 PuTTY 可能会关闭窗口。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
大型环境中的许多组合 CLI 更改可能会导致此问题。在大型环境中运行命令可能会导致 CLI 会话异常关闭。
如果窗口保持打开状态,用户可能会注意到“已终止”消息:
Cluster1> add_replication_volume group=CG copy=Copy1 replication_set=RSet1 name=device_DEV01 Cluster1> add_replication_volume group=CG copy=Copy1 replication_set=RSet2 name=device_DEV02 Cluster1> add_replication_volume group=CG copy=Copy1 replication_set=RSet3 name=device_DEV03 Killed
CLI 日志中可能会出现以下内容 (extracted.*/files/home/kos/cli/result.xx.log):
2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: Handling command: create_replication_set 2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: In CommandHandler::handleCommand(..) 2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: In CreateReplicationSetHandler::initDataMembers() 2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: In CommandHandler::initDataMembers() 2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: m_settingsCache is relevant, returning 2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: Calling Mgmt::getState() 2018/07/29 21:32:49.949 - #2 - 11944/11940 - MemoryShield: totalMemory = 827.188 [MB] resMemory = 331.613 [MB] shrMemory = 73.7656 [MB] 2018/07/29 21:32:49.949 - #0 - 11944/11940 - MemoryShield: errno=0 memory low watermark exceeded, current=347721728 totalMemory = 827.188 [MB] resMemory = 331.613 [MB] shrMemory = 73.7656 [MB], limit=283115520 2018/07/29 21:32:49.949 - #0 - 11944/11940 - MemoryShield: errno=0 memory high watermark exceeded, current=347721728 totalMemory = 827.188 [MB] resMemory = 331.613 [MB] shrMemory = 73.7656 [MB], limit=314572800 2018/07/29 21:32:49.949 - #0 - 11944/11940 - MemoryShield: errno=0 memory shield discovered an error !!! 2018/07/29 21:32:49.949 - #2 - 11944/11940 - DLManager: dumpDetectors 2018/07/29 21:32:49.949 - #2 - 11944/11940 - DLManager: running status for N6Kashya29MemoryShieldScheduler_AO_IMPLE, pid=11944/11940, config=(alertThreshold=10,alertLevel=0,killThreshold=7200,coreThreshold=0,full=1), deltaTime=0, cmd=N6Kashya59MemoryShieldScheduler_AO_IMPL_printStatistics_6_CmdConcreteE 2018/07/29 21:32:49.949 - #0 - 11944/11940 - MemoryShield: errno=0 Assertion failed: false Line 285 File MemoryShield.cc PID: 11940 Info: memory limit exceeded, no core END OF LOGGER
Cause
由于环境的大小以及同一 CLI 会话中合并的许多更改,CLI 进程达到其内存限制并崩溃。
例如,在创建一致性组时,许多更改会合并到 edit_group_settings 命令作为单个更改。另一个例子是”heavier“命令,例如 get_group_statistics.
Resolution
解决 方案:
可以使用 putty/ssh > 在群集 IP 上运行以下签名脚本:[2] Setup -> [8] Advanced options -> [4] Run script。
ZWE0M2YwMTIzYzg5ZWRhZjk2MzIwYzAzNzA0MzI5YzIKdW5saW1pdGVkCm5vdF9yZXN0cmljdGVk ClRoZSBpZCBvZiB0aGUgc2NyaXB0IGlzOjAwMDE2NzExNQpDcmVhdGUgYW4gb3V0cHV0IGZpbGUg Zm9yIGdyb3VwIHN0YXRpc3RpY3MgaW4gbGFyZ2UgZW52aXJvbm1lbnRzCk5pdiBOZXRhbmVsaQoj IS9iaW4vY3NoCmVjaG8gZ2V0X2dyb3VwX3N0YXRpc3RpY3MgLW4gPiAvaG9tZS93d3cvaW5mby9H cm91cF9TdGF0cy5vdXRwdXQKY2htb2QgK3IgL2hvbWUvd3d3L2luZm8vR3JvdXBfU3RhdHMub3V0 cHV0CmZvcmVhY2ggQ0cgKCBgc3UgYWRtaW4gLWMgImdldF9ncm91cHMgLW4iIHwgZWdyZXAgIl4g IFtbOmFsbnVtOl1dIiB8IHNlZCBzLVwgXCAtLWcgfCBzZWQgcy1cOi0tZ2AgKQojICBlY2hvICRD RwogIHN1IGFkbWluIC1jICJnZXRfZ3JvdXBfc3RhdGlzdGljcyBncm91cD0kQ0ciID4+IC9ob21l L3d3dy9pbmZvL0dyb3VwX1N0YXRzLm91dHB1dAplbmQKc2V0ZW52IEVUSCBgZ3JlcCBldGggL2hv bWUva29zL2NvbnRyb2wvYWNxdWlyZUlQLnRjc2ggfCBhd2sgJ3twcmludCAkN30nIHxncmVwIGV0 aGAKc2V0ZW52IElQIGBpcCBhZGQgfCBncmVwICJnbG9iYWwgJEVUSCIgfCBoZWFkIC1uMXxhd2sg J3twcmludCAkMn0nIHwgc2VkICJzL1wvLiovLyJgCmVjaG8gR3JvdXAgU3RhdGlzdGljcyBmaWxl IGF2YWlsYWJsZSBodHRwczovLyRJUC9pbmZvCmV4aXQgMAo= #
输出文件创建于 https://{RPA-IP}/info/Group_Stats.output.
解决方法 2:
此问题存在解决方案,但需要 Dell Technologies 技术支持人员的干预。支持人员必须访问您的站点控制设备以进行内部更改。请联系 Dell Technologies 客户支持中心 或您的服务代表寻求技术支持,并提供此 Dell Technologies 知识库解决方案 ID。
Affected Products
RecoverPoint, RecoverPoint CL, RecoverPoint EX, RecoverPoint for Virtual MachinesProducts
RecoverPoint SEArticle Properties
Article Number: 000167115
Article Type: Solution
Last Modified: 16 Jan 2026
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.