Problem z dostępem SRM do interfejsu użytkownika FE po zaktualizowaniu certyfikatu
Summary: Po przejściu przez "Konfigurowanie protokołu HTTPS przy użyciu certyfikatów podpisanych przez urząd certyfikacji" w przewodniku "M&R Security and Configuration Guide" interfejs użytkownika Frontend(FE) nie jest dostępny. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Przeglądarka może wyświetlać następujące komunikaty podczas uzyskiwania dostępu do FE:
Podczas przeglądania dzienników catalina na serwerze FE mogą pojawić się następujące komunikaty o błędach:
"Upłynął limit czasu połączenia"
""Nie można skontaktować się z tą witryną"
""Nie można skontaktować się z tą witryną"
Podczas przeglądania dzienników catalina na serwerze FE mogą pojawić się następujące komunikaty o błędach:
SEVERE: Nie udało się zainicjować punktu końcowego powiązanego z ProtocolHandler ["http-nio-58443"]
java.security.UnrecoverableKeyException: Nie można odzyskać klucza
LUB
BARDZO: Nie udało się zainicjować łącznika [Connector[HTTP/1.1-58443]]
org.apache.catalina.LifecycleException: Nie udało się zainicjować składnika [Connector[HTTP/1.1-58443]]
Spowodowane przez: org.apache.catalina.LifecycleException: Inicjalizacja programu obsługi protokołu nie powiodła się
Spowodowane przez: java.security.UnrecoverableKeyException: Nie można odzyskać klucza
java.security.UnrecoverableKeyException: Nie można odzyskać klucza
LUB
BARDZO: Nie udało się zainicjować łącznika [Connector[HTTP/1.1-58443]]
org.apache.catalina.LifecycleException: Nie udało się zainicjować składnika [Connector[HTTP/1.1-58443]]
Spowodowane przez: org.apache.catalina.LifecycleException: Inicjalizacja programu obsługi protokołu nie powiodła się
Spowodowane przez: java.security.UnrecoverableKeyException: Nie można odzyskać klucza
Cause
Podczas przechodzenia przez procedurę "Konfigurowanie protokołu HTTPS przy użyciu certyfikatów podpisanych przez urząd certyfikacji" wystąpił problem z hasłem klucza innego niż hasło magazynu kluczy.
Krok, który należy wykonać, aby naprawić tę różnicę, nie jest wymieniony w Podręczniku konfiguracji zabezpieczeń M&R.
Różnica musi być wyraźnie określona w pliku server.xml , w przeciwnym razie interfejs użytkownika FE nie jest dostępny.
Resolution
Na serwerze FE skoryguj następujące błędy:
- Czy podczas importowania magazynu kluczy został utworzony alias dla klucza "apg-aliasname.pfx"?
Ponieważ lokalizacja pliku może nie być taka sama, jak pokazano, wykonaj następujące czynności na serwerze FE:
find / -iname apg-a*
Poszukaj "apg-aliasname.pfx" (rozszerzeniem pliku może być również .PEM lub . CRT).
find / -iname apg-a*
Poszukaj "apg-aliasname.pfx" (rozszerzeniem pliku może być również .PEM lub . CRT).
- Dla klucza "apg-aliasname.pfx" ustawiane jest dowolne hasło.
Jeśli alias klucza i hasło są ustawione, podaj ten alias klucza, hasło klucza, a także hasło magazynu kluczy w pliku server.xml.
Przykład: Dodaj poniższe atrybuty w server.xml.
keystorePass="wstaw hasło magazynu kluczy tutaj"
keyPass="wstaw hasło klucza tutaj"
keyAlias="wstaw tutaj alias klucza prywatnego"/>
Przykład: Dodaj poniższe atrybuty w server.xml.
keystorePass="wstaw hasło magazynu kluczy tutaj"
keyPass="wstaw hasło klucza tutaj"
keyAlias="wstaw tutaj alias klucza prywatnego"/>
- Zaktualizuj i uruchom ponownie wszystkie moduły lub usługi.
PuTTY na hoście lub serwerze FE, przejdź do/opt/APG/bin, uruchom ./manage-modules.sh service update all,a następnie uruchom ./manage-modules.sh service restart all.
- Spróbuj uzyskać dostęp do FE, powinien być teraz dostępny.
Products
SRMArticle Properties
Article Number: 000190501
Article Type: Solution
Last Modified: 07 Oct 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.