VMware vRealize Aria Operations 在建立或刪除新物件期間回報記錄的錯誤

Summary: 在建立物件或刪除物件期間,記錄的 VMware Aria Operations 發生錯誤。不過,手術終於成功了。 觸發此問題的版本為 8.16.0,但可能不僅限於此版本。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

在現有儀錶板或新儀錶板上創建物件(如圖表)時,客戶將看到創建失敗。如果刪除某些圖表,刪除將失敗,但一段時間后,可以看到新儀錶板或現有儀錶板中的新圖表。

圖表操作失敗

創建欄位時,Web 圖形使用者介面將觸發“Cassandra 超時錯誤消息”,但一段時間后,客戶可以看到該字段已創建。

欄位建立逾時

記錄:
[2024-04-22 08:53:04.372+0000] ["CassandraClientParallelExecutor-thread-4152"/10.159.197.195 WARN] [com.vmware.loginsight.cassandra.CassandraClient] [Exception during asynchronous execution (3875612721059898833): Statement:(select guid, count from spock_cluster_counts where guid in ? and bucket = ? limit 1000000) java.util.concurrent.ExecutionException: com.datastax.oss.driver.api.core.servererrors.ReadTimeoutException: Cassandra timeout during read query at consistency QUORUM (2 responses were required but only 1 replica responded). In case this was generated during read repair, the consistency level is not representative of the actual consistency.]
java.util.concurrent.ExecutionException: com.datastax.oss.driver.api.core.servererrors.ReadTimeoutException: Cassandra timeout during read query at consistency QUORUM (2 responses were required but only 1 replica responded). In case this was generated during read repair, the consistency level is not representative of the actual consistency.



即使修改設定檔 /storage/core/loginsight/cidata/cassandra/config/cassandra.yaml 並將write_request_timeout值增加至 3000 毫秒,並為記錄服務重新開機 aria 作業,問題依然持續存在。

Cause

Cassandra 集群存在一些問題。
嘗試在 Aria Operations 下建立記錄欄位時,收到逾時錯誤。
這將涉及用於管理欄位的特定 LI API。

Resolution

若要解決此問題,請重新啟動 Aria Operations 記錄叢集中的所有裝置節點。

Affected Products

OpenManage Management Pack for VMware Aria Operations
Article Properties
Article Number: 000224734
Article Type: Solution
Last Modified: 16 May 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.