Cliente Avamar: El respaldo de imagen de cliente Linux de IDPA se completa con excepción debido a un problema de reposo

Summary: Los clientes de respaldo de imágenes de Linux fallan con el respaldo completado con excepción del código de error 10020

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



El respaldo de imagen de Linux para el sistema IDPA "Se completa con excepción" debido al problema de modo de reposo.

En este ejemplo, la máquina virtual era la máquina virtual interna de ACM que viene con la solución

IDPA. En el registro de imagen de Linux de VMware del respaldo, se puede ver lo siguiente:


avvcbimage Info <40726>: Información de configuración de VM: VMX versión 4 (F), ctk habilitado (T), tolerante a fallas (F), SO invitado SUSE Linux Enterprise 12 (64 bits), UUID de nube = NoUUID. version=9
avvcbimage info <40727>: Información de invitado de VM: Familia GuestOS = linuxGuest, nombre completo del invitado = SUSE Linux Enterprise 12 (64 bits), estado del SO huésped = en ejecución, herramientas en ejecución = guestToolsRunning, estado de la versión de las herramientas = guestToolsUnmanaged
Información de avvcbimage <42650>: Creando la instantánea "Avamar-epoch_time<>< client_id>", quiesceFS=1
avvcbimage Info <41136>: SnapshotManager: createSnapshot para vmMoref = vm-21
avvcbimage Info <42182>: SnapshotManager: POST a /snapshotmanager/vm/vm-21/action/createSnapshot, payload({
"snapshotName": "Avamar-epoch_time <><client_id>",
"snapshotDesc": "Creado por Avamar workorder Management_VM_Backup-Management_VM_Backup-epoch<> on <date>",
"quiesceFileSystem": "cierto"
...
avvcbimage Windows19733<>: La tarea de vSphere falló (en modo de reposo, error de instantánea = 45): "Se produjo un error al guardar la instantánea: No se pudo poner la máquina virtual en modo de reposo".
Error 17775> de <avvcbimage: La creación de la instantánea "Avamar-epoch_time<>< client_id>" para la VM "[vsanDatastore] DataProtection-ACM/DataProtection-ACM.vmx" detectó un problema de reposoen
avvcbimage Advertencia <40710:> La VM no se pudo poner en modo de reposo antes de la creación de la instantánea y este respaldo no se utilizará como base para respaldos de CBT posteriores si se realiza correctamente.
Advertencia 40711> de < avvcbimage:     Considere la posibilidad de usar los scripts previos y posteriores a la descongelación para facilitar el modo de reposo
de las VM Advertencia <de avvcbimage 41146>:     Este error puede deberse a que el script de congelamiento previo devuelve un código de error distinto de cero.
...



Después de que falla la tarea de la primera instantánea, el respaldo continúa tomando la segunda instantánea, pero con la característica de reposo deshabilitada.

Información de avvcbimage <14631>: La tarea de consolidación de discos de VM para la tarea "[vsanDatastore] DataProtection-ACM/DataProtection-ACM.vmx" sigue en curso, se suspende durante 3 segundos
Información <de avvcbimage 42650>: Creando la instantánea 'Avamar-epoch_time <><client_id>', quiesceFS=0
avvcbimage Info <41136>: SnapshotManager: createSnapshot para vmMoref = vm-21
avvcbimage Info <42182>: SnapshotManager: POST a /snapshotmanager/vm/vm-21/action/createSnapshot, payload({
"snapshotName": "Avamar-epoch_time <><client_id>",
"snapshotDesc": "Creado por Avamar workorder Management_VM_Backup-Management_VM_Backup-epoch<> on <date>",
"quiesceFileSystem":  "falso"



El respaldo finaliza, pero se muestra como completado con excepción (código 10020).


En el registro de órdenes de trabajo (.alg), se ve lo siguiente: 

2019-04-03 00:12:42 Management_VM_Backup-Management_VM_Backup-epoch<> Advertencia <0000>: Estado de salida distinto de cero de la orden de trabajo "Management_VM_Backup-Management_VM_Backup-epoch" "Código 170: Completado con errores, se debe examinar el registro del cliente"  

Cause

1. Para ver qué está causando que falle el modo de reposo, configure el registro de depuración para vmtools. 
Los siguientes pasos en https://kb.vmware.com/s/article/1007873 configurar el registro de depuración en el sistema operativo huésped y, a continuación, reiniciar VMware Tools. 

2. Realice un nuevo respaldo para volver a crear la falla de reposo.  

3. Revise los registros de las herramientas de depuración (la información de reposo debe estar en el registro de vmsvc y tener un prefijo [vmbackup]).

En este ejemplo, podemos indicar que el problema fue causado por un directorio /var/log/brs parcialmente eliminado.  Este directorio no se pudo eliminar por completo debido a que el proceso en segundo plano aún tenía el directorio abierto.     Esta carpeta parcialmente eliminada evitará que el sistema de archivos de Linux se congele con funciones ioctls. 


[depuración] [VMbackup] Tarea de inicio de respaldo enviada.
[depuración] [vmbackup] *** VmBackupSyncDriverStart
[ debug] [vmsvc] SyncDriver: Se omite el sistema de archivos remoto, name=systemd-1, mntpt=/proc/sys/fs/binfmt_misc.
[depuración] [vmsvc] Controlador de sincronización: Backend de llamada 0.
[depuración] [vmsvc] Controlador de sincronización: Congelando usando ioctls de Linux...
[depuración] [vmsvc] SyncDriver: abriendo la ruta "/var/lib/named/proc".
[depuración] [vmsvc] SyncDriver: ruta de congelamiento "/var/lib/named/proc".
[depuración] [vmsvc] SyncDriver: se devolvió la congelación en '/var/lib/named/proc': 95 (operación no compatible)
[ debug] [vmsvc] SyncDriver: abriendo la ruta '/var/log/logbundles'.
[depuración] [vmsvc] SyncDriver: ruta de congelamiento "/var/log/logbundles".
[depuración] [vmsvc] SyncDriver: se congeló correctamente "/var/log/logbundles".
[ debug] [vmsvc] SyncDriver: abriendo la ruta '/var/log/brs (deleted)'.
[ debug] [vmsvc] SyncDriver: no se pudo abrir '/var/log/brs (deleted)': 2 (no existe tal archivo o directorio)
[ warning] [vmbackup] Error al congelar los sistemas de archivos.



Resolution

Un examen más detallado de /var/log/brs en el directorio con puede ver problemas para abrir este directorio desde otros comandos. Al igual que lsof y stat, también se muestra el problema. 
IDPA-ACM:/var/log # lsof|grep brs
lsof: ADVERTENCIA: no se puede stat() sistema de archivos xfs /var/log/brs (eliminado)
      Es posible que la información de salida esté incompleta.

IDPA-ACM:/var/log # ls -al
drwxr-xr-x 0 root root 6 27 de febrero de 2018 brs



La máquina virtual de ACM se reinició para interrumpir el proceso de acm en segundo plano.    Después del reinicio, el proceso de ACM volvió a crear el directorio /var/log/brs y el respaldo pudo completarse sin más problemas
de reposoIDPA-ACM:/var/log # ls -al
drwxr-xr-x 2 root root 6 15 abr 10:30 brs

 


Additional Information

Asegúrese de seguir el artículo de la base de conocimientos anterior para eliminar el registro de depuración de vmtools en el cliente y reinicie el servicio vmtools.

Affected Products

Avamar Client

Products

Avamar Client, PowerProtect Data Protection Software
Article Properties
Article Number: 000056249
Article Type: Solution
Last Modified: 11 Oct 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.