Avamar Client: IDPA Linuxクライアント イメージのバックアップが、休止の問題による例外で完了しています
Summary: Linuxイメージ バックアップ クライアントが例外エラー コード10020でバックアップ完了して失敗する
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
休止の問題により、IDPAシステムのLinuxイメージ バックアップが「Completing with Exception」です
この例では、vmはIDPAソリューションに付属する内部ACM VMでした
バックアップのVMware Linuxイメージ ログから、次のように表示されます。
avvcbimage Info <40726>: VM Config Info: VMXバージョン4(F)、ctk有効(T)、フォールト トレラント(F)、ゲストOS SUSE Linux Enterprise 12(64ビット)、Cloud UUID = NoUUID。version = 9
avvcbimage Info <40727>: VM Guest Info: GuestOS Family = linuxGuest、Guest Full Name = SUSE Linux Enterprise 12 (64-bit)、Guest OS State = running、Tools Running = guestToolsRunning、Tools Version Status = guestToolsUnmanaged
avvcbimage Info <42650>: スナップショット「Avamar-<epoch_time><client_id>」を作成しています。quiesceFS = 1
avvcbimage Info <41136>: SnapshotManager: createSnapshot for vmMoref = vm-21
avvcbimage Info <42182>: SnapshotManager: /snapshotmanager/vm/vm-21/action/createSnapshotへのPOST、ペイロード({
"snapshotName": "Avamar<epoch_time><client_id>",
"snapshotDesc": "Created by Avamar workorder Management_VM_Backup-Management_VM_Backup-<epoch > on <date>",
"quiesceFileSystem": "true"
...
avvcbimage Warning <19733>: vSphere タスクが失敗しました (静止、スナップショットエラー = 45): スナップショットの保存中にエラーが発生しました: 仮想マシンの停止に失敗しました。'.
avvcbimage エラー <17775>: VM '[vsanDatastore] DataProtection-ACM/DataProtection-ACM.vmx' のスナップショット 'Avamar-<epoch_time><client_id> ' の作成タスクの作成で、停止プロブレ
mavvcbimageWarning <40710>: スナップショットの作成前にVMを停止できませんでした。成功した場合でも、このバックアップは後続のCBTバックアップのベースとしては使用されません
avvcbimage 警告 <40711>: VMの停止を容易にするために、pre-freezeスクリプトとpost-freewスクリプトの使用を検討してください
avvcbimage 警告 <41146>: このエラーは、pre-freeze スクリプトが 0 以外のエラー コードを返したことが原因で発生する可能性があります
...
1番目のスナップショット タスクが失敗した後、バックアップは2番目のスナップショットを作成して続行されますが、休止機能は無効になります。
avvcbimage Info <14631>: 「[vsanDatastore] DataProtection-ACM/DataProtection-ACM.vmx」タスクの仮想マシン ディスク統合がまだ進行中です。3秒間スリープします
avvcbimage Info <42650>: スナップショット「Avamar-<epoch_time><client_id>」を作成しています。 quiesceFS = 0
avvcbimage Info <41136>: SnapshotManager: createSnapshot for vmMoref = vm-21
avvcbimage Info <42182>: SnapshotManager: /snapshotmanager/vm/vm-21/action/createSnapshotへのPOST、ペイロード({
"snapshotName": "Avamar<epoch_time><client_id>",
"snapshotDesc": "Created by Avamar workorder Management_VM_Backup-Management_VM_Backup-<epoch> on <date>",
"quiesceFileSystem": "false"です
バックアップは完了するが、例外(コード10020)付きで完了と表示される
作業オーダー ログ(alg)では、次のように表示される。
2019-04-03 00:12:42 Management_VM_Backup-Management_VM_Backup-<epoch>Warning <0000>: 作業オーダー「Management_VM_Backup-Management_VM_Backup-epoch」のゼロ以外の終了ステータス「コード170:エラーが発生して完了しました。クライアント ログを調べる必要があります」
Cause
1.停止が失敗する原因を確認するには、vmtoolsのデバッグ ログを設定します。
https://kb.vmware.com/s/article/1007873の手順に従って、ゲスト オペレーティング システムでデバッグ ログを設定してから、VMware Toolsを再起動します。
2.新しいバックアップを実行して、休止エラーを再現します。
3.デバッグ ツールのログを確認します(静止情報はvmsvc ログにあり、[vmbackup]プレフィックスが付いている必要があります)。
この例では、/var/log/brsディレクトリーが部分的に削除されたことが問題の原因であると判断できます。 バックグラウンド プロセスでディレクトリーがまだ開いているため、このディレクトリーを完全に削除できませんでした。 この部分的に削除されたフォルダーは、ioctls関数でLinuxファイルシステムがフリーズするのを防ぎます。
[デバッグ][vmbackup]バックアップ開始タスクを送信しました。
[デバッグ][vmbackup] *** VmBackupSyncDriverStart
[デバッグ] [vmsvc] SyncDriver: リモート ファイルシステムをスキップしています。name=systemd-1、mntpt=/proc/sys/fs/binfmt_misc.
[デバッグ][vmsvc]SyncDriver: 呼び出しバックエンド0.
[デバッグ][vmsvc]SyncDriver: Linux ioctlsを使用してフリーズしています...
[デバッグ][vmsvc]SyncDriver:パス '/var/lib/named/proc'を開きます。
[デバッグ][vmsvc]SyncDriver:パス '/var/lib/named/proc'をフリーズします。
[デバッグ][vmsvc]SyncDriver: フリーズ '/var/lib/named/proc' が返されました: 95(サポートされていない操作)
[デバッグ] [vmsvc] SyncDriver:パス「/var/log/logbundles」を開いています。
[デバッグ][vmsvc]SyncDriver:パス「/var/log/logbundles」をフリーズします。
[デバッグ][vmsvc]SyncDriver: successfully freeze '/var/log/logbundles'.
[デバッグ] [vmsvc] SyncDriver:パス「/var/log/brs(削除済み)」を開きます
[デバッグ] [vmsvc] SyncDriver: '/var/log/brs (deleted)' を開くことができませんでした: 2 (該当するファイルまたはディレクトリはありません)
[警告] [vmbackup] ファイル システムのフリーズ中にエラーが発生しました。
https://kb.vmware.com/s/article/1007873の手順に従って、ゲスト オペレーティング システムでデバッグ ログを設定してから、VMware Toolsを再起動します。
2.新しいバックアップを実行して、休止エラーを再現します。
3.デバッグ ツールのログを確認します(静止情報はvmsvc ログにあり、[vmbackup]プレフィックスが付いている必要があります)。
この例では、/var/log/brsディレクトリーが部分的に削除されたことが問題の原因であると判断できます。 バックグラウンド プロセスでディレクトリーがまだ開いているため、このディレクトリーを完全に削除できませんでした。 この部分的に削除されたフォルダーは、ioctls関数でLinuxファイルシステムがフリーズするのを防ぎます。
[デバッグ][vmbackup]バックアップ開始タスクを送信しました。
[デバッグ][vmbackup] *** VmBackupSyncDriverStart
[デバッグ] [vmsvc] SyncDriver: リモート ファイルシステムをスキップしています。name=systemd-1、mntpt=/proc/sys/fs/binfmt_misc.
[デバッグ][vmsvc]SyncDriver: 呼び出しバックエンド0.
[デバッグ][vmsvc]SyncDriver: Linux ioctlsを使用してフリーズしています...
[デバッグ][vmsvc]SyncDriver:パス '/var/lib/named/proc'を開きます。
[デバッグ][vmsvc]SyncDriver:パス '/var/lib/named/proc'をフリーズします。
[デバッグ][vmsvc]SyncDriver: フリーズ '/var/lib/named/proc' が返されました: 95(サポートされていない操作)
[デバッグ] [vmsvc] SyncDriver:パス「/var/log/logbundles」を開いています。
[デバッグ][vmsvc]SyncDriver:パス「/var/log/logbundles」をフリーズします。
[デバッグ][vmsvc]SyncDriver: successfully freeze '/var/log/logbundles'.
[デバッグ] [vmsvc] SyncDriver:パス「/var/log/brs(削除済み)」を開きます
[デバッグ] [vmsvc] SyncDriver: '/var/log/brs (deleted)' を開くことができませんでした: 2 (該当するファイルまたはディレクトリはありません)
[警告] [vmbackup] ファイル システムのフリーズ中にエラーが発生しました。
Resolution
/var/log/brsディレクトリーを詳しく調べると、このディレクトリーを他のコマンドから開くときに問題が発生することがあります。lsofやstatと同様に、問題も表示されます。
IDPA-ACM:/var/log # lsof|grep brs
lsof: 警告: xfs ファイルシステム /var/log/brs (削除済み) を stat() できません
出力情報が不完全である可能性があります。
IDPA-ACM:/var/log # ls -al
drwxr-xr-x 0 root root 6 Feb 27, 2018 brs
ACM 仮想マシンが再起動され、バックグラウンドの acm プロセスが強制終了されました。 再起動後、/var/log/brsディレクトリーがACMプロセスによって再作成され、それ以上の休止の問題なしにバックアップを完了できました
IDPA-ACM:/ var / log#ls-al
drwxr-xr-x 2ルートルート6 Apr 15 10:30 brs
IDPA-ACM:/var/log # lsof|grep brs
lsof: 警告: xfs ファイルシステム /var/log/brs (削除済み) を stat() できません
出力情報が不完全である可能性があります。
IDPA-ACM:/var/log # ls -al
drwxr-xr-x 0 root root 6 Feb 27, 2018 brs
ACM 仮想マシンが再起動され、バックグラウンドの acm プロセスが強制終了されました。 再起動後、/var/log/brsディレクトリーがACMプロセスによって再作成され、それ以上の休止の問題なしにバックアップを完了できました
IDPA-ACM:/ var / log#ls-al
drwxr-xr-x 2ルートルート6 Apr 15 10:30 brs
Additional Information
上記のKBに従って、クライアント上のvmtoolsのデバッグ ログを削除し、vmtoolsサービスを再起動してください。
Affected Products
Avamar ClientProducts
Avamar Client, PowerProtect Data Protection SoftwareArticle Properties
Article Number: 000056249
Article Type: Solution
Last Modified: 11 Oct 2024
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.