Isilon Gen6: Gen6-strømforsyningen viser en ulæselig streng for produkt-id, og forsøg på firmwareopdatering kan forårsage en genstartssløjfe

Summary: Nogle Gen6-strømforsyninger blev leveret med beskadigede data i deres EEPROM for genoptagelse. Dette kan medføre, at deres produkt-id-streng ikke kan læses, og forsøg på firmwareopdatering mislykkes. Denne fejl kan få noden til at åbne en opstartssløjfe. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Gen6-strømforsyning med beskadigede data i deres genoptagede EEPROMs kan vise en streng med ødelagt/ulæseligt ID. Denne streng kan findes i isi_hw_status:
 
PwrSupl: Slot1-PS0 (type=ARTESYN, fw=02.02)

Ovenstående eksempel viser en upåvirket strømforsyning. På en berørt strømforsyning kan den røde tekst erstattes af ulæselige ikke-teksttegn eller være fraværende helt. Strømforsyninger, der er berørt af dette problem, kan ikke acceptere firmwareopdateringer. hvis du forsøger at opdatere firmwaren, kan det resultere i en genstartssløjfe.

Cause

Strømforsyningsproducenten leverede et bestemt antal strømforsyninger med beskadigede data i deres interne EEPROM. Disse beskadigede data påvirker ikke strømforsyningen, men det kan medføre, at den ugyldige streng med produkt-id vises, og det kan forårsage de ovenfor beskrevne firmwareopdateringsfejl.

Resolution

BEMÆRK:  Hvis en node fanges i en opstartssløjfe pga. dette problem, skal du fjerne den berørte strømforsyning. Noden starter normalt. Når noden er startet op, skal du geninstallere strømforsyningen for at gendanne redundans og anmode om en ny strømforsyning. Når den ankommer, skal du udskifte strømforsyningen efter den normale procedure. I Gen6 administreres begge strømforsyninger til et peer-node-par af noden i den odd-nummererede bås (1 og 3) for hvert par - hvis fjernelse af strømforsyningen fra en berørt node ikke afbryder opstartssløjfen, skal du geninstallere strømforsyningen, vente et par sekunder og derefter fjerne peer-nodens strømforsyning..

Hvis fejlen opstår under et sundhedstjek, skal du kontakte support.  Supporten afgør, om fejlen er en falsk positivmelding, der udløses af et ældre sundhedstjekscript, eller om der skal sendes en ny strømforsyning.  Hvis fejlen opstår på en PowerScale Hybrid- eller Archive-node (A300/A3000/H700/H7000), er dette en falsk positiv, da de berørte strømforsyninger ikke er blevet leveret med disse noder.

Additional Information

Trin 1: For at bruge scriptet til at kontrollere PSU'en på en ikke-tilsluttet node:

Trin 1: Forberedelse
– Sørg for, at nodens shell-konsol er tilgængelig. Hvis noden er forud for tilslutningen, skal du trykke på CTRL-C i konfigurationsguiden og derefter trykke på Enter for at bruge shell'en.
- Download scriptet fra linket ovenfor.
- Kopiere scriptet gen6_ps_check.py til et USB-drev; slutte drevet til noden.  Monter derefter drevet. 
 
BEMÆRK: Afhængigt af softwareversionen vises USB-drevet muligvis som da0s1 i stedet. Hvis det er tilfældet, skal du udskifte da0p1 med da0s1 i nedenstående kommando.
 
# mount_msdosfs /dev/da0p1 /mnt


Trin 2: Kør scriptet
 
# cd /mnt  
# python gen6_ps_check.py

- Scriptet udskriver resultatet som bestået eller mislykket, som i eksemplet ovenfor.

Trin 3: Afslut
– Frigør USB-drevet, og bring noden tilbage til guiden:  
 
# cd /   
# unmount /mnt
# reboot


Script-indstillinger:

- Sådan skifter du mellem flere linjer og mere detaljeret udskrivning:  
 
# python gen6_ps_check.py -v


- Sådan kontrolleres begge strømforsyningsenheder i et peer-par (én i den lokale node, én i peer-noden):  
 
# python gen6_ps_check.py -a

Affected Products

Isilon, Isilon Gen6
Article Properties
Article Number: 000057263
Article Type: Solution
Last Modified: 19 Dec 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.