Avamar:Avamar VMware 備份隨機失敗,並顯示錯誤:0237 無法建立線程 (11) 資源暫時不可用
Summary: Avamar VMware 備份隨機失敗,並顯示錯誤:0237 無法建立執行緒 (11) 升級至 Proxy 19.3 後,資源暫時無法使用。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- 使用代理部署管理員部署代理版本 19.3。
- 使用代理版本 19.3 時,隨機虛擬機器映像備份失敗,並顯示以下錯誤訊息:
[VcbImageBackupAssistThread] ERROR: <0237> Cannot create thread (11) Resource temporarily unavailable avvcbimage Info <43574>: vcApiVersion 6.5 avvcbimage Info <43575>: VSphereHTTP::vcVersion65 will be true avvcbimage Info <42137>: job type = 4 . avvcbimage Info <16041>: VDDK:VixDiskLib: Advanced transport plugin /usr/lib/vmware-vix-disklib/lib64/libdiskLibPlugin.so was successfully loaded into vixDiskLib. avvcbimage Info <16041>: VDDK:VixDiskLib: Enabling advanced transport modes. [VcbImageBackupAssistThread] ERROR: <0001> threadimpl::runthread Exception Resource temporarily unavailable avvcbimage Info <9772>: Starting graceful (staged) termination, MCS cancel (wrap-up stage)
Cause
- 代理工作計數超過為「TasksMax」設定的值 (512),即使在檔案「/etc/systemd/system/multi-user.target.wants/avagent.service」中將值設為「無窮大」,如下所示:
<Proxy_Name>:~ # less /etc/systemd/system/multi-user.target.wants/avagent.service . [Service] ExecStart=/etc/init.d/avagent start ExecStop=/etc/init.d/avagent stop KillMode=process Restart=on-abort RemainAfterExit=yes TasksMax=infinity - 此外,檢查服務「vami-sfcb.service」的工作計數時,會顯示正確的工作計數,如下所示:
<Proxy_Name>:~ # systemctl status vami-sfcb.service vami-sfcb.service - LSB: Small Footprint CIM Broker Service Loaded: loaded (/etc/init.d/vami-sfcb; disabled; vendor preset: disabled) Active: active (running) since <DAY> <yyyy-mm-dd hh:mm:ss UTC; # days ago Docs: man:systemd-sysv-generator(8) Tasks: 16 (limit: 512) CGroup: /system.slice/vami-sfcb.service 6873 /opt/vmware/sbin/vami-sfcbd -d 6878 /opt/vmware/sbin/vami-sfcbd -d 6882 /opt/vmware/sbin/vami-sfcbd -d 6883 /opt/vmware/sbin/vami-sfcbd -d 6892 /opt/vmware/sbin/vami-sfcbd -d 6901 /opt/vmware/sbin/vami-sfcbd -d 11366 /usr/local/avamarclient/bin/avagent.bin --listenport=28009... - 但是,當檢查「avagent.service」中的工作計數數位時,它會顯示「0」值,這表示它沒有正確計算任務,如下所示:
<Proxy_Name>:~ # systemctl status avagent.service avagent.service - Avamar Unix backup/restore agent (avagent) Loaded: loaded (/usr/lib/systemd/system/avagent.service; enabled; vendor preset: disabled) Active: active (exited) since <Day> <yyyy-mm-dd hh:mm:ss UTC; # ago Main PID: 1286 (code=exited, status=0/SUCCESS) Tasks: 0 CGroup: /system.slice/avagent.service 1476 /usr/local/avamarclient/bin/avagent.bin --listenport=28009 ...
Resolution
- 在代理上,確認檔案「/etc/systemd/system/multi-user.target.wants/avagent.service」中的「TasksMax」值已設為「infinity」,如下所示:
<Proxy_Name>:~ # less /etc/systemd/system/multi-user.target.wants/avagent.service . [Service] ExecStart=/etc/init.d/avagent start ExecStop=/etc/init.d/avagent stop KillMode=process Restart=on-abort RemainAfterExit=yes TasksMax=infinity - 啟用代理上的服務「vami-sfcb」,如下所示:
<Proxy_Name>:~ # systemctl enable vami-sfcb Synchronizing state of vami-sfcb.service with SysV init with /usr/lib/systemd/systemd-sysv-install... Executing /usr/lib/systemd/systemd-sysv-install enable vami-sfcb Created symlink from /etc/systemd/system/multi-user.target.wants/vami-sfcb.service to /usr/lib/systemd/system/vami-sfcb.service.
- 使用「reboot」命令將代理重新開機。
- 確認服務「avagent.service」顯示正確的工作計數,而不是 零 ,如下所示:
<Proxy_Name>:~ # systemctl status avagent.service avagent.service - Avamar Unix backup/restore agent (avagent) Loaded: loaded (/usr/lib/systemd/system/avagent.service; enabled; vendor preset: disabled) Active: active (exited) since <Day> <yyyy-mm-dd hh:mm:ss UTC; # ago Main PID: 1286 (code=exited, status=0/SUCCESS) Tasks: 16 CGroup: /system.slice/avagent.service 1476 /usr/local/avamarclient/bin/avagent.bin --listenport=28009 ...
Affected Products
AvamarProducts
Avamar, Avamar Client for VMwareArticle Properties
Article Number: 000173642
Article Type: Solution
Last Modified: 07 Nov 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.