PowerScale: L'elencazione degli oggetti del bucket S3 viene ripetuta all'infinito quando si utilizza l'API ListObjects

Summary: Il comando S3 App o S3 utilizza l'API S3 listobject o listobjectv2 per eseguire query sugli oggetti dal bucket S3. In alcuni casi, PowerScale OneFS S3 restituisce il risultato errato se dirCache è presente ma non soddisfa la richiesta. L'app S3 smette di rispondere a causa di un ciclo infinito degli oggetti elenco. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

L'app S3 smette di rispondere a causa dell'elenco di un bucket non completato.

Comando S3 ls ottiene ripetutamente gli stessi oggetti restituiti in un elenco impaginato.

Cause

È possibile che si verifichi un problema della cache S3. 
 
Se il client richiede ListObjects Con max entry = 1000, internamente possiamo ottenere 10.000 voci (se la directory è ampia) ma restituirne solo 1000 al client, quindi riutilizzare le restanti 9000 per una richiesta futura. Nella richiesta successiva, se è presente una cache e nella directory sono ancora presenti file che non vengono ancora restituiti al client e la cache corrente non dispone di voci sufficienti per soddisfare la richiesta, si verifica il problema e vengono restituiti risultati errati.

Resolution

Dell Engineering sta lavorando a una risoluzione permanente del problema. È previsto il rilascio

di una patch cumulativa (RUP).La soluzione alternativa corrente consiste nel configurare S3 ls DIR_CACHE_TTL a 0 temporaneamente:
# isi_for_array -X  "/usr/likewise/bin/lwsm inject s3 s3_ls_set_dir_cache_ttl on 0"
Se il processo S3 o un nodo si riavvia, applicare nuovamente la soluzione alternativa al nodo poiché è stato ripristinato il valore predefinito di 1 ora al riavvio di S3.

Al manuale DIR_CACHE_TTL:
#isi_for_array -X  "/usr/likewise/bin/lwsm inject s3 s3_ls_set_dir_cache_ttl off"

Affected Products

Isilon, PowerScale
Article Properties
Article Number: 000223936
Article Type: Solution
Last Modified: 07 Apr 2026
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.