vProxy: Los respaldos de VM de NVP fallan con: "No se puede abrir la sesión en el dispositivo de destino \"DD_HOSTNAME\."""

Summary: La actualización a la versión más reciente del vProxy hace que los respaldos fallen con el siguiente error: "Falla", "Descripción": "El respaldo falló: No se puede abrir la sesión en el dispositivo de destino \"DD_HOSTNAME\."" ...

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Symptoms

Los respaldos de VM de NetWorker VMware Protection (NVP) fallan.

El valor de /opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE/vbackupd-session del vProxy.log

2025-01-15T14:45:46Z INFO: "State": "Failure",
2025-01-15T14:45:46Z INFO: "Description": "Backup has failed: Backup has FAILED. Unable to open session to target device \"DD_HOSTNAME\".",
2025-01-15T14:45:46Z INFO: "Progress": 0,
2025-01-15T14:45:46Z INFO: "Error": {
2025-01-15T14:45:46Z INFO: "Text": "Backup has FAILED. Unable to open session to target device \"DD_HOSTNAME\".",

/opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log del vProxy

2025-01-15T02:05:52Z ERROR: [ 5920:140027409463040] ddp_connect_with_config_internal() failed, Hostname: DD_HOSTNAME, Err: 5040-RPC procedure=SYSTEM_INFO failed, Can't connect to NFS server retval=5
2025-01-15T02:05:52Z ERROR: [ 5920:140027409463040] ddp_connect_with_config() failed, Hostname: DD_HOSTNAME, Err: 5040-RPC procedure=SYSTEM_INFO failed, Can't connect to NFS server retval=5

Cause

La causa raíz de la falla del respaldo es la configuración incorrecta del archivo /etc/hosts del vProxy.

Por ejemplo, se agregó la IP de administración de Data Domain 10.130.102.176 al archivo /etc/hosts en el vProxy, lo que causó la falla del respaldo.

El entorno tiene un grupo de interfaces personalizado configurado en la interfaz de usuario de Data Domain en DD Boost - IP Network.

Imagen agregada por el usuario
El host vProxy está configurado para utilizar un grupo de interfaces diferente en Data Domain. 

Resolution

Para resolver el problema de falla de respaldo, siga estos pasos:
  1. Inicie sesión en la interfaz de usuario de DD.
  2. Vaya a Protocols ->DD Boost ->IP Network.
  3. Compruebe el campo Configured Clients para confirmar qué grupo de interfaces está configurado para usar el vProxy.
  4. Compruebe el campo Grupos de interfaces para ver qué direcciones IP están asignadas al grupo de interfaces.
  5. Actualice la configuración del archivo /etc/hosts del vProxy para utilizar la IP correcta.
  6. Realice un respaldo de VM y verifique que el respaldo se realice correctamente.
NOTA: Se recomienda utilizar la IP de grupo de interfaces correcta para evitar problemas de conectividad con Data Domain.
Article Properties
Article Number: 000272927
Article Type: Solution
Last Modified: 16 Jan 2025
Version:  1
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