NetWorker: backups to CloudBoost are aborted by CONNECTION_DISCONNECTED error
Summary: Randomly backup done using CloudBoost devices are aborted with the common error CONNECTION_DISCONNECTED.
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Symptoms
NetWorker backups are configured to go to a CloudBoost device. The NetWorker Storage Node performing the write operation observes a CONNECTION_DISCONNECTED error:
The error appears on the save process at the storage node, but is the Storage Node nsrmmd daemon reports the following:
MM/DD/YYYY HH:mm:SS nsrmmd SYSTEM critical Unable to write to a file: CONNECTION_DISCONNECTED MM/DD/YYYY HH:mm:SS nsrmmd SYSTEM error Cannot write to base/NW_DEVICE_NAME/##/##/LONG_SSID - errno No error. MM/DD/YYYY HH:mm:SS nsrmmd SYSTEM critical Unable to write buffer to disk for ssid=SSID: Failed opening file / directory base/NW_DEVICE_NAME/##/##/LONG_SSID: Magfs SDK returned: CONNECTION_DISCONNECTED. MM/DD/YYYY HH:mm:SS nsrmmd NSR warning Unable to close or sync file for ssid=SSID: Failed to get fd for ssid=SSID to sync/close file MM/DD/YYYY HH:mm:SS nsrmmd SYSTEM critical Unable to remove SSID file 'base/NW_DEVICE_NAME/##/##/LONG_SSID' on device 'rd=storagenode:base/NW_DEVICE_NAME': Unable to stat save set file 'base/NW_DEVICE_NAME/##/##/LONG_SSID': Unable to retrieve the file statistics: CONNECTION_DISCONNECTED MM/DD/YYYY HH:mm:SS nsrmmd NSR error MM/DD/YY HH:mm:SS nsrmmd #5: save set \\NAS_FILER\CIFS_SHARE$\~snapshot\backup.0 for client nw_client_NAS was aborted and removed from volume VOLUME_NAME MM/DD/YYYY HH:mm:SS nsrsnmd SYSTEM notice nw_cbcl_disconnect: Mount handle is NULL.
Similar errors are found in the NetWorker server and storage node's daemon.raw:
- Linux:
/nsr/logs/daemon.raw - Windows (Default):
C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw - NetWorker: How to use nsr_render_log to render .raw log files
Cause
- The
nsrmmddaemon on the storage node reaches the internal timeout for a write operation. - This error is because the CloudBoost appliance has a high number of requests at the time the issue was observed, this added load caused the
nsrmmdconnection to timeout.
Resolution
- On the NetWorker storage node used for the CloudBoost devices, create a file called
nsrcbconfig(no extension) in the following path:
- Linux:
/nsr/debug - Windows (default):
C:\Program Files\EMC NetWorker\nsr\debug
- Add the following contents to the file:
curlConnectTimeout=40000 nwTimeoutSecs=600 echoInterval=15000
- Save the file.
- Restart NetWorker services on the NetWorker storage node:
- Linux:
systemctl restart networker - Windows (PowerShell):
net stop nsrexecd /y ; net start nsrexecd- If the Windows NetWorker storage node is also the NetWorker server, run:
net start nsrd - If the Windows NetWorker storage node is also the NetWorker Management Console (NMC) server, run:
net start gstd
- If the Windows NetWorker storage node is also the NetWorker server, run:
Additional Information
Affected Products
CloudBoost, NetWorkerProducts
NetWorker SeriesArticle Properties
Article Number: 000043752
Article Type: Solution
Last Modified: 08 Jan 2026
Version: 4
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