Data Protection Advisor: Agent kan zich niet registreren bij de server

Summary: Data Protection Agent (DPA) kan zich niet registreren bij de Data Protection Application-server (DPA APP) vanwege de HTTP-proxy-instelling (Hyper-Text Transfer Protocol), wat resulteert in de CURL-fout (Communication Url) [56] en HTTP-code (Hyper-Text Transfer Protocol) 403. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Agent wordt niet weergegeven in de gebruikersinterface onder Data Collection>Agents, ook al is de agent geïnstalleerd.

Als de agent is ingesteld om fouten op te sporen, vindt u de volgende weergaven in het agentlogboek:
 

DBG1    18535.18535    20170628:142552             com.http - httpSendRequest(): CURL error: [56] Received HTTP code 403 from proxy after CONNECT
ERR     18535.18535    20170628:142552         agent.config - initAgentConfig(): Failed to register agent with the server. Waiting to retry...


 

Cause

Dit probleem wordt veroorzaakt door een http-proxy-instelling, waardoor de DPA APP-server het registratieverzoek voor een agent weigert bij het maken van een verbinding.

Resolution

Meld u als root aan bij de DPA-agentserver en doe het volgende:

Beëindig de DPA-agentservice met de volgende opdracht:

/opt/emc/dpa/agent/etc/dpa stop


Bewerk het dpa.custom-bestand in de <directory DPA-installatiemap>/dpa/agent/etc en voeg de volgende twee regels toe:
 

export http_proxy=
export https_proxy=
 
De bovenstaande twee regels moeten precies zo worden gemaakt als hierboven, zonder verdere tekens buiten de =.


Sla de wijzigingen op en start de agentservice opnieuw. De agent zou zich nu moeten registreren, omdat de nieuwe vermeldingen in het bestand dpa.custom de http- of https-proxy-instellingen op besturingssysteemniveau uitschakelen. 

Neem contact op met de technische support van Dell voor meer informatie.

 

Products

Data Protection Advisor
Article Properties
Article Number: 000065495
Article Type: Solution
Last Modified: 24 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.