VNX: Filsystemsløyfe oppdaget når du kjører "finn" på kontrollstasjonen

Summary: VNX: Filsystemsløyfen oppdaget når du kjører "finn" på kontrollstasjonen.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Brukeren kjører find -kommandoen på kontrollstasjonen når du leter etter en fil i et filsystem montert på dataflytteren.

Brukeren mottar feilmeldingen "Filesystem loop detected" når linux kjøres find Kommando som root-bruker fra rotkatalogen "/" i kontrollstasjonen for å prøve å søke etter en fil.

»find: Filesystem loop detected; `/nasmcd/quota/slot_7/fs03group61/mail/61'" har samme enhetsnummer og inode som en katalog som er tre nivåer høyere i filsystemhierarkiet.

Informasjonen i find Kommandoen slutter å svare når den kjøres på kontrollstasjonen.

 

Cause

Når du bruker find kommando på en VNX- eller Celerra-kontrollstasjon fra som rotbruker fra rotkatalogen "/", find Søker i hele systemet etter det angitte nøkkelordet. Dette inkluderer alle kundens filsystemer montert på dataflytterne (f.eks. "/nas/quota/slot_2/fs_name/"). Fordi kontrollstasjonskatalogstrukturen er et annet fysisk filsystem enn kundefilsystemene som er montert på dataflytteren. Hvert av disse to filsystemene kan dele de samme inodenumrene.

Når find Kommandoen oppdager det samme inodenummeret fra en tidligere katalog som den allerede har søkt i. Feilen vises og kommandoen kan slutte å svare.
Fordi katalogstrukturen for kontrollstasjonen og kundekatalogstrukturen er på separate fysiske filsystemer i dette scenariet, kan feilen ignoreres.

Ved å bruke kommandoen "ls -ial" kan vi sjekke inoden # mellom de to forskjellige filsystemene og bekrefte at inodenumrene er dupliserte.
I eksemplet nedenfor vises inoden # i venstre kolonne i "ls -ial"- utdataene.

Eksempel:

[root@VNX001 /]# find / -name rpt_file
/nasmcd/quota/slot_7/fs03install/.etc/rpt_file
/nasmcd/quota/slot_7/fs03db99/.etc/rpt_file
/nasmcd/quota/slot_7/fs03sub/.etc/rpt_file
/nasmcd/quota/slot_7/fs03audit/.etc/rpt_file
/nasmcd/quota/slot_7/fs03group99/.etc/rpt_file    <<<<<Filesystem loop detected here

»find: Filesystem loop detected; `/nasmcd/quota/slot_7/fs03group61/dir/99'" har samme enhetsnummer og inode som en katalog som er tre nivåer høyere i filsystemhierarkiet.

Legg merke til at sammenligning av katalogstrukturene 3 nivåer opp, de to filene kalt "." og "99" deler samme inode #.

[root@VNX001 slot_7]# ls -ial /nasmcd/quota/slot_7/
total 552
                   2 drwxr-xr-x  37 root root  2048 Aug 10  2015 .   <<<inode # is 2
                5695 drwxr-xr-x  17 root root     0 Jul 15 01:00 ..
                   4 dr-xr-xr-x  13 root bin   2048 Apr 16  2015 .etc
18446744071562067968 drwxr-xr-x   6 root root  1024 Sep  8  2013 .etc_common
                   3 drwxr-xr-x   2 root root  8192 Sep  8  2013 lost+found
....(output omitted)....
[root@VNX001 slot_7]#

[root@VNX001 slot_7]# ls -ial /nasmcd/quota/slot_7/fs03group99/mail/      <<<Note different directory
total 2448
   75 drwxrwx--- 102 103 101  4096 Oct 10  2013 .
   95 drwxrwx---   7 103 101  1024 Sep 12  2013 ..
....(output ommited)...
    2 drwxrwx--- 301 103 101 25600 Jul 26 20:24 99    <<<inode # is 2
....(output ommited)...
[root@VNX001 slot_7]#

 

Resolution

Dette er ikke et problem med brudd/løsning. Feilen som rapporteres er den forventede virkemåten til kommandoen. Control Station har tilgang til de monterte data mover-filsystemene under /nas/quota/, slik at find Kommandoen kan finne en inode loop som det er forskjellige filsystemer montert.

Mens du kjører find Kommandoen forstyrrer ikke produksjonsmiljøet. Det anbefales ikke å kjøre kommandoroten på katalognivået "/" eller "/nas" på kontrollstasjonen.

 

Affected Products

VNX1 Series

Products

Celerra, VNX VG10, VNX VG2, VNX VG50, VNX VG8, VNX1 Series, VNX2 Series
Article Properties
Article Number: 000052326
Article Type: Solution
Last Modified: 20 Oct 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.