Cliente Avamar: El respaldo de la imagen del cliente Linux de IDPA se completa con excepción debido a un problema de reposo

Summary: Los clientes de respaldo de imágenes de Linux fallan con el respaldo completado con excepción del código de error 10020

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Symptoms

El respaldo de imagen de Linux para el sistema IDPA "Se completa con excepción" debido al problema de modo de reposo.

En este ejemplo, la VM era la VM interna de ACM que viene con la solución IDPA.

En el registro de imagen de Linux de VMware del respaldo, se puede ver lo siguiente:

avvcbimage Info <40726>: VM Config Info: VMX version 4(F), ctk enabled(T), fault tolerant (F), Guest OS SUSE Linux Enterprise 12 (64-bit), Cloud UUID = NoUUID. version=9
avvcbimage Info <40727>: VM Guest Info: GuestOS Family = linuxGuest, Guest Full Name = SUSE Linux Enterprise 12 (64-bit), Guest OS State = running, Tools Running = guestToolsRunning,  Tools Version Status = guestToolsUnmanaged
avvcbimage Info <42650>: Creating snapshot 'Avamar-<epoch_time><client_id>', quiesceFS=1
avvcbimage Info <41136>: SnapshotManager: createSnapshot for vmMoref = vm-21
avvcbimage Info <42182>: SnapshotManager: POST to /snapshotmanager/vm/vm-21/action/createSnapshot, payload({
  "snapshotName": "Avamar-<epoch_time><client_id>",
  "snapshotDesc": "Created by Avamar workorder Management_VM_Backup-Management_VM_Backup-<epoch >  on <date>",
  "quiesceFileSystem": "true"
...
avvcbimage Warning <19733>: vSphere Task failed (quiesce, snapshot error=45): 'An error occurred while saving the snapshot: Failed to quiesce the virtual machine.'.
avvcbimage Error <17775>: Snapshot 'Avamar-<epoch_time><client_id> ' creation for VM '[vsanDatastore] DataProtection-ACM/DataProtection-ACM.vmx' task creation encountered a quiesce problem
avvcbimage Warning <40710>: The VM could not be quiesced prior to snapshot creation and this backup will not be used as a base for subsequent CBT backups if successful.
avvcbimage Warning <40711>:     Consider using the pre-freeze and post-thaw scripts to facilitate VM quiescing
avvcbimage Warning <41146>:     This error might caused by the pre-freeze script returning a non-zero error code.
...

Después de que falla la tarea de la primera instantánea, el respaldo continúa tomando una segunda instantánea, pero con la característica de reposo deshabilitada.

avvcbimage Info <14631>: VM Disk Consolidation for '[vsanDatastore] DataProtection-ACM/DataProtection-ACM.vmx' task still in progress, sleep for 3 sec
avvcbimage Info <42650>: Creating snapshot 'Avamar-<epoch_time><client_id>', quiesceFS=0
avvcbimage Info <41136>: SnapshotManager: createSnapshot for vmMoref = vm-21
avvcbimage Info <42182>: SnapshotManager: POST to /snapshotmanager/vm/vm-21/action/createSnapshot, payload({
  "snapshotName": "Avamar-<epoch_time><client_id>",
  "snapshotDesc": "Created by Avamar workorder Management_VM_Backup-Management_VM_Backup-<epoch> on <date>",
  "quiesceFileSystem": "false"

El respaldo finaliza, pero se muestra como completado con excepción (código 10020)

En el registro de órdenes de trabajo (.alg), se ve lo siguiente:

2019-04-03 00:12:42 Management_VM_Backup-Management_VM_Backup-<epoch>Warning <0000>: Workorder "Management_VM_Backup-Management_VM_Backup-epoch" non-zero exit status 'code 170: completed with errors, client log should be examined'

 

Cause

  1. Para ver qué está causando que falle el modo de reposo, configure el registro de depuración para vmtools.
    Los siguientes pasos en https://kb.vmware.com/s/article/1007873Este hipervínculo lo redirige a un sitio web fuera de Dell Technologies. configurar el registro de depuración en el sistema operativo huésped y, a continuación, reiniciar VMware Tools.

  2. Realice un nuevo respaldo para volver a crear la falla de reposo.

  3. Revise los registros de las herramientas de depuración (la información de reposo debe estar en el registro de vmsvc y tener un prefijo [vmbackup]).

En este ejemplo, el problema se debió a un directorio /var/log/brs parcialmente eliminado. Este directorio no se pudo eliminar por completo debido a que el proceso en segundo plano aún tenía el directorio abierto. Esta carpeta parcialmente eliminada evita que el sistema de archivos de Linux deje de responder con las funciones ioctls.

[   debug] [vmbackup] Submitted backup start task.
[   debug] [vmbackup] *** VmBackupSyncDriverStart
[   debug] [vmsvc] SyncDriver: Skipping remote filesystem, name=systemd-1, mntpt=/proc/sys/fs/binfmt_misc.
[   debug] [vmsvc] SyncDriver: Calling backend 0.
[   debug] [vmsvc] SyncDriver: Freezing using Linux ioctls...
[   debug] [vmsvc] SyncDriver: opening path '/var/lib/named/proc'.
[   debug] [vmsvc] SyncDriver: freezing path '/var/lib/named/proc'.
[   debug] [vmsvc] SyncDriver: freeze on '/var/lib/named/proc' returned: 95 (Operation not supported)
[   debug] [vmsvc] SyncDriver: opening path '/var/log/logbundles'.
[   debug] [vmsvc] SyncDriver: freezing path '/var/log/logbundles'.
[   debug] [vmsvc] SyncDriver: successfully froze '/var/log/logbundles'.
[   debug] [vmsvc] SyncDriver: opening path '/var/log/brs (deleted)'.
[   debug] [vmsvc] SyncDriver: failed to open '/var/log/brs (deleted)': 2 (No such file or directory)
[ warning] [vmbackup] Error freezing filesystems.

 

Resolution

Un examen más detallado de /var/log/brs en el directorio con puede ver problemas para abrir este directorio desde otros comandos. Al igual que lsof y stat también muestran el problema.

IDPA-ACM:/var/log # lsof|grep brs
lsof: WARNING: can't stat() xfs file system /var/log/brs (deleted)
      Output information may be incomplete.

IDPA-ACM:/var/log # ls -al
drwxr-xr-x 0 root     root            6 Feb 27  2018 brs

La máquina virtual de ACM se reinició para interrumpir el proceso de ACM en segundo plano. Después del reinicio, el proceso de ACM volvió a crear el directorio /var/log/brs y el respaldo pudo completarse sin más problemas de reposo.

IDPA-ACM:/var/log # ls -al
drwxr-xr-x 2 root     root            6 Apr 15 10:30 brs

 

Additional Information

Asegúrese de seguir el artículo de la base de conocimientos anterior para eliminar el registro de depuración de vmtools en el cliente y reinicie el servicio vmtools.

 

Affected Products

Avamar Client

Products

Avamar Client, PowerProtect Data Protection Software
Article Properties
Article Number: 000056249
Article Type: Solution
Last Modified: 27 May 2026
Version:  5
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