Avamar Client: Back-up van IDPA Linux client image voltooid met uitzondering van slaapprobleem

Summary: Back-up van Linux-image Clients mislukken met back-up voltooid met uitzondering Foutcode 10020

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

De back-up van de Linux-image voor het IDPA-systeem is "Completing with Exception" vanwege het onderbrekingsprobleem.

In dit voorbeeld was de vm de interne ACM-vm die bij de IDPA-oplossing wordt geleverd.

In het VMware Linux image log van de back-up kan het volgende worden gezien:

avvcbimage Info <40726>: VM Config Info: VMX version 4(F), ctk enabled(T), fault tolerant (F), Guest OS SUSE Linux Enterprise 12 (64-bit), Cloud UUID = NoUUID. version=9
avvcbimage Info <40727>: VM Guest Info: GuestOS Family = linuxGuest, Guest Full Name = SUSE Linux Enterprise 12 (64-bit), Guest OS State = running, Tools Running = guestToolsRunning,  Tools Version Status = guestToolsUnmanaged
avvcbimage Info <42650>: Creating snapshot 'Avamar-<epoch_time><client_id>', quiesceFS=1
avvcbimage Info <41136>: SnapshotManager: createSnapshot for vmMoref = vm-21
avvcbimage Info <42182>: SnapshotManager: POST to /snapshotmanager/vm/vm-21/action/createSnapshot, payload({
  "snapshotName": "Avamar-<epoch_time><client_id>",
  "snapshotDesc": "Created by Avamar workorder Management_VM_Backup-Management_VM_Backup-<epoch >  on <date>",
  "quiesceFileSystem": "true"
...
avvcbimage Warning <19733>: vSphere Task failed (quiesce, snapshot error=45): 'An error occurred while saving the snapshot: Failed to quiesce the virtual machine.'.
avvcbimage Error <17775>: Snapshot 'Avamar-<epoch_time><client_id> ' creation for VM '[vsanDatastore] DataProtection-ACM/DataProtection-ACM.vmx' task creation encountered a quiesce problem
avvcbimage Warning <40710>: The VM could not be quiesced prior to snapshot creation and this backup will not be used as a base for subsequent CBT backups if successful.
avvcbimage Warning <40711>:     Consider using the pre-freeze and post-thaw scripts to facilitate VM quiescing
avvcbimage Warning <41146>:     This error might caused by the pre-freeze script returning a non-zero error code.
...

Nadat de eerste snapshottaak mislukt, gaat de back-up verder door een tweede snapshot te maken, maar met de rustfunctie uitgeschakeld.

avvcbimage Info <14631>: VM Disk Consolidation for '[vsanDatastore] DataProtection-ACM/DataProtection-ACM.vmx' task still in progress, sleep for 3 sec
avvcbimage Info <42650>: Creating snapshot 'Avamar-<epoch_time><client_id>', quiesceFS=0
avvcbimage Info <41136>: SnapshotManager: createSnapshot for vmMoref = vm-21
avvcbimage Info <42182>: SnapshotManager: POST to /snapshotmanager/vm/vm-21/action/createSnapshot, payload({
  "snapshotName": "Avamar-<epoch_time><client_id>",
  "snapshotDesc": "Created by Avamar workorder Management_VM_Backup-Management_VM_Backup-<epoch> on <date>",
  "quiesceFileSystem": "false"

De back-up wordt voltooid, maar wordt weergegeven als voltooid met uitzondering (code 10020)

In het werkorderlogboek (.alg) is het volgende te zien:

2019-04-03 00:12:42 Management_VM_Backup-Management_VM_Backup-<epoch>Warning <0000>: Workorder "Management_VM_Backup-Management_VM_Backup-epoch" non-zero exit status 'code 170: completed with errors, client log should be examined'

 

Cause

  1. Om te zien waardoor de quiescing mislukt, stelt u de debug logging voor de vmtools in.
    Volg de stappen in https://kb.vmware.com/s/article/1007873Deze hyperlink leidt u naar een website buiten Dell Technologies. om de logboekregistratie voor foutopsporing in te stellen op het gastbesturingssysteem en start vervolgens VMware-tools opnieuw.

  2. Maak een nieuwe back-up om de rustfout opnieuw te maken.

  3. Controleer de logboeken van de hulpprogramma's voor foutopsporing (de benodigde informatie moet in het vmsvc-logboek staan en een voorvoegsel [vmbackup] hebben).

In dit voorbeeld werd het probleem veroorzaakt door een gedeeltelijk verwijderde /var/log/brs-directory. Deze map kon niet volledig worden verwijderd vanwege het achtergrondproces waarin de map nog steeds open stond. Deze gedeeltelijk verwijderde map voorkomt dat het Linux-bestandssysteem niet meer reageert met ioctls-functies.

[   debug] [vmbackup] Submitted backup start task.
[   debug] [vmbackup] *** VmBackupSyncDriverStart
[   debug] [vmsvc] SyncDriver: Skipping remote filesystem, name=systemd-1, mntpt=/proc/sys/fs/binfmt_misc.
[   debug] [vmsvc] SyncDriver: Calling backend 0.
[   debug] [vmsvc] SyncDriver: Freezing using Linux ioctls...
[   debug] [vmsvc] SyncDriver: opening path '/var/lib/named/proc'.
[   debug] [vmsvc] SyncDriver: freezing path '/var/lib/named/proc'.
[   debug] [vmsvc] SyncDriver: freeze on '/var/lib/named/proc' returned: 95 (Operation not supported)
[   debug] [vmsvc] SyncDriver: opening path '/var/log/logbundles'.
[   debug] [vmsvc] SyncDriver: freezing path '/var/log/logbundles'.
[   debug] [vmsvc] SyncDriver: successfully froze '/var/log/logbundles'.
[   debug] [vmsvc] SyncDriver: opening path '/var/log/brs (deleted)'.
[   debug] [vmsvc] SyncDriver: failed to open '/var/log/brs (deleted)': 2 (No such file or directory)
[ warning] [vmbackup] Error freezing filesystems.

 

Resolution

Bij nadere bestudering van de /var/log/brs waarmee de directory wordt geconfronteerd, kunnen problemen ontstaan bij het openen van deze directory via andere opdrachten. Zoals lsof en stat ook een probleem laten zien.

IDPA-ACM:/var/log # lsof|grep brs
lsof: WARNING: can't stat() xfs file system /var/log/brs (deleted)
      Output information may be incomplete.

IDPA-ACM:/var/log # ls -al
drwxr-xr-x 0 root     root            6 Feb 27  2018 brs

De ACM Virtual Machine is opnieuw opgestart om het ACM-achtergrondproces te beëindigen. Na het opnieuw opstarten werd de /var/log/brs-directory opnieuw gemaakt door het ACM-proces en kon de back-up zonder verdere problemen worden voltooid.

IDPA-ACM:/var/log # ls -al
drwxr-xr-x 2 root     root            6 Apr 15 10:30 brs

 

Additional Information

Zorg ervoor dat u de bovenstaande KB volgt om logboekregistratie voor foutopsporing voor de vmtools op de client te verwijderen en de vmtools-service opnieuw op te starten.

 

Affected Products

Avamar Client

Products

Avamar Client, PowerProtect Data Protection Software
Article Properties
Article Number: 000056249
Article Type: Solution
Last Modified: 27 May 2026
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.