Avamar:由于巨型 MTU,备份在大约 4.3 MB 时停滞 - 将 MTU 与 1500 对齐以解决问题

Summary: Linux 客户端上的 Avamar 备份在 ~4.3 MB 处停止,没有任何错误。客户端的最大传输单位 (MTU) 设置为 5000(巨型数据包),而其他节点使用标准 MTU 1500 会导致该问题。将客户端 MTU 重置为 1500 可解决此问题。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

观察到的备份行为。

在 Linux 客户端上执行备份作期间,观察到以下症状:

  • 备份将启动并在短时间内按预期运行。
  • 进度前进到大约 4.3 MB,然后停止。
  • 备份停滞时不显示任何错误消息。
  • 如果备份取消,显示的进度会略微增加到约 5 MB,但仍然没有错误。

Cause

网络 MTU 不匹配会导致备份停滞。

备份过程已停止,因为客户端系统配置了用于巨型数据包的最大传输单元 (MTU) 大小 (MTU=5000)。环境中的所有其他系统都使用标准以太网 MTU 1500

此差异会导致数据包碎片化或丢失,从而阻止 Avamar Client 传输超过大约 4 MB 进度的数据。

  • 客户端 MTU 设置为 5000 字节(巨型帧)。
  • 对等系统 MTU 设置为默认的 1500 字节。
  • MTU 大小不兼容导致数据传输期间通信失败。
  • 未生成任何错误消息;备份停止进行。

Resolution

在具有问题以匹配其他系统的客户端上设置 MTU 可解决此问题。
 

调整 MTU 以匹配网络标准。

分步指南

  1. 识别 Avamar Client 使用的网络接口
# List network interfaces
$ ip link show
  1. 验证接口的当前 MTU
$ ip link show dev eth0 | grep mtu
  1. 将 MTU 值更改为标准大小 (1500):
# Set MTU temporarily
$ sudo ip link set dev eth0 mtu 1500

# Verify the change
$ ip link show dev eth0 | grep mtu
  1. 使 MTU 更改 在重新启动后持续存在:
    1. 在 Red Hat Enterprise Linux/CentOS 上,编辑 /etc/sysconfig/network-scripts/ifcfg-eth0添加或修改行 MTU=1500
    2. 在 Ubuntu/Debian 上,编辑 NetPlan YAML 文件 (/etc/netplan/01-netcfg.yaml) 并 添加 mtu: 1500 在相应的接口定义下,或 编辑 /etc/network/interfaces 并添加 mtu 1500
    3. 重新启动网络服务 或重新引导主机以应用持久设置。
# Restart network (RHEL/CentOS)
$ sudo systemctl restart network

# Apply Netplan changes (Ubuntu)
$ sudo netplan apply
 

验证

  1. 运行新的 Avamar 备份。作业的进展现在应超过之前的 4.3 MB 停滞。
# Check Avamar client status
$ avtar -status
  1. 确认 备份按预期完成。
 
注意:不正确的 MTU 设置可能会导致数据包丢失或连接问题。如果您不确定,请在做出更改之前联系 戴尔支持

注意:缩短 MTU 可能会影响依赖巨型帧的应用程序。在更改后测试网络性能。

提醒:如果您的环境需要巨型帧,请确保所有交换机、路由器和主机使用相同的 MTU 值。

Affected Products

Avamar

Products

Avamar, Avamar Plug-in for NDMP
Article Properties
Article Number: 000061962
Article Type: Solution
Last Modified: 22 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.