Avamar: Virhe 52001 (tietoliikennemoduulin skannerivirhe), joka johtuu käytöstä poistetun kytkimen Telnet-palvelimen vuoksi

Summary: Avamar Gen5A -järjestelmä ilmoittaa tietoliikennemoduulin skannerivirheestä, joka johtuu Dell S4128F-ON -kytkimen Telnet-palvelimen käytöstä poistamisesta.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Seuraava virhe ilmoitetaan Avamar-käyttöliittymässä, ja se näkyy myös suoritettaessa alla olevaa mccli-komentoa:

admin@avamar:~/>: mccli event show --unack
0,23000,CLI command completed successfully.
ID   Date                    Type  Code  Category Severity Domain Summary
---- ----------------------- ----- ----- -------- -------- ------ -----------------------------------
...
2381 2025-10-08 10:22:48 AST ERROR 52001 SYSTEM   PROCESS  /      Communications Module Scanner Error

Avamar-apusolmun switch_monitoring lokissa näkyvät vain seuraavat merkinnät, jotka toistuvat:

admin@avamar:~/>: tail -50 /usr/local/avamar/var/log/switch_monitoring.log
...
2025/10/01-09:28:09 INFO: simulating error codes =
2025/10/01-09:28:12 INFO: publish() cmd="mccli event publish --code=52001 " successful
2025/10/01-09:49:48 INFO: simulating error codes =
2025/10/01-09:49:51 INFO: publish() cmd="mccli event publish --code=52001 " successful
2025/10/01-10:43:01 INFO: simulating error codes =
2025/10/01-10:43:04 INFO: publish() cmd="mccli event publish --code=52001 " successful

Jos sisäisiin kytkimiin yritetään muodostaa yhteys Telnetin avulla, näyttöön tulee viesti yhteyden estämisestä.

Huomautus: Kytkimen A IP-osoite on tavallisesti 192.168.255.200 ja kytkin B on 192.168.255.201. Kytkimen IP-osoitteet voivat kuitenkin poiketa tästä järjestelmän kokoonpanon mukaan. Kytkimen IP-osoitteiden keräysohjeet ovat tämän artikkelin Tarkkuus-osassa.
admin@avamar:~/>: telnet 192.168.255.200
Trying 192.168.255.200...
telnet: connect to address 192.168.255.200: Connection refused
admin@avamar:~/>: telnet 192.168.255.201
Trying 192.168.255.201...
telnet: connect to address 192.168.255.201: Connection refused
admin@avamar:~/>:

Yhteyden muodostaminen sisäisiin kytkimiin ssh:lla onnistui.


  
admin@avamar:~/>: ssh admin@192.168.255.200
Debian GNU/Linux 10

Dell SmartFabric OS10 Enterprise
admin@192.168.255.200's password:
...
admin@avamar:~/>: ssh admin@192.168.255.201
Debian GNU/Linux 10

Dell SmartFabric OS10 Enterprise
admin@192.168.255.201's password:
...

Cause

Avamar Dell S4128F-ON -sisäisten kytkimien Telnet-palvelin on poissa käytöstä.

Resolution

  1. Kirjaudu Avamar-apusolmuun, jota ongelma koskee, admin-käyttäjänä ssh:n avulla.
  2. Vahvista kytkimen IP-osoitteet suorittamalla seuraava komento:
    nodedb print | grep -A1 "switch id"
  3. Hae kytkimen salasana järjestelmän Lockboxista suorittamalla seuraava komento:
    avlockbox.sh -r switch-A-password
  4. Muodosta yhteys ensimmäiseen kytkimeen (kytkin A) järjestelmänvalvojakäyttäjänä ssh:lla. Käytä kytkimen A IP-osoitetta, joka on kerätty vaiheessa 2, ja vaiheessa 3 kerättyä salasanaa.
    admin@avamar:~/>: ssh admin@192.168.255.200
    Debian GNU/Linux 10
    
    Dell SmartFabric OS10 Enterprise
    admin@192.168.255.200's password:
    ...
    dell-swa#
  5. Ota Telnet-palvelin käyttöön suorittamalla seuraavat komennot ja katkaise sitten yhteys kytkimeen:
    dell-swa# configure
    dell-swa(config)# ip telnet server enable
    dell-swa(config)# exit
  6. Muodosta yhteys toiseen kytkimeen (kytkimeen B) järjestelmänvalvojakäyttäjänä ssh:lla ja toista vaihe 3. Käytä kytkimen B IP-osoitetta, joka kerättiin vaiheessa 2, ja vaiheessa 3 kerättyä salasanaa.
    admin@avamar:~/>: ssh admin@192.168.255.201
    Debian GNU/Linux 10
    
    Dell SmartFabric OS10 Enterprise
    admin@192.168.255.201's password:
    ...
    dell-swb# configure
    dell-swb(config)# ip telnet server enable
    dell-swb(config)# exit

Additional Information

Seuraavassa tietämyskannan artikkelissa on telnet-/ssh-yhteyden käyttöönoton tai poistamisen yksityiskohtaiset ohjeet, jotka koskevat kaikkia kytkimiä, joissa on Dell SmartFabric OS10 -käyttöjärjestelmä:
Dell EMC Networking OS10 -kytkimet Telnetin/SSH:n ottaminen käyttöön tai poistaminen käytöstä

Affected Products

Avamar, Avamar Data Store, Avamar Data Store Gen5A, Avamar Server
Article Properties
Article Number: 000400243
Article Type: Solution
Last Modified: 05 Dec 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.